2000T issue

waterman4

New Member
I was watching BBC iplayer on the tv portal but it suddenly froze and no matter what i pressed, nothing happened so I switched it off at the mains and turned it back on.

Now, no matter what I press on the remote, nothing happens except the TV button at the top of the remote lights up. I can change channel and volume by pressing the buttons on the freeview box itself but nothing i press on the remote works. I've changed the batteries so it's nothing to do with that.

Anyone got any ideas?
 

Ezra Pound

Well-Known Member
If the remote has a TV button and a PVR button, you should be using the PVR button followed by the other buttons, so that the PVR button lights up rather than the TV button
 
OP
W

waterman4

New Member
I had actually tried that and it didn't work. I kept pressing it about 20 times and finally it's worked. thanks
 

MartinLiddle

Super Moderator
Staff member
Sounds like the keypads need cleaning, the WiKi has a disassembly guide HERE
The original HDR-2000T remotes don't seem to be of very good quality. Ours started to give problems after six months and was useless after nine months. I suggest the OP rings Humax, explains the problem and ask for a new remote. Ours arrived in two days via Royal Mail.
 
OP
W

waterman4

New Member
Did you have to pay Humax for the replacement remote, Martin? I'm going to have to do something - now the Back and Exit buttons don't work at all and the Guide and Mute buttons work eventually if you press them about 50 times.
 
Top