1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2TB Hard Drive - Problem getting Humax T2 to recognise it

Discussion in 'HD-FOX T2 Freeview Receiver' started by roddyb, Sep 30, 2011.

  1. roddyb

    roddyb New Member

    Hi, I read that the Humax T2 has trouble with drives above 1tb generally but it looks like some people might have had some success in getting the 2tb drives to work.

    Most of the posts online seem to refer to when people are needing help rather than what the final solution was (I assume that they eventually got it working). If I manage to get it working I will post the solution so hopefully it will help others.

    I loaded the latest software on the Humax and then created a ext3 partition (1TB x 2) via the PC on a WD Elements 2TB drive. The Humax recognised the drive as 1TB but then asked to format it. After the format, the Humax then showed the drive as 1.8TB and would not allow me to choose the drive for recording/pvr.

    The first partition was the primary and the second was the other option (logical I think) - would this make a difference?

    Any help/advice would be greatly appreciated!
     
  2. Black Hole

    Black Hole Ron Glum

    With the standard partition table you can have 4 primary partitions, of which one is marked "active" for booting. Any primary partition can be divided into logical partitions - effectively it gets a new partition table within the primary partition. So, at the moment we don't know quite how you set up the drive, but I suspect it was two primaries. When plugged into the HD-FOX it would only have recognised the first partition.

    What happened after that I'm not sure. From what I have gathered on the forum the Humax should only format up to 1TB, but I have never tried it myself.
     
  3. roddyb

    roddyb New Member

    Thanks for replying. I wonder if the mistake I made was creating 2 partitions rather than just one. I will try creating one ext3 partition and see if the Humax allows the drive to be used.
     
  4. roddyb

    roddyb New Member

    Hi, just for people wondering (or reading this in future) - I swapped my 2TB for a 1TB as I could not get the 2TB to work. Thanks to everyone who replied.
     
  5. Black Hole

    Black Hole Ron Glum

    And the 1TB works as advertised? Did you format it with the Hummy?
     
  6. roddyb

    roddyb New Member

    Hi, I formatted the 1TB WD Elements drive via the Humax (took a while) and it worked straight away. Shame I could not get the 2tb to work. Thanks for replying.
     
  7. Splog

    Splog New Member

    Hi Roddyb,

    I had the same problem as you. I tried to get my WD Elements 2TB disc working with my humax, I failed and then fell back to a 1TB disc.

    I later had a look a the 1TB disc to see if I could see if anything jumped out at me that would explain why the 2TB disc wouldn't work, I didn't find anything.

    I decided to give the 2TB disc another go. I partitioned (1 big partition) and formatted (ext3) it on my PC, copied over the files from the 1TB disc (including a hidden folder called .tsr) and now I'm successfully using a 2TB disc with my humax.

    As an add note, my 2TB disc is an advanced format disc (as yours probably is) and the software I used to partition it advised that for performance reasons, the partition should be aligned to 1MB boundaries. See this link.

    Edit: Changed a "did" to a "didn't"
     
  8. Black Hole

    Black Hole Ron Glum

    Including recording to it? I presume so, pointless otherwise on an HD-FOX.

    The reason I raised my eyebrows is because the received wisdom says you can only record to a drive that has been formatted locally.
     
  9. Splog

    Splog New Member

    Yes, including recording to it.
     
  10. Black Hole

    Black Hole Ron Glum

    This is interesting. At a guess I would say the existence of the .tsr folder is the clue.
     
  11. Splog

    Splog New Member

    I've posted this on another thread but I thought it belonged here as well:

    On a freshly HD-Fox formatted HDD there are 2 folders and 3 files. The .tsr folder is one of the folders but I'm not 100% sure that it's the key to an HDD formatted on a PC being recordable on the HD-Fox without the HD-Fox having to do its own reformatting first.

    The folders on a freshly HD-Fox formatted HDD are:
    /Video - New recordings are placed in here.
    /.tsr - I've read elsewhere that this stands for 'Time Shift Recording'.​

    and the files are:
    /epgsavedata​
    /.tsr/0.nts - in case it's not clear the '0' is a zero​
    /.tsr/0.ts​
     
  12. Black Hole

    Black Hole Ron Glum

    How big is the 0.ts? Is it a predefined file so that the time shift buffer doesn't constantly fragment the drive (like a Windows swap file)?

    There will be differences with the format on a HDR-FOX, as it has an internal drive for all that stuff.
     
  13. Splog

    Splog New Member

    The 0.ts file from last night is about 17.5 MB. I formatted the HDD and pretty much switch off the humax straight away.

    My current 0.ts is a constant 18,481,152KB (reading courtesy of the samba) . The humax has been on an SD channel (BBC News) for a few hours. Does 18GB seem rather large for an SD chase buffer seeing as a 2 hour HD film is about 7GB ?

    I've switched to ITV1, 0.ts has remained the same size. I've refreshed a few times, the time stamp changes and the file stays the same size.

    In case you're interested, a 0.hmt file has joined the other 0.* files in the .tsr folder.
     
  14. Black Hole

    Black Hole Ron Glum

    The .hmt and .nts are what have been called "sidecar" files, they contain attributes such as SD/HD, and the last played position. A thumbnail file makes up the full set.

    Thanks for the info.
     
  15. Jam3s

    Jam3s New Member

    Hi,

    Sorry to drag up an old(ish) thread but rather than start a new one I thought it was worth mentioning that I've just done similar to splog above and now have a 3Tb external drive set up with my HD-Fox T2 which is successfully recording (and accessing old files copied to it from my previous drive(s)).
     
  16. Black Hole

    Black Hole Ron Glum

    3TB? That's impressive. I think we thought 2TB was the limit.
     
  17. Jam3s

    Jam3s New Member

    Well it seems to be happily recording so far :)

    The media screen is showing 2768Mb free at the moment too so it looks like it's seeing it OK too.

    Weirdly the output of the mount command is showing it as an ext2 drive even though it's formatted as ext3 - doesn't seem to be causing any issues so far though.

    I am having a couple of issues with file permissions at the moment but I think that's to do with the way I copied the files from the old drive. Unfortunately it means that the customised firmware isn't working as it can't get into the mod directory but I just need to wait for it to stop recording something and I'll take a look at that.
     
  18. xyz321

    xyz321 Well-Known Member

    How did you partition it? The 'msdos' format partition table which is normally used by the Hummy has a limit of 2TiB. The newer format GPT partition tables can go much larger but I don't think the kernel has been configured to support it.
     
  19. Black Hole

    Black Hole Ron Glum

    That would depend on the cluster size wouldn't it? Double the cluster size, double the maximum capacity?
     
  20. Jam3s

    Jam3s New Member

    I partitioned it using gparted (using Ubuntu).

    I'm not sure which format of partition able it used ... whichever is the default I suppose (I was going to look into that if it didn't work using the defaults). I could have a look at the settings in gparted to see what it's set to now - alternatively is there a way to check by querying the drive itself?

    The same's true of the cluster size - presumably I can query the drive to see what it is...?
     
  21. xyz321

    xyz321 Well-Known Member

    I presume you mean sector size (clusters are usually associated with certain filesystems not partition tables). The old msdos (MBR) partition table only supports 512 byte sectors. Some disks do use larger sectors internally but the OS still has to support the original spec. of 512 byte sectors.