Adding Static Route

TomT

Member
Hi
I know to add a static route via the command line.. How do I have that route reloaded when the box is rebooted?
 
OP
T

TomT

Member
Hi
My son has added a NAS drive to my network. This is running TWonky which is causing my Humax to reboot.

I don't need access to the NAS from the Humax so I've manually added a static IP route to the Humax with a reject so the box can't connect to the NAS. A simple ping from the Humax to the NAS now fails.

I'd like to set this as a permanent IP route to see if it will help!

Thx
 

Black Hole

May contain traces of nut
The file system that gets read at boot time is read-only, so you need to create a hook.

THIS (click) will tell you what you need to know (different purpose, same principle).

Please share the result, it may help others (the Twonky problem is well known, but usually solved by downgrading Twonky to v6).
 

prpr

Well-Known Member
I've manually added a static IP route to the Humax with a reject so the box can't connect to the NAS. A simple ping from the Humax to the NAS now fails.

I'd like to set this as a permanent IP route to see if it will help!
If you tell people exactly what you've done, someone could tell you how to make it permanent.
If you don't, it's a bit tricky don't you think?
 
OP
T

TomT

Member
Ive had the reboot issue before when my NAS was running a newer version of twonky.. It's started again since he added his to the network.

I'm testing adding a static route to reject packets to the NAS.
route add -h 192.168.0.1 reject

Rejects packets sent to that IP address.
 

dragon-it

Member
Can you add the route to your NAS instead? Otherwise maybe you can get a bit creative with subnet masks:

Router - 192.168.1.1
Humax - 192.168.1.3

NAS 192.168.1.xx - anything 8 or above say. For humax try setting subnet mask to 255.255.255.248

Then unless the Humax will still listen to that traffic going on the network it should ignore / not be able to talk back to anything other than 192.168.1.1 to 192.168.1.7

Steve
 

af123

Administrator
Staff member
When I try to create a file in /etc/init.d I get bread only messages.
Any way to do this?
Create the file in /mod/etc/init.d

Nice solution to an old problem! I've been playing with adding ipfilter support to achieve the same result but this is far simpler.

Edit: Now I'm on a real keyboard...

So, something like:

Code:
humax# echo 'route add -h 192.168.0.1 reject' > /mod/etc/init.d/S22nasroute
humax# chmod 755 /mod/etc/init.d/S22nasroute
 
OP
T

TomT

Member
Slight error in my command !

It should be :
route add -host 192.168.0.1 reject

I'll see how this goes. The Humax has been powered up for 15 minutes now and no reboots !
 
OP
T

TomT

Member
No problems at all today since adding the route.
Humax is running fine and my sons NAS is still working for him :)
 
Top