1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Advice for Newbie please - Firmware Update

Discussion in 'HDR-FOX T2 Freeview Recorder' started by quarkrad, Oct 21, 2012.

  1. quarkrad

    quarkrad Member

    I was about to install the custom-firmware when I read (wiki) that it needs to be installed over/along side the normal firmware. I checked my box (a week old) and it says 1.02.20. My reasoning (?) is to upgrade to 1.02.29 and then install the custom-firmware. I downloaded 1.02.29 and installed the .hdf file (but not the txt file) on a newly formatted usb stick. I have tried both the front and rear usb ports but when I switch the box on it does not see the stick and boots to the normal TV. Any advice on the best thing to do would be much appreciated. (My stick is 4GB, fat32 - could there be an issue using a 4GB stick? I would not have thought so as this is a linux box).
     
  2. Black Hole

    Black Hole Felinos Guru

    The Humax is finniky about USB sticks (when updating firmware). Try another. Advice about firmware updating HERE (click) or HERE (click - scroll to end).

    Be sure that you want to update to 1.02.29. The custom firmware is also available for 1.02.20. Read about the issues HERE (click), sections 1 and 2.
     
  3. 4291

    4291 Well-Known Member

    I am on 1.02.20 cf 2.11 It works for me and I have seen no reason to change, yet.
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    Try the notes on the WiKi HERE (bottom of the page)
     
  5. quarkrad

    quarkrad Member

    Thank you all. I think I will stick to 1.02.20 having read your links and install the custom-firmware. I did a OTA search and after some time I was told I had the latest edition although it looks like 1.02.28 is also on OTA so I'm not picking that up for some reason. I have a lot to learn - only scratched the surface, so things will become clearer as I learn. I'm a previous Toppy user and I must say this box is really really good.
     
  6. Ezra Pound

    Ezra Pound Well-Known Member

    There is something that the Manual doesn't tell you about 'Search for new Software', that the software is not always available, because all manufactures have to share the same OTA channel, Humax only get a few days a month (at most) when they can transmit new software, so although 1.02.28 is sometimes available it isn't now. Have a look HERE to see when an OTA is available (the list is updated every week)
     
  7. quarkrad

    quarkrad Member

    Having decided to stick with 1.02.20 I'm having my original problem - this time installing the custom firmware. I have reconfigured my 4G stick to 2G so there are no issues (not that there should be with linux) re the number of partitions on it. I have followed the wiki instructions but when I hold in the big button on the front after a while all I get is the TV channel. From standstill, when I hold the big button in, I can hear the HD start up and then I get the TV picture. Are there any other ways of installing? (I've tried front and back usb ports).
     
  8. af123

    af123 Administrator Staff Member

    You shouldn't have to hold the button in, just put the USB stick in and press the button briefly. (holding the power button in is the method for the HD model rather than the HDR).

    A 4G stick will be fine, just make sure it has a single primary partition on it and is (freshly) formatted FAT32 and that you have unzipped the firmware download so that there is a file at the top level called hdr_fox_t2_upgrade.hdf
     
  9. quarkrad

    quarkrad Member

    I've just tried a different usb stick - 256Mb capacity. Formatted as fat32 and has only one file on it hdr_fox_t2_upgrade.hdf. Same thing - just goes to TV channel.
     
  10. quarkrad

    quarkrad Member

    Apologies - the new stick was fat16. Reformatted and now something is happening(?). Inserted stick, switch on from standy and now TV screen just showing Humax startup screen, Humax in center of screen and Ver a7.31 lower left. I'll wait a while to see if anything happens.
     
  11. quarkrad

    quarkrad Member

    OK it worked! Tried a third stick - formatted it my linux machine and copied file onto it. This time the hummy liked it. Thanks.
     
  12. quarkrad

    quarkrad Member

    Mmmm ...... I might have messed up a bit here. Not sure how to find out if custom firmware was loaded - it looked like it loaded OK from the tv screen. I thought I would try and 'see' the hummy from my PC so went into the hummy internet settings to get the ip address of the box. I put the hummy ip address into my browser but it would not connect - I was not suprised as it was not in the range of my home lan ip addresses. I use static ip address on my home lan so I chose Manual on the hummy box and changed the ip address to 192.168.1.12 (and the gateway / DNS addresses to 192.168.1.1 as per my lan). I thought I would be able to ping the hummy box (it says it is connected) but I cannot. So I'm in bit of a fix now - is there a way via Menu/Settings/etc I can read something that tells me the customer firmware is loaded?
     
  13. Black Hole

    Black Hole Felinos Guru

    The custom firmware announces itself on the front panel display during boot-up. I trust you loaded the correct version of the custom firmware - 2.12 for 1.02.20 not 1.02.29?
     
  14. quarkrad

    quarkrad Member

    Thank you - yes it is loaded, it says 2.12. All I need to do now is to sort out the ip addressing. When in the internet setting screen I set a specific ip address in the 192.168. x range and when I click on Apply it searches and then says it connects. However, the TV Portal briefly tries to connect and then the screen message disappears and nothing happens. I will continue to learn/fix this issue.
     
  15. Black Hole

    Black Hole Felinos Guru

    Try DHCP and see what gets returned. Might give you a clue.
     
  16. quarkrad

    quarkrad Member

    Got it all working now - and with static ip address for hummy. I think my problem was a poor ethernet connection (I have two routers on my lan - one acting as a slave). Anyway - downloaded the rest of the files and restarted the box. Thank you very much for your kind support.