After CF upgrade

tommarv

Member
Can anyone whos been helping myself just stick to this forum now. Ive updated to CF. Had a play with folders and duplicates etc. Im trying to play (on pc)a transferred file (.ts) upto now no joy. Im getting (cant render file) in media lite player. So im almost sure Im missing out on de-encrypting these files. Upto now Im sticking with SD files. Ive made a new folder on my hard drive (humax hdd) then copied a file into it then downloaded. Still wont play.

p.s. Ive installed the full web package. and can open it via my ip addy in address bar. Using both IE 10 and chrome.
Unit: Humax HD FOX T2
 
OP
tommarv

tommarv

Member
For the HD-FOX, the custom software HDR Mode package gives it the ability to decrypt when copying using the handset.




Can anyone elaborate on this? From the guide.
 
OP
tommarv

tommarv

Member
I thought i had installed full package. When I looked in package management, I only had ffmpeg and webif. installed. Ive just installed boothdr. I think it asked me to press yellow button at first install for that (boothdr). What are the best packages to install first. Ive seen samba, betaftp, auto unprotect, disable -ota. Or am I supposed to install all these? To be honest I thought they were all installed at initial update.
 
OP
tommarv

tommarv

Member
Im upto "install virtual disk and boothdr" 5;2 in guide. were do I get virtual disk from? Thanks for your help Black Hole,,Ive noticed theres a few grandstanders who just like commenting. Before Ive had chance, I get remarks like "moron" scattergun approach. If you cant help dont hinder. Too many commas, ,,,wtf,, why dont you go and watch the telly
 

Black Hole

May contain traces of nut
But I do like to see correct spelling, grammar, and punctuation! If a post gets too hard to read I won't bother. What have you got against full stops (and apostrophes, and...)? BTW, if you read my posts too soon after I've written them I won't have had chance to correct the typos and stupid spell-check auto-corrections. (The remarks about commas were made in the Hummy Arms, where anything goes!)

virtual-disk is a package available from the Package Management page just like any other. It is possible you might have to turn on advanced packages in the Settings page.
 
OP
tommarv

tommarv

Member
Ive managed to get pie chart green. when I press media button it goes straight to videos, in system info, it says "HDR-FOX T2; 1.02.20; 10 JUN 2011". It reverts back to blue pie after reboot.
Ive downloaded a recording (sd) to my pc as a .ts file but it still wont open.
 

MontysEvilTwin

Well-Known Member
Virtual disk is a package and can be installed through the package management section of Web-If. Strictly speaking, you don't need to install it to carry out file decryption, but it will make things a bit easier if you are not familiar with the ins and outs of the process on the HD Fox. You will also need to install the auto-unprotect package for the process to work with programmes recorded from HD channels.

Once the HD Fox has been booted into HDR mode, if you select a programme using the Opt+ button on your remote control and use the Move/ Copy option to copy into the virtual disk folder, the copy is saved without encryption:)
 

MontysEvilTwin

Well-Known Member
Ive managed to get pie chart green. when I press media button it goes straight to videos, in system info, it says "HDR-FOX T2; 1.02.20; 10 JUN 2011". It reverts back to blue pie after reboot.
Ive downloaded a recording (sd) to my pc as a .ts file but it still wont open.
You have successfully booted into HDR mode. While in this mode, if you copy a file as I described in my previous message, this copy is unencrypted and can be played on a PC. This is currently the only way to do it on a HD Fox.
 
OP
tommarv

tommarv

Member
Ive copied using remote then extracted and Ive got a mpg file now in virtual disk. when i played with quick player only got audio.
 

MontysEvilTwin

Well-Known Member
Ive copied using remote then extracted and Ive got a mpg file now in virtual disk. when i played with quick player only got audio.
The native output is as a .TS file with sidecar files .htm and .nts, plus a thumbnail (.thm) which is created when the file is first played by the Humax. Have you repackaged the .TS file as an mp4? The native .TS file will play on a Windows PC with VLC player and Splash Player, plus probably some others too: I don't know about quick player (QuickTime?).
 

MontysEvilTwin

Well-Known Member
Copy all the files as they are. The sidecar files are needed for playback on the Humax. Don't change the file extension, the video player will either play the TS or it won't, changing the extension from .TS might make the file unplayable.
 
OP
tommarv

tommarv

Member
Ive copied a file from videos folder to virtual disk. Then downloaded using filezilla. I got the sidecar files htm,thm,nts,and ts. I tried playing the ts file in "vlc 2.1.1 rincewind". But it wont strike up. I renamed it ".mp4" still no joy.
 

MontysEvilTwin

Well-Known Member
In Web-If, does the video file show up with a green 'DEC' flag or an orange 'ENC' flag? If it does not have the 'DEC' flag the file is still encrypted.

Sometimes booting into HDR mode fails: make sure you have the green pie chart in Web-If before copying the file.

When copying the programme to the virtual disk with the remote ensure that the function (next to the red circle on the screen) says copy not move: in this mode the file to be copied will be in the 'HDD' folder and will need to be copied into the virtual disk (mounted as an external USB drive). It might take a few minutes to complete depending on the file size: check that the size of the copy
 

Black Hole

May contain traces of nut
Whats the best way to copy? Using webif or remote
The instructions are EXPLICIT on this point (from the HD-FOX decryption guide):
Use the remote control handset to navigate the Media list and copy the required recording(s) to the virtual drive (on the USB device options) - this will decrypt them (copying using the WebIF media browser WILL NOT DO, and if the red button offers you "move" instead of "copy" you are trying to send it to the wrong place);
 
Top