anacrontab resolve_conffiles error

Owen Smith

Active Member
I did an "upgrade" of all packages from the telnet menu on one of my HDR Fox T2s, running 1.03.12/3.10. I was rather concerned to see the following at the end:

* resolve_conffiles: Existing conffile /mod/etc/anacrontab is different from the conffile in the new package. The new conffile will be placed at /mod/etc/anacrontab-opkg.

Do I need to do anything about this? I don't even know what anacrontab does or what package it is part of.
 
OP
O

Owen Smith

Active Member
And next after a reboot I ran again from telnet the fix-flash-packages diagnostic (I'm never sure when I'm supposed to run that so always do it after upgrading either any packages or the custom firmware) and got the following errors:

Installing undelete (1.6-2) to root...
Downloading http://hpkg.tv/hdrfoxt2/base/undelete_1.6-2_mipsel.opk.
Configuring undelete.
Collected errors:
* pkg_run_script: package "undelete" postrm script returned status 126.

and:

Collected errors:
* file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico: No such file or directory.

Are these anything to worry about?

By the way, I love doing package upgrades and other management from the telnet menu. Feedback is much more direct, I can see what it's doing at each stage. In a web browser it displays nothing until the very end so it's always a worry that it's got stuck.
 
OP
O

Owen Smith

Active Member
And on my other HDR Fox T2 (a Grade A one) I get all the erros above but in addition this looks more serious, fix-flash-packages appears unable to remove undelete so can't upgrade it:

Re-installing undelete
Removing package undelete from root...
sh: /mod/var/opkg/info/undelete.postrm: Permission denied
No packages removed.
Installing undelete (1.6-2) to root...
Downloading http://hpkg.tv/hdrfoxt2/base/undelete_1.6-2_mipsel.opk.
Configuring undelete.
Collected errors:
* pkg_run_script: package "undelete" postrm script returned status 126.
 

af123

Administrator
Staff member
I did an "upgrade" of all packages from the telnet menu on one of my HDR Fox T2s, running 1.03.12/3.10. I was rather concerned to see the following at the end:

* resolve_conffiles: Existing conffile /mod/etc/anacrontab is different from the conffile in the new package. The new conffile will be placed at /mod/etc/anacrontab-opkg.

Do I need to do anything about this? I don't even know what anacrontab does or what package it is part of.
No, that's nothing to worry about.
 

af123

Administrator
Staff member
By the way, I love doing package upgrades and other management from the telnet menu. Feedback is much more direct, I can see what it's doing at each stage. In a web browser it displays nothing until the very end so it's always a worry that it's got stuck.
Me too but the recent versions of the web interface give the same level of feedback with messages appearing as soon as they are generated.
 

af123

Administrator
Staff member
* pkg_run_script: package "undelete" postrm script returned status 126.
I don't know why but the postrm script has lost its executable privilege.
Run this to fix:

Code:
humax# chmod 755 /mod/var/opkg/info/undelete.postrm
 

prpr

Well-Known Member
I don't know why but the postrm script has lost its executable privilege.
It hasn't lost it, it's not there to start with:
Code:
humax /tmp/undelete_1.6-2_mipsel # ls -l CONTROL/
-rw-r--r--  1 root  root   32 Nov 25  2015 conffiles
-rw-r--r--  1 root  root  297 Nov 25  2015 control
-rwxr-xr-x  1 root  root  213 Jan 12  2015 postinst
-rw-r--r--  1 root  root  117 Jan 12  2015 postrm
-rwxr-xr-x  1 root  root  141 Jan 12  2015 preinst
-rwxr-xr-x  1 root  root  127 Jan 12  2015 prerm
So that's a packaging error.
 

prpr

Well-Known Member
Yes, it will, but everything else will be right and you know how to fix the undelete package...
 

Black Hole

May contain traces of nut
So what's the short answer on all this? Without intervention, does anybody who's run FFP no longer have undelete functioning? I get thes same/similar errors:

Code:
...
Re-installing undelete
Removing package undelete from root...
No packages removed.
Installing undelete (1.6-2) to root...
Downloading http://hpkg.tv/hdrfoxt2/base/undelete_1.6-2_mipsel.opk.
Configuring undelete.
Collected errors:
* pkg_run_script: package "undelete" postrm script returned status 126.
Re-installing webif
Removing package webif from root...
Not deleting modified conffile /mod/webif/html/favicon.ico.
Installing webif (1.3.1-1) to root...
Downloading http://hpkg.tv/hdrfoxt2/base/webif_1.3.1-1_mipsel.opk.
SMART: (PASSED)
startstop: 6180
realloc: 0
hours: 25842
spinretry: 0
pending: 0
offline: 0
Configuring webif.
Collected errors:
* file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico: No such file or directory.
 

prpr

Well-Known Member
Thought af123 might have fixed this by now (and a couple of other tweaks to packages I mentioned elsewhere), so I guess he's off grid or unable at the moment.
 
Top