1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Another request for help with automount

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Freefall, Nov 1, 2012.

  1. Freefall

    Freefall New Member

    I have just purchased a synology DS213 NAS. I created two folders called "video" and "HumaxTV" with user with read only priviledges of lets say "fred" with password of "fredspass".

    I installed automount on my HDR-T2 and went into / media-My Video-[ModSettings]- smb and created two folder called "NAS video" and "NAS TV"

    within the NAS video folder i edited the folders there to read (?= number not shown for security ?)

    domain=WORKGROUP
    folder=video
    host=192_168_1_??
    mac=00_11_32_15_25_??
    password=fredspass
    shareFolder=off
    user=fred (4.0KiB)
    wakeConstantly?
    wakeNow?
    I'm getting none of the files that are in the video folder showing anywhere.
    A few questions
    1. Do the folder names on the NAS and Humax have to be the same or can I use "NAS video" on humax = "video" on NAS also is upper or lower case important ?
    2. Where would this " NAS video" folder show up on the humax, under / media /My Video / ?
    3.What else am I doing wrong
    I have read the threads but cannot get my head around this problem so sorry about this new thread
    Freefall
     
  2. Black Hole

    Black Hole Felonius Gru

    With shareFolder=off (don't turn it on), the network share is effectively a virtual USB drive so the access will be via Media >> Storage (blue) >> USB, but you also need real USB storage plugged in otherwise the standard Humax firmware doesn't bother to look for any virtual devices (it's the way it has to be tricked into it).

    The real USB can be a cheap & cheerful UPD if you like, no problem.
     
  3. Freefall

    Freefall New Member

    Thanks,

    thats all it took :frantic:
     
  4. af123

    af123 Administrator Staff Member

    It had slipped my mind but someone did send me a way of getting round needing the USB drive plugged in.. I'll dig it out!
     
  5. Freefall

    Freefall New Member

    NAS folders all showing now, only problem is when the humax starts up it freezes with 'system start up screen' on the display . Using a 32mb USB drive, have tried front and back, have to remove and switch off on back to get humax to start up
     
  6. Black Hole

    Black Hole Felonius Gru

    Try it with the NAS off.
     
  7. ntm1275

    ntm1275 Member

    @Freefall

    Just a quick reminder to you how the shared folders from your DS213 work depending on whether your user (fred) has Read Only or Read/Write access to your DS213

    Read Only - if you stop a video before the end and then play it again, you don't get the option to resume from where you originally stopped it - this information is normally written to the NAS in a 'hmi' file, but as the user is Read Only, it is not created

    Read/Write - This gives you complete control over folders and files on the NAS including 'delete', so if the NAS is turned on and you use the remote 'opt' functionality to delete, it will delete what you ask it to - if you accidentally 'delete' the video folder it will start deleting all the files and folders within your Synology shared video folder
    If you have other members in your household who you are going to allow to use the shared folder, I would suggest setting up two shares one Read Only user called Video or as you suggest NAS video, and another called 'DO NOT USE OR DELETE' with Read/Write access, so that other members of your household don't accidentally delete everything you have stored on your NAS

    I fell in to this trap when I was testing the original release of 'automount' - I thought I was just deleting the share that had been created on the Humax, but it started deleting all my videos on the NAS (Synology DS1010+) - I was lucky I kept a backup
     
  8. Freefall

    Freefall New Member

    Thanks for the warning, it would be nice to resume from where I had stopped watching but the risk is too great.

    I will try starting with the NAS off, Blackhole, but surely thats going to be a pain checking each time or is a one off type of action
     
  9. Black Hole

    Black Hole Felonius Gru

    Just trying to pin down the problem, I'm not suggesting it as a solution.
     
  10. Freefall

    Freefall New Member

    Ok, switched off NAS, still got to "Start Sytem" on display at which point it freezes, have to remove usb and use swithc on back to restart. Also tried connecting USB while HUMAX on ( fine) then going into setting to format usb and get "crash - Wait" on display.
     
  11. Freefall

    Freefall New Member

    Found a 2GB USB stick that works, Humax can start and go into standby - with NAS switched off - so maybe size or make of USB stick has effect , tried 32mb, 64mb and 2gb .only 2gbworks


    But

    with NAS switched on, no USB stick in, Humax will start up when switched off/on from switch on back, but when touch round button on front, display dims but circle does not turn red but stays blue and Humax will not restart until use switch on back
     
  12. ntm1275

    ntm1275 Member

    This might be a long shot, but I wonder if the larger USB sticks you have tried need fractionally more power than the Humax USB socket can provide

    In the manual it says 5 V 500mA Max - this is the spec for USB 2 devices

    Most USB sticks that I have tired only use 100mA each, but larger ones may need more, especially if they are USB 3 devices - USB 3 spec allows for 900mA

    To test what power your large USB sticks require, you can go to device manager on a Windows PC, and open the Universal Serial Bus Controller section - in this section there may be several Generic USB Hubs or USB Root Hubs - double click each one in turn and select the 'power' tab at the top to display the attached devices - here it will state the power required for the USB device

    On the Hummy, the front and back USB sockets are probably being shared, so 500mA is the maximum over both connections, not 500mA each

    Just a thought
     
  13. Black Hole

    Black Hole Felonius Gru

    A UPD exceeding the power output? No way. I have used a 32GB stick myself. Much more likely to be the Humax's difficulty interfacing with some UPDs (bear in mind it does not have the same range of drivers that come with Windows).
     
  14. ntm1275

    ntm1275 Member

    @Black Hole

    I did say it was a 'long shot'

    I don't think it's the drivers, as a 'mass storage device' in Windows, Linux and Apple uses the same drivers for any that are plugged in - it has been a standard specification for a number of years

    What it may be, is that the onboard flash memory chips are of a newer specification which the BIOS of the Hummy does not recognise
     
  15. Freefall

    Freefall New Member

    I don't think the problem is anything to do with the USB drives as I am getting the same problem of the humax not going into stand by (red ring , just get blue ring with dimmed display) or coming back from that state while the NAS is on.

    I should point out I wasn't having success with 32 and 64 megabyte drives but the shares show fine with a 2 gigabyte USB drive its just the damned Humax not going into and coming back out of standby. Have also tried wIth 500gb portable Hard drive , same story
     
  16. Ezra Pound

    Ezra Pound Well-Known Member

    I understand your problem, but can I just point out that the 'stand-by' ring colour is an orange colour officially called amber, red is only used when the Humax is recording
     
  17. Freefall

    Freefall New Member

    OK, sorry, I mean and have meant orange. I have mapped 3 shares on the NAS to the Humax, that wouldnt make a difference ?
     
  18. Black Hole

    Black Hole Felonius Gru

    If that were the case, my PC wouldn't go away and load another driver when I plug in a different UPD. I believe there are differences.