Auto Functions WebIF, not working, insufficient disk space ?

free30

Member
OK this seems a bit like a stupid question but.
The auto functions in WebIF have stopped working.
The log says I've insufficient disk space. :(
Is that right?
I've at least 80gb spare; then again that might be a low ratio of the 2Tb total. You can see I tried turning on the DLNA server, not sure if it's needed or not.
Code:
05/02/2014 16:00 - DLNA Server is NOT running.
05/02/2014 16:00 - Media scan starting, DLNA server status: 0
05/02/2014 16:00 - Insufficient disk space. Require=1073741824, Free=0
05/02/2014 16:10 - Registered ::sweeper::scan for postdecryptscan hook.
05/02/2014 16:10 - -------------------------------------------------------
05/02/2014 16:10 - DLNA Server is running.
05/02/2014 16:10 - Media scan starting, DLNA server status: 1
05/02/2014 16:10 - Insufficient disk space. Require=1073741824, Free=0

Thanks
 

Black Hole

May contain traces of nut
The DLNA server is only needed for auto-decryption. Those messages look as if they are trying to reserve about 1GB, and finding none free, so the systems boys will have to prognosticate.
 

MartinLiddle

Super Moderator
Staff member
I've at least 80gb spare; then again that might be a low ratio of the 2Tb total. You can see I tried turning on the DLNA server, not sure if it's needed or not.
When you formatted the 2TB drive did you use the default reserve 5% of free space for root? If so by my calculation 5% of 2TB is 100GB and you only have 80GB free so that may explain the error message.
 
OP
free30

free30

Member
When you formatted the 2TB drive did you use the default reserve 5% of free space for root?
Oh ,no, not as I remember.
I think I did same strange disk copy and expanded the partition.
Would make sense as the onscreen file browser gave a different amount of free space compared to the WebIF.

Anything I could do at this late stage ?
I'm deleting a bit of stuff so should help just not stop it happening again in the future.
Thanks :)

Code:
05/02/2014 17:20 - DLNA Server is running.
05/02/2014 17:20 - Media scan starting, DLNA server status: 1
05/02/2014 17:20 - Dustbin: /media/My Video/[Deleted Items]
05/02/2014 17:20 - Root device: 2050
05/02/2014 17:20 -  [/media/My Video]
05/02/2014 17:20 -    (R)
05/02/2014 17:20 - DECRYPT: [/media/My Video]
05/02/2014 17:20 - Insufficient disk space. Require=10477342720, Free=8106708992
 
OP
free30

free30

Member
Ok I deleted a load and now auto functions are working.
Just it reports the wrong amount of free space.

Is there a good cloud storage that works well with the humax (filling to it and being able to search from remote control) ?
 

af123

Administrator
Staff member
Automatic processing requires there to be free space of 1GiB + (3 * size of file being processed).
That log extract indicates that it was detecting no free space at all. It could be a bug but you can see the disk space stats that it uses be running the diskfree diagnostic:

Code:
Running: diskfree
Filesystem                Size      Used Available Use% Mounted on
/dev/sda2                 1.8T    983.8G    867.6G  53% /mnt/hd2
 
OP
free30

free30

Member
Thanks,
So the WebIF and Diskfree diagnostic both show I have 99GB less space than the on screen display.
Its always been like this, I've run diskfix before now from the telenet in maintenance mode and the difference has always been there.
I'd like to think the on screen display was right, either way can I fix it? (No, not on my own)
Any advice?:)

Now I've deleted a few things
Code:
>>> Beginning diagnostic diskfree
Running: diskfree
Filesystem                Size      Used Available Use% Mounted on
/dev/sda2                1.8T      1.6T    64.8G  96% /mnt/hd2
 
>>> Ending diagnostic diskfree

Disk space in WebIF gives this result, or non-result
Code:
Disk Utilisation Error, /media/My Video, 1726914208 /media/My Video/du: /media/My Video/Recent Series/Treasures of Ancient Egypt/.series: Input/output error du: /media/My Video/[Deleted Items]/webif_autoshrink/The Simpsons: Input/output error
 

MartinLiddle

Super Moderator
Staff member
I'd like to think the on screen display was right, either way can I fix it? (No, not on my own)
You need to unmount the recording partition /dev/sda2, I am guessing this will be best done in maintenance mode but I hope af123 will confirm and then issue the command

Code:
tune2fs -m 0 /dev/sda2

(this sets the percentage of reserved space to 0 (percent); currently it us 5%. You can choose any percentage you like but to get the two measures of free space to agree you need to set it to 0).
 
OP
free30

free30

Member
Thanks, so I've just managed to do it.
I ran command "tune2fs -m 0 /dev/sda2" it only took a sec.
Now it is reporting the same amount of free space in the WebIF as the TV browser.

Should I not have set it to 5% rather than 0%. If I make sure I've got space would it do any harm to my recordings?
Thanks the Humax was starting to lock up when deleting and crash when moving folders, but it seems to have fixed them too. :)
 

MartinLiddle

Super Moderator
Staff member
Should I not have set it to 5% rather than 0%.
It was 5% and you were complaining about the inconsistencies in free space reporting.
If I make sure I've got space would it do any harm to my recordings?
If you run the box with very little free space then you will get more file fragmentation which may some impact on performance so I always aim to keep at least 10% free space.
 
Top