BBC4 HD is removed on reboot

salad dodger

New Member
As per the the title. I can't work out why it is being removed. I did have the channel del package installed. I tried different configurations and finally removed the package.

If I do a manual tune for COM7 HD the channel returns.

But on a reboot, it disappears. I can't figure it out, any help appreciated.
 

af123

Administrator
Staff member
Do you have the tunefix package installed?
What's in your boot.log or xinit.log log files?
 
OP
S

salad dodger

New Member
Yes I have tunefix. And in xinit.log i can see

delete from TBL_SVC where szSvcName like 'BBC FOUR HD'

And I've found where that is configured. Not sure I'd ever tell it to delete this channel but its in the config. Thanks.
 
OP
S

salad dodger

New Member
As a side note, whats the difference between channel del and tunefix. Why the two, seems like they both do similar? Which one should I be using.
I do like the ability to retune and then automatically dump most of the rubbish I'll never use. Not sure i need to be doing it twice!

I think tunefix-automatic-channel-organisation-and-maintenance.6639

answers my question. I've only just created a login on here but this custom firmware resource is quite excellent. Thanks for all your efforts, I'm a massive fan.
 
Last edited:

prpr

Well-Known Member
delete from TBL_SVC where szSvcName like 'BBC FOUR HD'

And I've found where that is configured. Not sure I'd ever tell it to delete this channel but its in the config.
Somebody must have put it there, because there's no way it can get in there by any automated means.

Tunefix imports any config. from channeldel (and then deactivates the latter, so nothing will get done twice). So just uninstall channeldel.
 

jxp

Member
Not sure I'd ever tell it to delete this channel but its in the config.

Don't know if it's relevent, but BBC4HD changed mulitplexes during the Olympics.
I had great problems with configs around that time and I think I had to delete it from one Mux to get the other one to appear.
 
Top