1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Black Hole's Trail Guide to HDR-FOX T2 Hacking

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Black Hole, Jul 6, 2011.

Thread Status:
Not open for further replies.
  1. Black Hole

    Black Hole Felonius Gru

    rogdog, af123 and MattC like this.
  2. Black Hole

    Black Hole Felonius Gru

    Updated.
     
  3. fenlander

    fenlander Active Member

    This could become a major undertaking! - good luck...
    A few points:

    - "Settings.. System.. Internet Setting.. Configure LAN.. FTP Server.. ON" should be Settings.. System.. Internet Setting.. FTP Server.. ON

    - On the subject of Configure LAN, it's worth saying that it is safest, if you intend to use FTP, to use the Manual option and set a fixed IP address for the Hummy. If you leave it to your router's DHCP server to allocate an address, there's no guarantee that this will not change, invalidating the server address in the FTP client.

    - As you say, "Directory Opus 10" is a pricy file manager. Most users will probably use a free client, such as FileZilla, which works perfectly. I use Free Commander as my (free) dual-pane file manager and although it usually manages FTP tasks perfectly well, for some reason it won't talk to the Hummy. Someone might know why...?

    - I haven't tried formatting a USB stick via the Humax, but for a dummies-level guide, booting into a Linux Live disk and using gparted seems a little hairy. Having said that, I used gparted to format a partition on a USB hard drive for this purpose. I used gparted because my favourite Windows utility - EASEUS - failed to produce an ext3 partition that the Hummy would recognise. Worse, the Hummy formatter didn't seem to recognise the existence of more than one partition on the drive and wanted to zap the entire device. A simple and foolproof description - with appropriate health warnings - of how to format to ext3 is definitely needed.

    - Beware FAT32 disks/sticks. While the Hummy can write to them, the maximum file size they will allow is 4GB. The Hummy issues no warnings when it runs out of space; it just truncates the file and leaves you to work out what's wrong. [Paragraph edited to remove incorrect information]

    I look forward to your description of how to connect devices to the new media server (my success rate is about 15% so far) and just how to get into the most useful (consumer level) functionality in AF123's hacked software. I get lost somewhere around the point where I have to telnet commands to install packages. My Hummy hasn't got a keyboard!
     
  4. af123

    af123 Administrator Staff Member

    Actually the decryption doesn't change the file size, it is done in-place.
    All (Humax) .ts files are made up of the same number of 192 byte packets, before and after decryption. Not all packet types are encrypted but where they are then it is just the 128-byte payload that is scrambled.

    I was wondering why Black Hole was looking at ext3 though rather than keeping it simple with FAT32, but the size of HD recordings and the FAT32 size limit answers that nicely.
     
  5. fenlander

    fenlander Active Member

    My mistake. I felt sure I had seen a 4GB encrypted file expand to some 6GB when USBed, but clearly I'm not a trustworthy witness...
    I've corrected the original paragraph.

    Makes me wonder why the decryption process via USB is so slow, though.
     
  6. Black Hole

    Black Hole Felonius Gru

    For some reason I had 2GB in my head as the limit. I have edited the blog to 4GB.

    Ref difficulties documenting this, I'm not aiming to make a fool-proof all variations considered manual, just record what I did for others to follow if they want.
     
  7. Black Hole

    Black Hole Felonius Gru

    My notes (1.02.07) said what I wrote. I'll check later. Difference in 1.02.20?

    Update: You're right, I misinterpreted my notes. I will correct it later.
     
  8. Black Hole

    Black Hole Felonius Gru

    Updated.
     
  9. Black Hole

    Black Hole Felonius Gru

    Oops!

    I just had a crack at formatting a USB stick as Ext3, using Ultimate Boot CD 5.0.3 (I think) which provides a copy of the GParted utility. Once the GParted Linux had booted (in RAM) and I had a desktop, I started the Partition Manager thing and it took an age to scan the partitions (I had my 8GB stick plugged in at this point). I confirmed the stick was sdb1 with the file explorer, then selected it in Partition Manager and asked it to format to Ext3. "Error". File system not recognised. So then I selected the partition for deletion, deleted it, and created a new partition Ext3. "Error".

    I booted back into Windows and tried to format FAT. No joy. It seems I have bricked my USB stick. What do I do now? I will have to do some Googling unless anybody has any bright ideas.
     
  10. pk79

    pk79 New Member

    same happened to me using ext3 volume manager. I had to get my brother to reformat in linux. I too was playing with fire!
     
  11. Black Hole

    Black Hole Felonius Gru

    I have recovered my stick by downloading, installing, and running the HP USB Disk Storage Format Tool. I have it back to FAT32 (but empty!). Still need to make it Ext3 though!
     
  12. af123

    af123 Administrator Staff Member

    Not to mention the Humax HD model!
    Mostly I use/see HDD for hard disk* drive
    * - Yes, I know it should be a c but it always looks wrong to me. Too used to 5.25" floppies!
     
  13. Black Hole

    Black Hole Felonius Gru

    Oh yes, the good old "diskette" (which, for those of the younger generation, became contracted to "disk" and why we now have to suffer continual mis-spellings). Thus, for absolute purists, it should be "hard disc" and "floppy disk". However, language usage evolves, and I don't think anybody really minds if the spelling "disk" is used in computer contexts - just as it is a computer program but a television programme.

    I still have some 8" floppies somewhere (but no means to access them!). You don't realise how big they are until you see one. Stored a whole 90k too.

    I thought about HD as in HD-FOX T2, but decided not to bother as I had made it clear I haven't got one. I will spell it out in full if I need to, to avoid confusion.

    Post #1 now updated to incorporate some of the discussion.
     
  14. fenlander

    fenlander Active Member

    It seems the HDR-Fox-T2 won't format a memory stick - option is greyed out in the menu. I also tried Easeus Partition Manager in Windows - usually a reliable tool that can format disk partitions in ext2 and ext3. However, ask it to format a USB stick in ext3 and it tells you it needs to reboot Windows. I stopped at that point. Who'd have thought it would be so difficult to do such a trivial formatting task?

    The moral of the story is: forget about memory sticks. Get a cheap external 2.5" drive or use the virtual drive in af123's mods. I know, I know - this is for beginners....
     
  15. Black Hole

    Black Hole Felonius Gru

    I am thinking along the same lines. An external drive dedicated to Ext3 looks like the solution. I am trying to avoid running modified firmware at this point.
     
  16. grahamlthompson

    grahamlthompson Well-Known Member

    Try the free version of Easeus partition manager.
     
  17. Black Hole

    Black Hole Felonius Gru

    I'll give it a go, but see post #14.
     
  18. fenlander

    fenlander Active Member

    I have to say that auto-unprotect + virtual disk + samba make all these other processes seem cumbersome in the extreme. No foxy, no external sticks or disks, no format worries, no FTP - just copy files to the virtual disk then use your favourite file manager to put them wherever you want them. I'm playing HD files - decrypted Hummy files and .mkvs - directly from the Hummy via a samba share, so for most purposes it also makes the media server option irrelevant, too.

    What is it that meercat says...?
     
  19. Black Hole

    Black Hole Felonius Gru

    I know, but like I said the first stepping stone for those of a nervous disposition is to do it without modified software.

    I agree with your thoughts about Samba, it should make all the mucking about finding DLNA-compatible clients etc irrelevant. I'll be very happy if I can get WMC to play stuff (eventually).
     
  20. af123

    af123 Administrator Staff Member

    With mod 1.09 it will be even simpleser :) That version won't need you to use telnet at all if you don't want to. It has a simple web interface which allows you to install the full one and from there you can install additional packages.

    Need to do a bit more testing before I upload it but it's almost ready.
     
Thread Status:
Not open for further replies.