Black Hole's Trail Guide to HDR-FOX T2 Hacking

Black Hole

May contain traces of nut
Introduction: Readers must remember that this blog was started while the custom software was in early development - it has now developed to a slick and sophisticated add-on that virtually anybody can benefit from, as long as they have their HD/HDR-FOX T2 attached to their home network (and preferably also the Internet) and are prepared to use a PC (or other computing device) to access the web-based control panel. It is almost a no-brainer, the one remaining decision being "do I accept the very slight risk that I can't restore things to normal if I need to claim on the warranty". For me that means keeping standard for long enough to know the box hasn't suffered early failure and is therefore very likely to have a long and happy life. If you want to know what the custom software can do for you, take a look around the various introductions linked in the NEW READERS START HERE topic pinned at the top of the relevant forum sections (or in the signature panel at the bottom of each of my posts).
What follows is a careful step-by-step approach to "going custom", first exploring the issues and limitations of the standard firmware, what can be done to circumvent them without modification, at each stage limiting the intrusion to the minimum. It is largely irrelevant now the custom software is so user-friendly, but readers will benefit from understanding the reasons behind what the custom software does (and might stop asking basic questions all the time - "might" being the operative word!). BH

OK Folks, in response to AF123's "big up" for the idea of a non-programmer recording the experience as a helping hand for other newbies, here's my blog.

In order to keep the narrative thread reasonably unpolluted, I shall update the blog by editing the first few posts (there is a 10,000 character limit on each - Edit: not any more). Any questions or comments will then appear in other posts below this one and not interrupt the flow (easier to read instead of picking the bones out of a long topic). This has actually been transferred from a previous topic (for administrative reasons) and there are some replies already to be found here:

Remember: this is the Humax HDR-FOX T2 I am dealing with.

Remember also: I am not aiming to produce an idiot's guide, this is recording what I have done and putting down a trail of bread crumbs for others to follow if they wish.

Stage 1: Non-Hacked Access to HiDef* Recordings

* Due to the confusion between HD (Hard Drive) and HD (High Definition), I intend to stick to HiDef when that's what I mean.

What's the reason for this? Simple: the Humax encrypts the recordings on its hard drive. All of them. However, if you use the SUI (Standard User Interface - ie the remote control and on-screen menus) to copy a recording to a USB device, it obligingly decrypts the files unless they were HiDef. The first stepping-stone on the trail is to provide decrypted access to HiDef recordings as well, without interfering with the Humax in any way. We can do this by fooling it into thinking a HiDef recording is actually StDef, and decrypting it just the same.

Later stages will explore how to use modified software updates on the Humax to do all this within the box.

The steps in this stage of my development plan are thus:
  1. Use FTP to access the Humax file system*
  2. Pull the .hmt file (from the file set that comprises an HiDef recording) onto my PC (using FTP)
  3. Use the Foxy utility to clear the ENC (Encrypted) flag in the .hmt file
  4. Send the .hmt back to the Humax
  5. Format a USB stick in Ext3 (the only way it will be able to accommodate a file >4GB**)
  6. Copy the HiDef recording to the USB stick decrypted (because the ENC flag was cleared)
  7. Move it to the PC and do something with it
  8. Find out how much quicker it is writing to an external hard drive.
Note that this is an interim stage, initial explorations. Later stages with the modified Humax OS render Foxy irrelevant (the equivalent utility runs on the Humax itself, and no export of the .hmt file is required). Anybody wishing to take the plunge to the modded OS can bypass this stage and move straight on to Stage 2 (when I've explored and drawn up that part of the map).

* You could simplify even more and bypass the need for FTP, but that would involve copying the WHOLE file set (because that's all the Humax interface lets you do) to USB, then clear the ENC flag on the USB stick with Foxy on a PC, then copy the WHOLE file set back to the Humax and finally copy it ALL back to the USB stick again. Each USB copy of a HiDef file takes ages! Therefore I'm going straight for FTP!!

** For estimation, 1 hour of StDef occupies approximately 2GB. 1 hour of HiDef occupies approximately 4-5GB. My 346-minute recording of the Royal Wedding in HiDef is a 21.7GB .ts file!

Stage 1.1 - FTP Access

First of all I needed to network my Humax. You could just run an ethernet wire directly from the back of the Humax to your PC; other people have had success plugging a WiFi dongle into the Humax and accessing it by wireless network. I have mine connected to a HomePlug AV200 ethernet-over-mains adapter, which links to another adapter located near my ADSL router and then connected to an ethernet port on the router by wire. My router is also a WiFi base station so the Humax is accessible via WiFi. This set-up gives me access to iPlayer from the Humax, I didn't have to configure anything.

On the Humax the FTP server needs to be turned on. From the Menu button:

Settings.. System.. Internet Setting.. FTP Server.. ON​

Then, back-up with the Left button and visit:

Settings.. System.. Internet Setting.. Configure LAN​

Make a note of the IP Address - in my case:*

* I had DHCP set, which means the Humax requests an IP address from the router. I am told this means the IP address might be different every time you turn on, but in my experience it isn't - I think my router remembers what IP address it allocated to any particular connected hardware (possibly by MAC address) and allocates the same next time. If it causes you problems, on the Configure LAN screen you can select Manual instead of DHCP, and then choose your own IP address 192.168.x.y where x is typically 0 or 1 (follow your DHCP example) and y is in the range 1-255, but it must not conflict with anything else on the network.

Interestingly, I had to do a complete router reset and re-configure, and now the Humax is at! What I have done now is to take the settings allocated by DHCP and "freeze" them by changing "Configure IP" from "DHCP" to "Manual", and then clicking "Apply" at the bottom of the screen.

Update: I have now gone back to DHCP because there are situations with a manual IP address that can lead to network conflicts - the router might allocate that address while the Humax is off, and then when you turn it on... I do have fixed addresses though, because I have set the router to never unallocate it once set.

Now to access the Humax from a PC by FTP. You will need an FTP client program, I used to use "FTP Commander" (it has a nice Danger Mouse desktop icon!). Now I have "Directory Opus 10" installed, which is a (not cheap) Windows Explorer replacement with lots of bells and whistles including FTP, so the remote server looks just like another disc drive in a window with drag-n-drop file management. I recommend you try FTP Commander if you have no other FTP client in use.

FTP Commander v8.0 can be obtained from here:, and if I remember correctly runs as an exe without installation. When you run it, the left side of the screen is an explorer for your local file system, and the right side is a similar explorer for the remote (FTP) system. To start with you will have an empty server list. Click "New Server", and a box appears to set up the connection properties. Fill in as follows:

Name: Humax (or whatever you like)
FTP Server: (or whatever your IP address is)
FTP Port: 21 (default)
User ID: humaxftp​
Password: 0000 (unless you've changed it)
Passive Mode: NO (very important)
Save Password: YES​
Mask Password: YES (doesn't matter)
Anonymous Login: NO​

Click "Save", and an entry will appear in the server list "Humax". Click it, and you get the top directory in the Humax to explore.

I have had a tip, and have confirmed it, that Microsoft Internet Explorer will act as a rudimentary FTP client. Just put "" (or whatever your correct IP address is) in the URL bar, and you will be invited to log on with username and password details as described below. And then you'll try FTP Commander.

Update: I am now informed that Windows Explorer will also do FTP. I don't use Windows Explorer (Directory Opus replaces it), but it probably does the drag-n-drop stuff that Internet Explorer doesn't. Don't ask me how to work it though!

In my FTP client (Directory Opus) I set up the Humax address noted above (, user name = "humaxftp", password = "0000", and bingo - the Humax drive was available for me to explore.

If you want even more detailed instructions, here is a post in another thread using Filezilla:

One problem: you only get to see the raw file names, so it can be a bit tricky working out which file belongs to which recording, or more particularly if you have a series of programmes with similar file names, which file relates to which programme. Each recording comprises a set of 4 files: .ts .hmt .thm .nts; the .ts is the big one with the actual video/audio in it.

Stage 1.2 - Fetch the .hmt File

No problem now to pull the (small) .hmt file onto the PC (in my case by drag-n-drop).

Stage 1.3 - Clear the ENC Flag

The instructions for Foxy and the download link are here:

Note that (using Internet Exporer 8) I have had trouble with malware (if a message pops up offering to scan your system DON'T DO IT). Others have recommended using Firefox with scripts turned off. Note: when I downloaded the mod firmware (also from 4Shared), I didn't have any malware problem. Possibly 4Shared have evicted the trouble-maker, or it is one particular advert that doesn't always come up.

Foxy runs as a stand-alone executable (except according to the readme it needs the .NET framework which apparently is built into Win7 so that's OK then :) ). I actually put it in its own folder "Foxy" (unzipped of course), and dropped the .hmt file from Stage 1.2 into the same folder. I could equally well have used my desktop.

Double-click foxy.exe and a window pops up (with a picture of the Humax in it). All you need to do then is click and drag the .hmt file onto the Foxy window. It flashes a couple of times to let you know it's done something, and the timestamp on the .hmt file changes to now.

Stage 1.4 - Replace the Original .hmt File with the Modified Version

I then dragged and dropped the adjusted .hmt file back to where it was on the Humax by FTP (replacing the old one).

Stage 1.5 - Create an Ext3 Drive

I admit defeat on formatting a USB memory stick to Ext3 [Edit: not advisable, if using a stick use Ext2]. I tried once and trashed the stick - recovered using an HP utility mentioned in the other thread HERE (click). What I have actually done to make progress is buy a portable hard drive (Buffalo 320GB, £36 from Tesco). I plugged it into the Humax and then asked it to format the drive:

Settings.. System.. Data Storage.. Storage > drive1​


Settings.. System.. Data Storage.. Format Storage​

What surprised me was that it only took a couple of minutes to convert the FAT32 file system into Ext3. Note that if you do use this method to format Ext3, the Humax doesn't care about partitions - it will format the whole drive.

There is a caveat to this. After I had formatted very quickly on the Humax, I then used Linux (GParted) on a PC to partition the drive into halves and format one half Ext3 and the other NTFS. It has been mentioned that the Humax format has compatibility issues with other operating systems, so the fact that I reformatted probably saved my skin later. I am now also informed that the Humax format will only work on drives up to 1TByte.

Conclusion: best to format the drive to Ext3 using a Linux utility.

Stage 1.6 - Decrypt-copy a HiDef Recording

Now with the Ext3 hard drive connected by USB, I used Media to navigate to the HiDef recording I Foxyed - sure enough, the "Enc" flag was no longer showing, just "HD"! To actually decrypt it requires an Opt+ copy operation though, and that is where the Ext3 drive comes in. I selected "Copy/Move" from the Opt+ menu, then navigated to the USB drive and confirmed Copy with the red button. <Pause while copy operation is performed>

Caveat: see notes about proper dismount of an Ext3 drive:

Stage 1.7 - Play a HiDef Recording on a PC

OK, so now I have a theoretically decrypted HiDef recording on a portable drive formatted Ext3. What do I do with it? The problem is that the PC running Win7 won't read the Ext3 format unless I do something.

I could install an Ext3 driver (see supplimentary comments here:, and here:, but as this is interim I don't fancy fiddling with my OS. What I actually did was download the Ubuntu 11.04 iso and burn a live boot CD, then create a Ubuntu boot on the portable drive. With Ubuntu booted I can copy the video file to an NTFS partition on the PC.

As an alternative you could FTP the video file from the portable drive while it is plugged into the Humax directly to the PC. This is going to be much slower than walking the drive to the PCs USB socket.

What could I do with the file once accessible in Windows? VLC played it without sound, as did Windows Media Centre. That's fine, it proves the file was decrypted, and as this is only an interim solution I'm not playing about with codecs at the moment.

Stage 1.8 - Transfer Speeds

I don't know how long the same copy would have taken to a USB memory stick, but copying 5.86GB to the portable drive took about 34 minutes. It only took 3 minutes to get it into the PC! For comparison, I copied 6 half-hour (+padding) radio recordings to a FAT32 USB stick (which means 18 files - no thumbnail on radio recordings), totalling 1.7GB in 9 minutes. The surprise is that it is roughly 200MB/min either to USB hard drive or to USB Flash drive. However, the USB stick then took 1:40 to copy into the PC.

Out of interest I copied the same set of files (undecrypted) by FTP, and on my 11g (I think) link to the PC (AV200 from the Humax) the transfer took 14 minutes. However, for this method to be viable first you need to decrypt the files in the Humax, and we are in the realms of hacked rather than non-hacked.

Stage 2: Non-Hacked Streaming of StDef Recordings

Almost as soon as firmware version 1.02.20 came along, I hooked up my set-top streamer-in-waiting (DigitalStream DPS-1000) to see what happened. First of all you have to turn on media sharing in the Humax:

Settings.. System.. Internet setting.. Content Share > On​

The DigitalStream found the Humax DLNA* service OK, and played the content - but not without artifacts (disappointing). There has been some discussion that the Humax .ts files can be "corrected", but I have not tried it yet and who wants to correct the files (involving decrypt-copy to the PC, running the corrector, and putting the file back or to a NAS or streaming from the PC) before accessing them? Incidentally, I get the same artifacts if the .ts is decrypt-copied to a USB drive and played directly by the DS or plugged into my LG TV (so it's not a network issue), and the same file plays OK on a PC using Windows Media Centre. Annoying.

* DLNA - Digital Living Network Alliance, a standard which allows compatible devices to find each other's content and stream it without the user having to get into the nitty-gritty of network configuration.

Over the last couple of days I have made a couple of hit-and-run attempts to stream to my PC (in an effort to break my iPlayer habit and benefit everyone's Internet bandwidth). iPlayer (etc) is the way I see most of my telly, because I don't get the chance until bedtime and my notebook PC is my tool of choice, and when I doze off at least I'm in bed already.

So, as I like Windows Media Centre and prefer to use something I have already, I tried that. No luck, I couldn't find any controls that would access DLNA (I later read on a Google search that other people have the same annoyance and Microsoft don't seem to understand that WMC should do DLNA). Next choice is VLC, but although I could find options to open a network stream, DLNA is not on the list of protocols (possibly I have an old VLC, or more likely I don't know what I'm doing).

Next I tried Windows Media Player. Well, I normally avoid it by a country mile because whenever something has triggered it off it asks for some kind of installation, so I normally kick it into the long grass and reach for VLC. However, indications were that it could do DLNA so I let it do its thing for a change. Yay! It found the Humax server OK and showed me the files on it, but wouldn't play them. Research here and elsewhere said install the K-Lite codec pack, so I googled for it and downloaded the full version, installed it (mistake - too many options I didn't know how to answer. Maybe I should have gone for the basic version).

Now WMP would play the files, but very jerkily. Possibly I had the wrong options, or I need a graphics driver updated, I don't know but I do know I don't have the time to mess about. I have a universal "undo/redo" button on my PC - it's called RollbackRX and it does what Windows restore points should do (completely reinstates the system as was, and allows you to "return" to the future again) - so I just wound back and the WMP wizard + K-Lite install never happened.

I tried Splash Player Lite next (, and found that although it has been lauded for being able to play HiDef (decrypted) files, it isn't a DLNA client. Will be useful in the future though.

Finally, I got down the list to XBMC ( This is interesting, it's an open source project with downloads for all sorts of computers / OSs, and even stand-alone live boot from USB. I grabbed the Windows version and installed it. What you get is an interface that works very much like WMC, designed for a large screen and long viewing distance. To cut a long story short, it works!

Once it's running you have to Videos... Add source... Browse... Add uPnP, and then it picks up the Humax and it's files. It takes over your whole screen though, and the only way I have found so far to get control of my desktop is to program the "shut down" button as "minimise". No FF/RW control, so it's a pain sitting through adverts and padding, or finding the point where I dozed off the night before. Definitely not the last word!

New Info: With one very small piece of information, it becomes possible to stream to VLC (Network Stream option), or to download the file to PC and play it from there in Splash or VLC (VLC has the advantage of being able to start playback before the download is finished), and be able to FF/REW at will. The info required is the MediaID for the recording, which is buried in the DLNA process and requires either XBMC or a little tool called UPnP Inspector to find. Please refer to the relevant topic (click) and the wiki (click). The modified software makes this much easier. Update: the latest VLC is able to access DLNA on its own.

Stage 2B - Streaming of StDef and HiDef Recordings to an HD-FOX T2 (non-hacked)

As you may have read I cashed in on a bit of a give-away and acquired an HD-FOX T2 for playing with, with the intention of hooking it up to a projector (I have the Vivitek Qumi in mind) for bedroom viewing with or without an aerial feed. The Humax plus projector (and PC of course) would also serve as portable kit for any presentations or travel.

I broke it out today, and found I couldn't get past the installation screen without inconveniently giving it an aerial signal to scan. That done, I updated the firmware and found that it doesn't have the same procedure - it requires the front-panel power button to be held in until the update is detected on the USB port (of which there is only one, at the rear).

OK so far. Next: to add a network connection so it could see the HDR-FOX T2. Not having a convenient access point I tried a WiFi repeater box that I had handy, it might have worked if I persisted but I was having trouble with the configuration so I gave up and moved one of my HomePlug adapters. The other end goes to the HDR-FOX T2, so effectively I robbed that of a connection to the router and brought it straight to the HD_FOX T2. No DHCP server of course, so I had to configure manual IP settings and guessed the gateway address should be the HDR's IP address (it worked). I got a connection.

Selecting Media > Storage > Network found the HDR server (after a short delay), and then I was able to browse the content. Tried playing StDef, no problem. HiDef files had a "no entry" sign on them, but still played if I gave them time to start up. FF/REW doesn't work, and skip takes a long time to respond but it's better than nothing.



Since I acquired a Qumi projector for the bedroom I have been using the HD-FOX for my catch-up TV on a regular basis. I bought a WiFi adapter for it, but setting up the network password proved impossible using the HD-FOX interface (I have a long, complex key with too manu characters to enter before the menu times out, and includes characters which are not even available on the entry screen!) and the router isn't far away so I have wired it in.

Streaming recorded content from the HDR-FOX is no problem at all (the HiDef picture from the Qumi is great!), and although I remarked that skip is slow, using the right/left cursor controls enables me to skim through the time line and that's fine. Sometimes the HDR-FOX server doesn't start up and has to be rebooted.

Two major hiccups though: first, the TV Portal wouldn't run (you would think, connected to my network...). After a lot of messing about and help from the Forum, I twigged it was because the HD-FOX didn't know what the date was, being as it has no aerial. The solution is to provide it a time reference from the Internet, which meant installing the custom software (by necessity).

The second, more serious hiccup: HiDef playback kept breaking. It affected different recordings at different times but always the same recording at the same time. I put it down to a HiDef problem to start with, but then I had a StDef recording break (a long film). To cut a long story short (for details see HERE - click), the streaming client in the HD-FOX (and the HDR-FOX) has a programming bug which means it can't get past the 4GB mark in a recording file when accessed across a network connection. That's typically about 3 hours of StDef or less than 1 hour of HiDef.

I have reported this to Humax, it is a fundamental fault in the current firmware for the HD- and HDR-FOX (1.02.20) and really should be corrected (not fit for purpose), but in the absence of an official update the work-around lies in the MSP: network file sharing. CIFS can be installed on the HD-FOX and HDR-FOX, making the HDR-FOX's HDD navigable from the HD-FOX. That's not the whole solution though, because all it would see is encrypted files. Hot off the MSP press is background decryption, which squirrels away replacing any encrypted recording files it finds with decrypted ones. It means that HDR recordings won't be immediately available to the HD, but it's as good as we're going to get.

Background decryption also makes backing up very easy, so it's a no-brainer. I'll let you all know when I've actually done it!

Stage 3 - Exploring the Modified Software

Note: installing and using the custom firmware has been greatly improved since this was written. See the Quick Start Guide.

Gasp! Yes, I've actually done it (motivated by the desire to retune, and therefore back up my schedule first). As reported by others, the first steps have been remarkably painless - being a beneficiary of the BYTs making it so (and not diving in before it has been refined for the rest of us).

1. Download the 1.09 mods file (or whatever the latest one is) from here. You need one to match your current main firmware - in my case 1.02.20. Put it onto a USB stick - in my case a Medion (Aldi own-brand) 8GB - and rename it "hdr_fox_t2_upgrade.hdf", then I plugged it in the front port and powered up (I also have a Buffalo Ministation plugged in at the rear - ooerr missus). The Humax immediately started the update process no problem. I then whipped out the stick (ooerr again) and rebooted.

2. Over to the PC and put the Humax IP address into the Internet Explorer address bar - in my case IE8 automatically top & tailed it to, and the minimal web interface came up (as shown here), now added to my favourites bar. Only then did I have a slight set-back. I clicked the "download and install..." button and waited, but nothing seemed to happen. I hadn't bothered to read the manual, so I assumed it must have done something in the background and wondered how long to leave it. After getting on with something else and still no change after a page refresh, I decided to reboot the Humax. I then reloaded the web page - just the same. So I clicked the "download and install..." button again. And again... and then I got the scrolling list of packages being downloaded and installed, and at the end an instruction to go and reboot the Humax. I thought we had a way to reboot it on the web interface now? Why can't we have a reboot button at the end of the downloads?

3. Once rebooted and the web page refreshed again, we're into the pretty interface. Not done anything with it yet other than have a look around (like the EPG!), but I am stumped why the disc usage gauge at top right says I have 149G total and 6G used - my internal disc is 500GB, and the plugged-in Buffalo is 320GB. (PMN: I worked it out in the end - I had the Buffalo split into two partitions and the gauge was reporting one of them. With the Buffalo unplugged the gauge reports my internal drive. This may be corrected in more recent updates to the web interface.)

Stage 3B - Updating the Modified Software

Problem: My main transmitter went through another stage of DSO a few days ago, so I've lost access to a lot of channels; also I've fallen badly behind with MSP firmware (maybe 1.09, definitely not later than 1.10) and software updates (anybody unsure of the terminology needs to look at the Glossary of Terms (click)).

Solution: Full update of the MSP (1.11), use the debugged Schedule Backup to save my existing recording schedule (which would otherwise be destroyed and have to be recreated by hand after the retune), run a manual retune (because I can pick up signals from three transmitters), then restore the schedule from the backup.

Recalling Stage 3, you will notice I have been motivated into action by yet another enforced retune! Last time however, I didn't entrust schedule backup with the job and made a quick note of the programmes set to record. This time there has been significant time to get any bugs out of schedule backup/restore, so I'm going to go for it.

I downloaded version 1.11 (see Stage 3 for details), copied it onto a USB stick and gave it the required file name. I have, recently, come across one of my old (low capacity - 128MB!) sticks, and had intended to reserve it for Humax firmware update purposes, so this was the first time to try it. However, before installing I wanted to make sure all the MSP software (as opposed to firmware) would also update, so a little more preparation work was required.

In discussion, I had established that it was unnecessary to revert to unmodified firmware 1.02.20 first, and that the software update could be achieved by either running a command-line package update after the firmware update, or by deleting all the MSP files before the firmware update and then using the web interface to download everything again. I decided to do the latter (which still involves the command line and therefore a Telnet session. AF123 - would it be possible to put a "total package refresh" in the web tools? Update - there is now!).

To delete the MSP I started a Telnet session (see footnote) and opened a connection to the Humax "o" (or whatever your IP address is). I got the Humax prompt "Humax#" and could "ls -l" to see the top level directory. Removing the /mod directory proved a bit of a challenge (to me!) so I called for help and was told "rm -rf /mod/*".

Now to run the firmware update. I put the stick into the USB socket and rebooted. Bad move! This was one stick the Humax ignored at boot-up! Back to a tried and tested stick :(. Another stick worked fine, the firmware update loaded, and I rebooted (with the stick out). Next to open a web browser window, and that showed me the expected minimal web interface with the "Install Now" button, which all went perfectly (unlike the minor hiccup last time). Another reboot (why is there no button to do that on the install web page??) and reload the web page, and the full interface came up. Lovely.

Using the web interface I brought up the recording schedule listing, and for safety saved the web page for later reference if I needed it (saves noting it down!). I then used the backup option, and proceeded with a manual retune (see here - click). That done, I went back to the web interface and restored the recording schedule previously saved. Perfect!

Footnote: How to Enable Telnet in Windows7

At some point in my blog I'm going to be using the command line on the Humax (I just know it!) - already have done a few little exploratories, and I needed Telnet to open a command console window from my PC. One way is to download and run "putty.exe", but Windows7 (and probably others) already have a Telnet client if you know where to look for it (and by a stroke of good fortune the current issue of PCPlus told me exactly how).

So: to enable Telnet - Start.. Control Panel.. Programs.. Programs and features.. Turn Windows features on and off.

You will have to enter the admin password at some point, if you are not logged in as admin (never a good idea).

Scroll down the list (may take a while to appear) and tick the box for "Telnet client" (not server), then OK out of it.

Now you can click Start and type "telnet" in the search box, telnet.exe will be listed and clicking that brings up a command window. As long as you know the Humax' IP address (see earlier in the blog) the command "o <IPaddress>" opens a connection to the Humax and produces a Linux command prompt "Humax#". Now you can cd, ls, cat (and all those other UNIXy commands).

You will almost certainly find that the "Humax#" prompt is doubled up after every command, and some commands may not work properly at all. This is because of an incompatibility between Microsoft protocols and Linux protocols. Linux treats either a CR (carriage return) or LF (line feed) character as an end-of-line. MS-DOS (and its decendants - ie Windows) expects and sends a CRLF pair at the end of each line - hence Linux sees it as two end-of-lines, the second line being blank. To avoid this, when you start Telnet (before the "o" command to open a session to the Humax), type "unset crlf".

Stage 4 - NTFS Drives

I have read elsewhere that people are using an Ext3 driver on Windows PCs so they can plug in their Ext3 USB HDD from the HDR/HD-FOX and access just the same as any other drive. I much prefer the idea of using an NTFS format drive (which works with Windows out-of-the-box), but as stands the HD/HDR-FOX can't write to one. (Reminder: if you have files greater than 4GB - which is less than an hour of HiDef recording - FAT32 is not good enough and you have to use ext3 or NTFS.)

The MSP has the answer in the form of an NTFS driver available in the installable packages. I bought another USB HDD (Hitachi 500GB this time), and it came already NTFS-formatted. I installed the ntfs-3g package from the web interface. Now I have an Ext3 drive and an NTFS drive plugged into my HDR-FOX T2 (front and rear USB sockets), and I have used the OPT+ button to do a bulk copy from the Ext3 to the NTFS.

There are a couple of wrinkles. First, I had a problem with the copy of one of the files right at the end of the list. It appeared to copy, but it did so very quickly and the resulting file is corrupt. I have yet to track down the problem, the source file may have been corrupt, but I am skeptical in that by coincidence it was the last file to transfer. Second, the web interface (currently) does not correctly report the state of the StDef/HiDef flag on the files (AF123 is going to correct this, it is due to the way NTFS drives are accessed from the operating system).

In my opinion this is the way to go. A minor problem with the web interface no doubt easily rectified, and a dodgy copy (who hasn't had one of those?), but a portable drive which can be accessed on a PC without issues.

This won't be quite so easy on an HD-FOX. For a start, the MSP installs on the external drive so it can't be NTFS - you will need a USB port multiplier to have the MSP on an Ext3 drive or Ext2 stick, and the NTFS as another drive. I have talked about the idea of writing the MSP files to an NTFS drive by another means, and then using the native read capability of the Humax to load the MSP from it and thus gain the ability to write to the NTFS... but I'm not sure whether it would take without a reboot, and in the process of rebooting you are back to square 1.

AF123 has picked this up and is talking about integrating the NTFS driver into the core Custom Firmware (the part that is loaded as an .hdf firmware update). This would mean full NTFS access from boot without having to install the ntfs-3g package and load it from an external drive (or the internal drive on an HDR-FOX). This means the HD-FOX would be able to have an NTFS external drive fully accessible as the only connected drive, although whether it could be made to record programmes remains a subject for research (and, of course, they would be encrypted). [Update: there has been no further progress on this, as it is unclear whether the advantages would outweigh the disadvantages, and the CF would require considerable massaging to make it compatible with being hosted on NTFS.] be continued
Just to boost this topic up the most recent list (rather than the deprecated topic), I'll bump this. If anybody is following progress, for completeness I'm going to time the transfer of a smaller file to a USB stick (because of the FAT32 4GB limit) and then I'm done with Stage 1.

Can somebody lock the other one please?
(Hopefully returning the favour ...)

@stage 1.7 - I have successfully used the "Ext2 Installable File System for Windows" (google it- not sure if off-forum links are OK.) This is a Windows (all versions all bit-sizes) kernel mode driver, and it not only works very well, it beats the pants off of the limitations in Paragon's ExtBrowser for Windows. Both are free. The Ext2 IFS has a simple windows install/uninstall and even a control panel icon to set the drive letter. And it works in both read and write perfectly, making the drive appear and behave in windows explorer just like any other e.g. cut&paste. drag&drop, properties etc.
One minor snag, for backwards compatability with older Linux kernels it only supports 128b inodes at the moment. It turns out that the Fox T2 uses a newer Linux kernel that formats the USB drives with 256b inodes. The driver won't wont mount these (for backwards ...) for the moment. The answer is simply to format as Ext3 it using something else (I happened to use Paragon's HDM); and as far as the HDR is concerned, it's all fine.

Once it's mountable in this way, it can be directly accessed by VLC or copied elsewhere without needing FTP (not saying that FTP is a problem in any particular way). I've even loaded the driver on a Windows Home Server box and attached the drive using its eSCSI interface.

Just gives us all some extra options, if anybody needs them ...
Minor addedum to my notes above:

Ext3 is a journalising IFS, so it's preferable to ensure you get a 'clean' dismount of the disc, with no outstanding transactions in the journal. Otherwise the Ext2IFS driver may not mount the drive, or may only do so in read-only mode.

The analogous normal 'rules' in windows with USB drives apply here too - a 'safe' removal is always ideal. if you _know_ that there are no outstanding writes you may well 'get away with' just unplugging it - the Humax says something link 'USB device has been removed'.

For a 'clean' dismount and subsequent remount elsewhere, use the USB Eject on the hidden System Info page of the menu. (See AF123's threads)
(Hopefully returning the favour ...)

@stage 1.7 - I have successfully used the "Ext2 Installable File System for Windows" (google it- not sure if off-forum links are OK.) This is a Windows (all versions all bit-sizes) kernel mode driver, and it not only works very well, it beats the pants off of the limitations in Paragon's ExtBrowser for Windows
I use ext2fsd. It works well and is free also. Get from
I have had a tip, and have confirmed it, that Microsoft Internet Explorer will act as a rudimentary FTP client. Just put "" (or whatever your correct IP address is) in the URL bar, and you will be invited to log on with username and password details as described below. And then you'll try FTP Commander.

Update: I am now informed that Windows Explorer will also do FTP. I don't use Windows Explorer (Directory Opus replaces it), but it probably does the drag-n-drop stuff that Internet Explorer doesn't. Don't ask me how to work it though!

IE can also use the form ftp://humaxftp:0000@<ipaddress>; yes, username/password are sent in the clear (they are anyway unless you use SFTP), but if you're using cabled ethernet or powerlan, or WPA/2 Wifi, it may not matter to you. When you drill down the directory structure in IE to a file and click on that, you will be given a variant of the Windows Open/Save dialogue. Not the friendliest, but it does work to copy things.

Like Black Hole says, this can be 'integrated' into Windows Explorer, where it become noticeably friendlier. The easiest way to do this is to create a new 'Network Place' to represent the FTP connected directory on the Humax; but to do this on XP SP3, you'll first need to do Tools->Folder Options->Use Windows Classic Folders in Windows Explorer. This will then allow you to see the 'Add Network Place' wizard icon in 'Network Places'.

Running the wizard it will prompt you to 'specify the address of ... an FTP site' ->Next->Internet or network address in the form ftp://humaxftp:0000@<ipaddress> ->Next->Type a name for this Network Place e.g. Humax HDR->Successfully created/Open this network place when I finish. Leaving the latter checkbox set, Windows explorer will open a new window showing you the 3 My Videos/Photos/Music directories (and also drive1 if you happen to have a USB drive plugged in as well).

Thereafter there will be a Network Place folder called e.g. Humax HDR in the Network Places in Windows Explorer. Expanding that directory will connect FTP behind the scenes and show you the above directories. As Black Hole suggested you can then do 'that drag'n'drop stuff' directly (causing the corresponding push/pull FTP transfer behind the scenes).
Thanks for the above. I don't expect to be trying it out (because of DOpus), but if your instructions give Windows Explorer similar functionality that is the way to go.
Stage 3 - Exploring the Modified Software


...and then I got the scrolling list of packages being downloaded and installed, and at the end an instruction to go and reboot the Humax. I thought we had a way to reboot it on the web interface now? Why can't we have a reboot button at the end of the downloads?

...I am stumped why the disc usage gauge at top right says I have 149G total and 6G used - my internal disc is 500GB, and the plugged-in Buffalo is 320GB.
Anybody care to take up the gauntlet on these two?