Box Freezing

JGHummy

Member
Hi all
About a month ago I installed CF3.03 (prev on one of the CF2s can't remember exact version)
The only change to packages I made was I installed detectads
Since then I have missed recordings and box freezing (no response to remote or front panel have to switch off using switch on back)
Is their any possibility something in CF3.03 could be causing this?

Thanks
 

MymsMan

Ad detector
Have you detected any pattern in the freezes?

Does it occur when processing files with DetectAds? You can check the detectads.log for programs that start processing but don't complete - the last line should look like:
Code:
01/12/2015 17:59:58 DA(543)- done...processed /media/My Video/The Chase/New_ The Chase_20151201_1659.ts in 3512.985s 00:58:33 - 5 ad breaks detected
I too suffer occasional freezes but have not been able to determine what could be causing them - most appear to occur a random when detectads is not running.

Detectads is quite a processor intensive program so it has the potential to cause problems but so far no-one has managed to locate a pattern for freezes other than using iplayer which can cause problems for some users.
 

Black Hole

May contain traces of nut
There is no pattern that I can see in my freezes, all three of my HDR-FOXes freeze from time to time and on different versions of firmware with different collections of packages and different usage patterns, at random times of day. detectads is only running on one of them, and it doesn't crash any more often than the others.

I have accepted it as "one of those things", part and parcel of HDR-FOX ownership. If the OP is so sure it is to do with having custom firmware installed, uninstall it and wait for the inevitable freeze on stock firmware.
 

Wallace

Traveler 34122
I agree with BH. I have reported random box freeze on one of my HDRs. They appeared to be getting more frequent, so I posted about it on here.

However, I have not had a lockup since 4th November.

One thing I would mention is that the box does get 'hammered'. I use it for SWMBO and we regularly watch programs 'time shifted' while they are recording. Many programs were set to follow on. I.E. back-to-back. SWMBO could not be on time for anything! We also had recursive SHRINK and DECRYPT enabled at the top level. I have now disabled SHRINK to try and take some workload off the unit. Whether that has helped I don't know. It is hard to say as they were random lockups anyway.

FWIW I do not have detectads installed.
 
Last edited:
OP
J

JGHummy

Member
There is no pattern that I can see in my freezes, all three of my HDR-FOXes freeze from time to time and on different versions of firmware with different collections of packages and different usage patterns, at random times of day. detectads is only running on one of them, and it doesn't crash any more often than the others.

I have accepted it as "one of those things", part and parcel of HDR-FOX ownership. If the OP is so sure it is to do with having custom firmware installed, uninstall it and wait for the inevitable freeze on stock firmware.
Hi
Box has just frozen again whilst scrolling through media - video
3rd day in a row
I would like to uninstall temporarily the CF to eliminate it
What is best way to do this please?
 
Last edited:

Black Hole

May contain traces of nut
Flash it with standard firmware. The stuff on the HDD will remain in place and re-activate when you flash the custom firmware again.

When (if) you want to ditch the full set, set RMA mode from the Diagnostics page, then flash standard firmware.

Box has just frozen again whilst scrolling through media - video
3rd day in a row
You didn't say that before. What you have is a dodgy recording file - all you have to do is find it and delete it.
 
OP
J

JGHummy

Member
Flash it with standard firmware. The stuff on the HDD will remain in place and re-activate when you flash the custom firmware again.

When (if) you want to ditch the full set, set RMA mode from the Diagnostics page, then flash standard firmware.


You didn't say that before. What you have is a dodgy recording file - all you have to do is find it and delete it.
Hi
Sorry that is only what happened today other freezes have been different
EG not responding when starting up , not responding after running 4 or so hours, not recording because (I think has frozen overnight)
 

MymsMan

Ad detector
Do we know exactly what causes this? Surely an automated way of dealing with these could be devised if so.
Before we can start to think of automated fixes we need to be able to apply a fix manually, and before we can apply a fix manually we need to know what we are trying to fix and unfortunately we are sadly lacking in diagnostics that could tell us what is causing these apparently random hangups.

When you have an unhappy family missing their favourite programs the priority is to get the system up and running again rather than trying to work out exactly what happened :(

It is a pity that some of the log files that might show what was has happening (e.g. humaxtv.log) are over written on reboot so there is no way to see what happened before the crash/freeze
 

Black Hole

May contain traces of nut
I think prpr was talking about crashes caused by dodgy files. It would be possible to scan for those, if we knew what was wrong with them.
 

MymsMan

Ad detector
I think prpr was talking about crashes caused by dodgy files. It would be possible to scan for those, if we knew what was wrong with them.

Do we even know if some of the random crashes/freezes are being being caused by dodgy files?
When it appeared that OP had similar crashes 3 days running that seemed possible but less so now!
 

Black Hole

May contain traces of nut
I had an interesting and unusual "freeze" today: "BBC Red Button" still scrolling on the display (it normally stops dead), TV output showing a live picture (time and date on the Red Button service slide updating and correct), but no response to any front panel control or the handset, and a dead WebIF.
 

MymsMan

Ad detector
Did you have access to the box via telnet or samba share?
If you did you might get a chance to see whether the humaxtv process was still running and/or see see if there was anything interesting in the logs that are overwritten on restart.
 

Black Hole

May contain traces of nut
Samba wasn't working (that's how I knew it had crashed), but I didn't think to try Telnet. Crash.log doesn't look like it recorded the event.
 

Black Hole

May contain traces of nut
!

(A different one) was just sitting there (viewing The Chase, as it happens), and it rebooted then went into standby!

The crash log just says it crashed (really?!!), the activity log says it booted - as a scheduled event (yeah, right).

Anything else useful?
 

MymsMan

Ad detector
!

(A different one) was just sitting there (viewing The Chase, as it happens), and it rebooted then went into standby!

The crash log just says it crashed (really?!!), the activity log says it booted - as a scheduled event (yeah, right).

Anything else useful?
I have had a few crashes like this, if there was anything useful logged beforehand that would have been overwritten during the restart :(

What is especially annoying is that the system doesn't restart any recordings that were in progress at the time of the crash - if it did you would end up with two recordings with a small piece missing between the two halves which would be a nuisance but a lot better than missing the entire second half of the program!

This is something that potentially could be fixed via the custom firmware recognizing that there had been a crash and inserting a new entry into the recording schedule
 

Black Hole

May contain traces of nut
This is something that potentially could be fixed via the custom firmware recognizing that there had been a crash and inserting a new entry into the recording schedule
You've not got your thinking head on this morning.
 
OP
J

JGHummy

Member
Hi all
I am not sure if this is the way to update my posts
I have not changed any thing since my original post trying to get some pattern

Now about 30 mins ago I did a restart from the Webif to get rid off some expired stuff in schedule and got the page that contains the following

"To install the full web interface and supporting packages a suitably formatted internal hard disk must be present and none was detected."

I have rebooted using switch on the back of the box
now I cannot access any recordings using media button on remote
I would appreciate any guidance on how to proceed from here
Thanks
 

HarveyB

Active Member
Have you added anything else to your network later. It's been established that certain software (eg some Twonky DLNA server software versions) can cause this.


Sent from my iPad using Tapatalk
 
Top