Box has Died


New Member
Hey guys, just looking for ideas and possible solutions before I throw this box away...

I got home 2 weeks ago from work and the dim orange ring light was showing to say it was in stand-by. However the box wouldnt respond or come into life. So I turned it off at the wall and back on, but then nothing! Not even a light on the front anymore and wouldnt respond to anything.

I tried a few times to turn it off and on, but still nothing. So I left it most of the evening then suddenly (prob about 2 hours later) it suddenly booted up and worked normally all night.

The next morning it was dead again and it has shown no signs of life since.

Does anyone know what the prob might be? Whats the best way to fix this or do I need a new box?

Any ideas, suggestions or comments are appreciated.

I would say it depends on your technical background, If you are O.K. with taking the lid off and searching for dry joints (badly soldered connections), it's worth a try
Im quite happy to take it apart, and actually did this last night (Ive got nothing to lose now anyway).

I just have no idea what I'm looking for or what I'm doing. I have been speaking to someone about the dry joints, so can look carefully for that now. Not sure what I am looking for with the blown capacitors? Is it worth uploading a picture? I can get a very clear, large shot on my camera?
But not all 'failed' capacitors show any sign of deformation.

You could really do with checking the voltages, but be vary careful as LETHAL voltage is present when the cover is removed. As you have already stated that you don't know what you are doing or looking for, I recommend you entrust the job to someone who does.

There is a chap, Andy Frazer (andyfras) over on the Toppy forum who repairs PSUs taken from Topfield units. He is very well thought of and really is good at what he does. Perhaps he can offer guidence?
Thanks for the feedback guys. I will check this out tonight and see if I can at least diagnose the issue in the first instance, then can decide the next step from there.

I will report back.
Have looked at both the capacitors and the soldering joints, but cannot see any physical signs of problems, so not sure what the problem could be?

May have to consider taking it into a repair place somewhere, or just ditch it and buy a refurb replacement.
Mine went into a similar state last night. I managed to get it working again this morning by reinstalling the firmware, 1.02.32 mod 2.21.