1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Box stuck in RMA mode after resetting from Webif

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Paul Vickery, Dec 3, 2012.

  1. Paul Vickery

    Paul Vickery New Member

    Hi all,

    I have a problem with my HDR-FOX-T2. I had version 2.13 of the custom firmware installed, on version 1.02.29 and wanted to remove it in order to clear the box for possible return to manufacturer. I used the RMA mode option in the web interface, which appeared to do the trick, but now means that whenever I boot up, it shows "== RMA ==" on the display. I tried installing an older version of the official firmware (1.02.07) and then re-installed 1.02.29 and then tried the custom firmware again, both 2.13 and 2.14. The custom firmware doesn't work anymore (i.e. going to the box from a web browser shows "Page not found"), and continues to show the display as above.

    Does anyone know:
    a. what is supposed to happen when using the RMA mode option in the webif?
    b. how to clear out the RMA mode that so I can start again?
    c. will Humax accept the unit back if it shows the "== RMA ==" message?

    Thanks,

    Paul.
     
  2. Black Hole

    Black Hole Felonius Gru

    What was the state after you loaded official firmware before you added the custom firmware again?

    Loading the official firmware should wipe out the custom firmware from non-volatile memory, although on its own that would leave non-functioning traces on the hard drive.
     
  3. af123

    af123 Administrator Staff Member

    a) After using RMA mode, the box will always show == RMA == on the front panel after boot if the custom firmware is still installed, and the custom firmware environment will not be initialised (so there will be nothing custom on the hard disk). You need to then install the official firmware at which point the box will behave as normal and all traces of the custom firmware should have been removed*
    b) install the latest firmware and the telnet menu will give you an option to reset the RMA mode.
    c) I doubt it : ) Once you're seeing that message, install official firmware to get back to a clean state.

    * - at least in terms of the files created by the standard custom firmware packages.
     
  4. Paul Vickery

    Paul Vickery New Member

    Thanks guys. I'm fairly sure I didn't get the RMA message after reloading the official firmware, but I'll try re-loading it again tonight and see what I get, and then try the custom again, and report back to you tomorrow.
     
  5. Paul Vickery

    Paul Vickery New Member

    OK guys, here are the results:
    - installed official 1.02.29: no RMA mode message
    - installed custom 1.02.29/2.14: boots up, shows 2.14, shows BBC One, then shows the RMA mode message
    I can't access the box via Web browser or Telnet. (I can ping it, so it's definitely on the network).
    Any more suggestions? Is there any other way of resetting the RMA mode other than from the web interface?
     
  6. HarveyB

    HarveyB Active Member

    But if you are trying to get it to a state of no Custom Firmware, so that you can return the box, surely just installing the standard firmware is all you need to do now.
    If i understand af123 correctly, The RMA message is telling you that the CF files have gone so just installing the standard firmware removed the bit that sits in the BIOS.
    Your test showed this (no 2.14 display on boot up, no RMA message either).


    Sent from my iPad using Tapatalk
     
  7. af123

    af123 Administrator Staff Member

    You can't reset RMA mode from the web interface - by definition the web interface is no longer installed or running in RMA mode. The intended way to reset it is to telnet in and select the appropriate option from the menu, but if you can't telnet in then I can prepare a package for you that you can put on a USB stick to force a reset. Have you double checked that the IP address hasn't changed via the on-screen menus? Telnet should definitely be running in RMA mode with the custom firmware installed.
     
  8. af123

    af123 Administrator Staff Member

    If you put the file at http://hummypkg.org.uk/hdrfoxt2/derma_1.0.0_mipsel.opk into the root of a USB drive and then plug that drive in while the Humax is up and running, it should reset RMA mode for you. A log file should be created on the USB drive. Once it has stopped flashing, try rebooting once more.
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    I have documented the derma_1.0.0 file in WiKi packages HERE , with some notes HERE
     
  10. Paul Vickery

    Paul Vickery New Member

    It's sorted.

    Couldn't get the opk to load from USB - probably my cheap promo USB drives! Tried reloading official then custom again, and this time managed to telnet in, and that then gave me the option to reset the RMA mode.

    Now I can start all over again!

    Many thanks for your help - I picked up a lot of useful things along the way!
     
  11. PSOK

    PSOK New Member

    Hi all
    I'm having a similar problem. I have downloaded the "derma" file onto a USB stick but when I plug it in the system doesn't seem to pick it up. it sees the stick and other files but doesn't automatically pick up the file and execute it. any ideas?
     
  12. af123

    af123 Administrator Staff Member

    Get access to your box's telnet menu then choose the 'rma - Reset RMA mode.' option.

    If the option does not appear then choose 'run diagnostic' and enter 'resetrma' as the diagnostic name.

    Alternatively you could do the official post-RMA process and install the official firmware. After that you can install custom again if you wish.
     
  13. PSOK

    PSOK New Member

    thank you so much!
     
  14. Black Hole

    Black Hole Felonius Gru

    ...but you do need Telnet (which you said you couldn't do in another topic). Telnet is an occasionally essential tool when playing with the CF.
     
  15. PSOK

    PSOK New Member

    Black Hole, please note my previous comment about Telnet. to get it working I had to temporarily disable my Bullguard firewall. it was blocking use of Telnet