Broken software on my Hummy - please help


New Member
Have been using my Fox T2 for the last couple of years with custom firmware and loving it. Recently an attempt to tidy up some of the series /episodes on the HDD led me to try and download Sweeper package. It's fair to say i haven't updated the firmware for a while as I learnt early on that auto-updates can break a working device.

So I tried to add Sweeper using the webif gui but it didnt work and suggested perhaps i needed to run opkg update first. I tried that but it didnt work. It throws this error:

Downloading hpkg_tv/hdrfoxt2/base/Packages.gz.
wget: server returned error: HTTP/1.1 403 Forbidden
Collected errors:
* opkg_download: Failed to download hpkg_tv/hdrfoxt2/base/Packages.gz, wget returned 1.

(note had to meddle with the urls to be able to post on forum)

Bit of googling led me to a thread (i can't link to) and thus I ran the following commands:
humax# opkg remove --force-depends jim
humax# opkg install --force-downgrade hummypkg_org_uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk

The removal worked but the downgrade failed with the same 403 error.

So now going backwards. No Jim, No webif.

Trying to reinstall webif from the browser fails due to 403 errors.

I was messing around trying to see if i could get wget to work and it did managed to get it to work if passed the "-U str" agent-string switch. I see no similar option for opkg install or update though and i'm beyond the limit of my unix knowledge!

I don't know why it works with this switch but i' thinking this is the root of the problem.

I did try to download the packages manually with wget and then run them locally but i couldn't get this to work.

The humax is connected to the LAN just fine and used to have internet access where the package updates downloaded just fine. Currently the TV portal doesn't work again suggesting limited internet connectivity.
I have recently changed broadband provider though im still using the same router/settings.

Am rather stuck - Please help!

[ Humax HDR-Fox T2 (humax) 1.03.11 / 2.22 ]