1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot access outside LAN after update

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by bh23456, Dec 3, 2011.

  1. bh23456

    bh23456 New Member

    Hi

    I followed the update for the custom FW 1.14 on my HDFOXT2, box rebooted and i went to the 'Full Web UI' updater, which installed fine without issues. But after a reboot i noticed that i could no longer access iPlayer (or anything else from outside of my LAN). DLNA and anything else within my home is fine.

    Looking further, using telnet

    Code:
    wget https://www.humaxtvportal.com/ --no-check-certificate
    Downloading http://hummypkg.org.uk/hdrfoxt2/base/Packages.gz.
    Collected errors:
    * opkg_download: Failed to download http://hummypkg.org.uk/hdrfoxt2/base/Packages.gz, wget returned 1.
    
    Error retrieving package list from the Internet. Please check your connection
    and try again. 
    Similar issues if i try and ping outside my LAN, i have checked my DNS and that seems fine
    First internally
    Code:
    humax# ping -w 5 192.168.0.10
    PING 192.168.0.10 (192.168.0.10): 56 data bytes
    64 bytes from 192.168.0.10: seq=0 ttl=64 time=3.318 ms
    64 bytes from 192.168.0.10: seq=1 ttl=64 time=1.332 ms
    Then externally

    Code:
    humax# ping -w 5 74.125.39.147
    PING 74.125.39.147 (74.125.39.147): 56 data bytes
    
    --- 74.125.39.147 ping statistics ---
    5 packets transmitted, 0 packets received, 100% packet loss
    Then to URL, which never returns any information, just hangs the telenet session

    Code:
    humax# ping -w 5 www.google.com
    Everything before i did this update was fine, i am confident that i do not have network issues. What in Linux can cause me to to be able to get outside of my LAN?

    Here is what i have in resolv.conf
    Code:
    humax# cat resolv.conf
    nameserver 127.0.0.1
    nameserver 8.8.8.8
    nameserver 8.8.8.4
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    humax#
    
    Here is what i have in my hosts file
    Code:
    humax# cat hosts
    127.0.0.1      localhost
    192.168.0.5    humax
    humax#
    
    Here is my /tmp/rsvsync.log

    Code:
    humax# cat rsvsync.log
    Opening /var/lib/humaxtv/rsvp.db
    Failed: unable to open database file
    humax# 
    And here is the /tmp/modinit.log

    Code:
    humax# cat modinit.log
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.0.0    *              255.255.255.0  U    0      0        0 eth0
    default        192.168.0.1    0.0.0.0        UG    0      0        0 eth0
        Interface: [eth0]
        IP: [192.168.0.5]
    === diag =================================================
    Filesystem                Size      Used Available Use% Mounted on
    rootfs                  15.2M    15.2M        0 100% /
    /dev/root                15.2M    15.2M        0 100% /
    tmpfs                    61.0M    24.0k    61.0M  0% /tmp
    tmpfs                    61.0M        0    61.0M  0% /media
    /dev/mtdblock1            2.0M    420.0k      1.6M  21% /var/lib/humaxtv
    /dev/mtdblock2            2.0M      1.2M    812.0k  60% /var/lib/humaxtv_backup
    /dev/sda1                55.0G    220.5M    52.0G  0% /media/drive1
    
    eth0      Link encap:Ethernet  HWaddr 00:03:78:9B:FC:7F
              inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:3 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:762 (762.0 B)  TX bytes:1188 (1.1 KiB)
              Interrupt:16
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
      PID USER      VSZ STAT COMMAND
        1 root      1248 S    init
        2 root        0 SW  [migration/0]
        3 root        0 SWN  [ksoftirqd/0]
        4 root        0 SW  [migration/1]
        5 root        0 SWN  [ksoftirqd/1]
        6 root        0 SW<  [events/0]
        7 root        0 SW<  [events/1]
        8 root        0 SW<  [khelper]
        9 root        0 SW<  [kthread]
      10 root        0 SW<  [kblockd/0]
      11 root        0 SW<  [kblockd/1]
      12 root        0 SW<  [khubd]
      13 root        0 SW<  [kseriod]
      14 root        0 SW  [pdflush]
      15 root        0 SW  [pdflush]
      16 root        0 SW<  [kswapd0]
      17 root        0 SW<  [aio/0]
      18 root        0 SW<  [aio/1]
      19 root        0 SW<  [ata/0]
      20 root        0 SW<  [ata/1]
      21 root        0 SW<  [ata_aux]
      22 root        0 SW<  [scsi_eh_0]
      23 root        0 SW<  [scsi_eh_1]
      24 root        0 SW  [mtdblockd]
      25 root        0 SW<  [kpsmoused]
      27 root      1244 S    /bin/sh /etc/init.d/rcS
      73 root        0 SWN  [jffs2_gcd_mtd1]
      74 root        0 SWN  [jffs2_gcd_mtd2]
      120 nobody    936 S    /usr/bin/dnsmasq
      125 root      812 S    /bin/utelnetd -l /bin/sh -p 23 -d
      140 root      1244 S    /bin/sh /etc/init.d/S90settop start
      150 root      303m R    /usr/bin/humaxtv
      165 root        0 SW<  [scsi_eh_2]
      166 root        0 SW<  [usb-storage]
      290 root      1256 S    udhcpc -t 5 -T 10 -p /var/lib/humaxtv/udhcpc.eth0.pid -i eth0
      310 root        0 SW<  [kjournald]
      314 root      1248 S <  /bin/sh /etc/mdev/run-and-gun
      326 root      1248 S <  /bin/sh /sbin/modinit
      333 root      1240 R <  ps -w
    
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.0.0    *              255.255.255.0  U    0      0        0 eth0
    default        192.168.0.1    0.0.0.0        UG    0      0        0 eth0
    
    === setup_directories ====================================
    === create_rcS ===========================================
    === setup_hostname =======================================
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.0.0    *              255.255.255.0  U    0      0        0 eth0
    default        192.168.0.1    0.0.0.0        UG    0      0        0 eth0
        Interface: [eth0]
        IP: [192.168.0.5]
    === run_init =============================================
    humax#
    
    I dont know whether any of the above will help to track the issue down?
    Is the genmask correct for 192.168.0.1?, shouldnt it be 255.255.255.0?
    Code:
    Kernel IP routing table Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.0.0    *              255.255.255.0  U    0      0        0 eth0 default
    192.168.0.1    0.0.0.0        UG    0      0        0 eth0
    
    What else should i be looking at?, what should i check next?

    Many Thanks
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    The only difference I can find in your files is that my router gateway 10.0.0.2 is in my resolv.conf and yours isn't.
    Code:
    humax#
    humax# cat resolv.conf
    nameserver 10.0.0.2
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    humax#
    P.S. I am no expert in this field ! !
     
  3. Sam Widges

    Sam Widges Active Member

    Check the gateway setting in the master settings, what you are seeing is consistent with a gateway problem and your DNS server being outside the network (or the same as a now unreachable gateway).
     
  4. Black Hole

    Black Hole Ron Glum

    When you say you can't access iPlayer, what happens when you press the TV Portal button on the SUI (Standard User Interface)? Anything like THIS (click)?
     
  5. bh23456

    bh23456 New Member

    Hi,
    How can i change my resolv.conf?, i have changed the one which is here

    /var/linux/humaxtv/resolv.conf

    using cat > resolv.conf

    and changing to the two IP addresses you have, plus my gatway IP, but when i reboot, it returns to what i have in my original post, how can i prevent this?
    Thanks
     
  6. bh23456

    bh23456 New Member

    Found the issue!, my router!, for some reason, when i bind the MAC to an IP address everything stops working, set it free again and i can access the internet once again!

    Thanks for your help
    sorry