Cannot format - capacity too large

catnap

Member
For various reasons I removed the original 1TB drive from a box running 1.02.32 and copied files off it. I then reinstalled it and wanted to delete everything on it. I decided that the quickest way would be to reformat the drive. Going via Menu - System - Data Storage - Internal HDD - Format Storage. I get the message "Cannot format the hard disk. The capacity is too large."

I can just delete the individual recordings so that isn't a problem. I am though curious as to why the original drive cannot be formatted on its box.

I am also running the CF but presume that is irrelevant.
 
OP
C

catnap

Member
Interestingly, I tried to perform the format 3 times in succession and got the same message each time. I then put the box in standby and posted here. Following BH's response I took the box out of standby to manually cancel the recordings rather than removing the CF. I immediately saw a message that if I wanted to use Recording I needed to format the drive - which showed as zero space with zero used and zero available. I followed the onscreen instruction as before and this time the formatting worked even though I still had CF 2.15.
 

prpr

Well-Known Member
My suspicion is that it complains that it can't unmount the partitions, then blats the partition table anyway. So when you reboot, you effectively have a blank disk which it tells you it needs to format.
 

af123

Administrator
Staff member
It is best to put the box into RMA mode if you're planning to format the disk. That stops the CFW from starting anything up that might stop the disk from being unmounted. Once re-formatted, you can drop out of RMA via the telnet menu and then re-install.
Reverting to standard firmware works too.
 

TonyC

Member
Ah, I'd fitted a new (unformatted) drive so of course nothing was accessing it - the Humax prompted to format the disc as soon as it was powered on.
 
Top