Cannot upgrade custom firmware


New Member
Hi all,

Suddenly having a strange problem with the old HDR
Its been running for (years) fine on custom firmware, got a few additional packages installed but nothing major.
Currently running Web interface version: 1.2.2-5, Custom firmware version: 3.00 (build 2137)
i tend to update CF now and again when i remember and always goes fine.

Lately the HDR has been crashing and rebooting quite a lot, the better half reports its on Channel 4/E4 type channels more than others.
So i thought id update the box (and use the crash/loop firmware to clear settings first just in case).

Problem is the HDR will not load firmware from the USB stick. I have done it so many times before so don't think i am being stupid, stick is formatted to Fat32, file name is correct, used an existing stick that i have always used so knows it reads, but tried others just in case, box is always fully powered down.

I shove the stick in, turn it on (Humax logo appears on screen), led on stick blinks a few times, screen goes black, TV picture appears.

So now i am very confused!

To expand, the HDR (in the process of booting) is simply not recognising there is an update file on the UPD. That's nothing to do with CF etc, it's a built-in operation.

Assuming the update file is correct (has the correct file name and carries the correct ID codes), it could be that the UPD has become corrupt since last used (the mass media accesses during boot are very picky). The first thing to check is that you have in fact downloaded the correct file, and that it has not been corrupted in the process of downloading or unzipping it.
The Humax seems to be picky about which USB sticks it will accept for firmware upgrades and since it is relatively infrequent I can never remember which one worked last time and end up trying several before finding one that works.
Thanks for your feedback, but the thing is I am using sticks I have always used for updating so i know they work and Ive done the process many times so familiar with that too.
I have downloaded the file several times, checked, rechecked and checked again. Stick is Fat32, filename is correct, file is correct, in fact tried both the upgrade and the flush settings file.
The only variable I can think of that has changed is the sticks have been formatted under windows 10 (technical preview), not that I can see why that should matter but its the only thing i can see that's different but the only OS i have available at the moment so cant try anything else.
Have worked out the issue, for some reason Win 10 has converted all my USB sticks to use GUID (GPT) partitioning instead of MBR as well as creating a EFI system partition on the stick.
I am guessing this is why the humax doesn't like the USB sticks anymore.
Trouble is windows wont allow me to change back to MBR even under disk management via control panel, so anyone running windows 10 be aware, it will take over your USB sticks!!
OK, so in summary Win10 corrupts UPDs!

I'll add a note to Things Every... section 12, but I have other priorities at the moment.

Edit: done now.
Last edited: