1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't access web interface

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Pompeygeorge, Nov 5, 2012.

  1. Pompeygeorge

    Pompeygeorge New Member

    Hi,
    I installed the custom firmware a few months back to save something off iPlayer. That worked. The other day I reset my router, and I can't seem to open the web interface any more. (standard page not found error)

    I think theHummy's URL has changed to 192.168.0.102 from 100 (neither works as a URL). If I try and diagnose the problem it says that remote device won't accept the connection.

    I know I've tweaked some settings in the Humax as it kept crashing. I may have turned off content sharing (which I was using for talking to the other Humax for the kids). Are there any other settings I need to change on the Hummy?

    I don't think I've turned the hummy off since I reset the router? Would that help?

    Hummy definitely has internet access as I can see iPlayer.

    Thanks for any advice.

    George
     
  2. Pompeygeorge

    Pompeygeorge New Member

    oh, this is for the HDR-FOX T2!
     
  3. af123

    af123 Administrator Staff Member

    Do you know what software version your Humax has on it? It may have updated itself automatically which will have overwritten the custom firmware.
    You can tell if you have a recent version of the customised firmware on there if the front panel display shows 'Cust FW 2.XX' when it boots (just after SYSTEM START)
     
  4. Pompeygeorge

    Pompeygeorge New Member

    Ah, that may be it. Doesn't seem to be showing anything. Better find that USB stick again, and try and remember how I loaded it!

    I don't remember any recent OTA upgrades however?

    Cheers
     
  5. af123

    af123 Administrator Staff Member

    Humax did broadcast 1.02.28 as an OTA at least for some part of the last few months (although they seem to have stopped now)
     
  6. Black Hole

    Black Hole Felinos Guru

    Start HERE (click), post 2.
     
  7. grahamlthompson

    grahamlthompson Well-Known Member

    Rather than start a new thread thought I would ask this here.

    Bought a HDR FOX T2 (Comet Sale) and I have installed the custom firmware. I have a couple of problems. After installing a number of packages I can't get the installed list to show them. I have enabled Show development and advanced packages in settings. After installing the option to install is greyed out until you close and reopen the screen. The ir remote is definetely installed as I can control the box.

    I can also see the box using the remote scheduling options.

    Also unable to acess the customised epg channel options.

    I get this message on opening the web-if

    MSG: no such table: epg.epg

    I have tried several re-boots.

    If it's relevant I don't have any recordings yet but have set some series recordings.
     
  8. prpr

    prpr Well-Known Member

    How much did you pay, just out of interest?

    Can you make recordings?
    Can you Telnet to the box and do "mount" followed by "df -h" ?

    I'd be tempted just to format the disk and start again and see what happens.
     
    grahamlthompson likes this.
  9. grahamlthompson

    grahamlthompson Well-Known Member

    Thanks for the reply. £153.99 (500GB model)

    Yes I can record, just done a short recording of ITV1-HD

    Results of telnet

    humax# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    devpts on /dev/pts type devpts (rw)
    tmpfs on /tmp type tmpfs (rw)
    tmpfs on /media type tmpfs (rw)
    /dev/mtdblock1 on /var/lib/humaxtv type jffs2 (rw)
    /dev/mtdblock2 on /var/lib/humaxtv_backup type jffs2 (rw)
    /dev/mtdblock2 on /usr/browser/config-ocontroller-si-rootfs.txt type jffs2 (rw)
    /dev/sda1 on /mnt/hd1 type ext3 (rw,data=ordered)
    /dev/sda2 on /mnt/hd2 type ext3 (rw,data=ordered)
    /dev/sda3 on /mnt/hd3 type ext3 (rw,data=ordered)
    humax#
    humax# df-h
    -/bin/sh: df-h: not found
    humax#
    humax# mount df-h
    mount: can't find df-h in /etc/fstab
    humax#
    humax#
     
  10. Ezra Pound

    Ezra Pound Well-Known Member

    Hi Graham
    I would access the Humax via Telnet and enter opkg list-installed, to list installed packages
    BTW
    you need a space between df and -h
     
    grahamlthompson likes this.
  11. grahamlthompson

    grahamlthompson Well-Known Member

    Thanks Ezra Pound :)

    Looks an impressive piece of work by the way. The short ITV1-HD recording looks as if it's not encrypted so it appears to be all working.

    Telnet results

    humax# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    devpts on /dev/pts type devpts (rw)
    tmpfs on /tmp type tmpfs (rw)
    tmpfs on /media type tmpfs (rw)
    /dev/mtdblock1 on /var/lib/humaxtv type jffs2 (rw)
    /dev/mtdblock2 on /var/lib/humaxtv_backup type jffs2 (rw)
    /dev/mtdblock2 on /usr/browser/config-ocontroller-si-rootfs.txt type jffs2 (rw)
    /dev/sda1 on /mnt/hd1 type ext3 (rw,data=ordered)
    /dev/sda2 on /mnt/hd2 type ext3 (rw,data=ordered)
    /dev/sda3 on /mnt/hd3 type ext3 (rw,data=ordered)
    humax#
    humax# df -h
    Filesystem Size Used Available Use% Mounted on
    /dev/root 16.9M 16.9M 0 100% /
    tmpfs 61.0M 84.0K 60.9M 0% /tmp
    tmpfs 61.0M 0 61.0M 0% /media
    /dev/mtdblock1 2.0M 468.0K 1.5M 23% /var/lib/humaxtv
    /dev/mtdblock2 2.0M 1.2M 792.0K 61% /var/lib/humaxtv_backup
    /dev/mtdblock2 2.0M 1.2M 792.0K 61% /usr/browser/config-ocon
    troller-si-rootfs.txt
    /dev/sda1 1011.4M 40.4M 919.7M 4% /mnt/hd1
    /dev/sda2 447.6G 3.0G 421.9G 1% /mnt/hd2
    /dev/sda3 9.8G 150.6M 9.2G 2% /mnt/hd3
    humax#
    humax# opkg list-installed
    BootHDR - 1.1
    anacron - 2.3-1
    auto-unprotect - 1.0.7
    betaftpd - 0.0.8pre17-3
    busybox - 1.19.3-3
    bzip2 - 1.0.4
    cron-daemon - 1.18.3-1
    epg - 1.0.9
    ffmpeg - 0.10
    file - 5.0.4
    hmt - 1.1.6
    humidify - 1.0.2
    id3v2 - 0.1.11-1
    inadyn - 1.96.2-2
    inotify-tools - 3.14
    ir - 1.01
    jim - 0.73-1
    jim-cgi - 0.5
    jim-oo - 0.71
    jim-sqlite3 - 0.73
    lamemp3 - 3.98.4
    lsof - 4.82
    mediatomb - 0.11.0r2-5
    mongoose - 3.0-7
    multienv - 1.3
    nicesplice - 1.3
    ntfs-3g - 2011.4.12-3
    openssl-command - 1.0.0.d
    portal-xtra1 - 1.12.064.300-1
    rs - 0.5.0
    rsvsync - 1.0.3
    samba - 2.2.12-3
    service-control - 1.2
    smartmontools - 5.41
    sqlite3 - 3.7.6
    squashfs-tools - 3.1r2
    ssmtp - 2.64
    stripts - 1.1.2
    trm - 1.0
    webif - 0.10.0-2
    webif-channelicons - 1.0.3
    webif-charts - 1.2
    wget - 1.12
    humax#
    humax#

    Any help ?

    EDIT - I can stream the clip to the HDR-1000s by the way so it's clearly de-crypted
     
  12. xyz321

    xyz321 Well-Known Member

    Try the following:
    Code:
    ls -lR /mnt/hd1
    
    Also have a look at modinit.log on the diagnostic pages - it might give some more clues as to why the epg database is missing/not working.
     
    grahamlthompson likes this.
  13. xyz321

    xyz321 Well-Known Member

    If this is an HDR box - you shouldn't need to install BootHDR.
     
  14. Ezra Pound

    Ezra Pound Well-Known Member

    First thought, BootHDR - 1.1 is only for the Humax HD Fox-T2, not the Humax HDR Fox T2, I would remove it with opkg remove BootHDR and then reboot
     
  15. grahamlthompson

    grahamlthompson Well-Known Member

    Results

    humax# ls -lR /mnt/hd1
    /mnt/hd1:
    drwxr-xr-x 2 root root 4096 Nov 10 15:14 dvbepg
    -rw-r--r-- 1 root root 4690944 Nov 10 15:09 epg.db
    /mnt/hd1/dvbepg:
    -rw-r--r-- 1 root root 2690332 Nov 10 15:14 epg.dat
    humax#
    humax#

    >>> Contents of /var/log/modinit.log 5.53 KiB
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
    Interface: [eth0]
    IP: [192.168.0.18]
    === complete =============================================
    === diag =================================================
    Filesystem Size Used Available Use% Mounted on
    /dev/root 16.9M 16.9M 0 100% /
    tmpfs 61.0M 28.0K 61.0M 0% /tmp
    tmpfs 61.0M 0 61.0M 0% /media
    /dev/mtdblock1 2.0M 464.0K 1.5M 23% /var/lib/humaxtv
    /dev/mtdblock2 2.0M 1.2M 792.0K 61% /var/lib/humaxtv_backup
    /dev/mtdblock2 2.0M 1.2M 792.0K 61% /usr/browser/config-ocontroller-si-rootfs.txt
    /dev/sda1 1011.4M 40.4M 919.7M 4% /mnt/hd1
    /dev/sda2 447.6G 2.9G 422.0G 1% /mnt/hd2
    /dev/sda3 9.8G 150.6M 9.2G 2% /mnt/hd3
    eth0 Link encap:Ethernet HWaddr DC:D3:21:57:8E:3B
    inet addr:192.168.0.18 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:25 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2790 (2.7 KiB) TX bytes:1188 (1.1 KiB)
    Interrupt:16
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    PID USER VSZ STAT COMMAND
    1 root 1248 S init
    2 root 0 SW [migration/0]
    3 root 0 SWN [ksoftirqd/0]
    4 root 0 SW [migration/1]
    5 root 0 SWN [ksoftirqd/1]
    6 root 0 SW< [events/0]
    7 root 0 SW< [events/1]
    8 root 0 SW< [khelper]
    9 root 0 SW< [kthread]
    10 root 0 SW< [kblockd/0]
    11 root 0 SW< [kblockd/1]
    12 root 0 SW< [khubd]
    13 root 0 SW< [kseriod]
    14 root 0 SW [pdflush]
    15 root 0 SW [pdflush]
    16 root 0 SW< [kswapd0]
    17 root 0 SW< [aio/0]
    18 root 0 SW< [aio/1]
    19 root 0 SW< [ata/0]
    20 root 0 SW< [ata/1]
    21 root 0 SW< [ata_aux]
    22 root 0 SW< [scsi_eh_0]
    23 root 0 SW< [scsi_eh_1]
    24 root 0 SW [mtdblockd]
    25 root 0 SW< [kpsmoused]
    27 root 1244 S {rcS} /bin/sh /etc/init.d/rcS
    73 root 0 SWN [jffs2_gcd_mtd1]
    74 root 0 SWN [jffs2_gcd_mtd2]
    128 nobody 936 S /usr/bin/dnsmasq
    133 root 812 S /sbin/utelnetd -l /bin/sh -p 23 -d
    156 root 1252 S {S90settop} /bin/sh /etc/init.d/S90settop start
    173 root 354m S /usr/bin/humaxtv
    324 root 1520 S udhcpc -t 5 -T 10 -p /var/lib/humaxtv/udhcpc.eth0.pid -i eth0
    343 root 1104 S tinyftp -i HumaxFTP -p 0000 -c /media
    368 root 0 SW< [kjournald]
    380 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    390 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    399 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    416 root 0 SW< [kjournald]
    418 root 0 SW< [kjournald]
    444 root 1252 S < {modinit} /bin/sh /sbin/modinit
    448 root 1232 S < sleep 1
    451 root 1232 S < sleep 1
    457 root 1336 R < ps -w
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
    === reset_all ============================================
    === rma ==================================================
    === upgrade_bootmod ======================================
    === setup_directories ====================================
    === create_rcS ===========================================
    === migrate_bootmod ======================================
    === setup_hostname =======================================
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
    Interface: [eth0]
    IP: [192.168.0.18]
    === run_init =============================================
    Loaded FUSE module into kernel.
    Loading config file /mod/etc/mongoose.conf
    Anacron 2.3 started on 2012-11-10
    Normal exit (0 jobs run)
    An FTP Server is already running, not starting betaftpd.
    2012-11-10 13:35:03 INFO: Loading configuration from: /mod/mediatomb/config/config.xml
    2012-11-10 13:35:03 INFO: Checking configuration...
    2012-11-10 13:35:03 INFO: Setting filesystem import charset to ASCII
    2012-11-10 13:35:03 INFO: Setting metadata import charset to ASCII
    2012-11-10 13:35:03 INFO: Setting playlist charset to ASCII
    2012-11-10 13:35:03 INFO: Configuration check succeeded.
    === complete =============================================

    Rendered in: 0.025 seconds
     
  16. grahamlthompson

    grahamlthompson Well-Known Member


    I can't see any installed packages on the webif so would presumably need to manually do this either by ftp or telnet. Not really familiar with telnet.
     
  17. Ezra Pound

    Ezra Pound Well-Known Member

    Just login to Telnet and enter:-
    opkg remove BootHDR
    reboot
     
  18. grahamlthompson

    grahamlthompson Well-Known Member

    Simple when you know how. Done that, made no difference.
     
  19. af123

    af123 Administrator Staff Member

    What is in the epgd.log file in /tmp?
    (more /tmp/epgd.log from telnet)
     
  20. xyz321

    xyz321 Well-Known Member

    Try reinstalling webif:
    Code:
    opkg install webif --force-reinstall