[CFW 2.16] Customised Firmware version 2.16

af123

Administrator
Staff member
CFW Version 2.16 has been released.
  • New version of fix-disk courtesy of xyz321.
    • Automatically perform a long disk test if necessary;
    • Bug fixes;
  • Embedded telnet menu updated to version 1.06;
    • Menu options to perform short and long disk tests and check test status;
    • EPG clear option renamed;
  • Bootstrap process detects when no suitable disk is found for the custom firmware environment and presents a web page explaining the problem (rather than providing no web page at all);
  • Only scan removable drives for packages;
  • Support signed packages (.spk) on USB drives. Allows for the execution of arbitrary code or installation of files into flash to help resolve problems.
Downloads at the usual place - http://wiki.hummy.tv/wiki/Firmware_Downloads
 

Black Hole

May contain traces of nut
Existing users should note the new and improved features of 2.16 make it easier to diagnose and cure file system problems, particularly those caused by a few sectors going bad on the hard disk, and provides a friendlier response to new users who think they know better than to follow the instructions (HD-FOX). There is nothing in it which demands the immediate replacement of whatever you are using at the moment, you could wait and only install it when you want to run fix-disk from the Telnet maintenance menu.
 

Black Hole

May contain traces of nut
Dare I say it... could this be the last CF???

Suggestion for an SPK (is running these a menu option, by the way?): Foxy all HiDef HMTs enabling a novice to 1: download 2.16 and the SPK to USB; 2: plug in the USB and install CF, then connect by Telnet and run the Foxy SPK; 3: plug in a USB drive and format it with the Humax menu; 4: copy off all recordings prior to replacing the HDR-FOX.
 

Ravi

Member
Been on 1.02.29/2.14 for a while, but upgraded to 1.02.32/2.16 this morning.

Thanks AF123 (and everyone else who contributes) :D
 

Black Hole

May contain traces of nut
With expert mode Telnet set in the WebIF settings, is there a way back to the Telnet menu from the command line? If not, perhaps there should be a "menu" command so there is?
 

gosling

New Member
I am not sure if I am doing this in the right place or in the right manner so please forgive me...

I bought my Humax HDR-Fox-T2 about 18 month ago. It has a 1tb hard disc and has worked perfectly until i went to play a recording, could see the folders on screen but found the folders were empty. I have checked the hard disk and found that the Humax is prompting me to reformat it as i am getting error code 8 during the self test. I do not want to do this and loose my recordings. I found this website and followed your advice, i have downloaded custom firmware 2.16 and ran option 1 – check and repair hard disk. The utility failed and i got the message below. Can anybody please help me?
Thanks,


Code:
 [ Humax HDR-Fox T2 (humax) 1.02.32/2.16 ]
 
Are you sure you wish to run the hard disk checker? [Y/N] y
Running /bin/fix-disk
Custom firmware version 2.16
 
Checking disk sda
 
Using superblock 32768 on sda3
Using superblock 0 on sda1
Using superblock 0 on sda2
 
Unmounted /dev/sda1
Unmounted /dev/sda2
Partition /dev/sda3 is already unmounted
 
Running short disk self test
Error at LBA 1932539180
Dev: /dev/sda LBA: 1932539180
LBA: 1932539180 is on partition /dev/sda3, start: 1932539175, bad sector offset: 5
dumpe2fs 1.41.14 (22-Dec-2010)
dumpe2fs: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda3
Bad block size
 
Press return to continue:
 
OP
af123

af123

Administrator
Staff member
You do have an error on the disk which has caused one of the partitions to become unusable. Luckily, it isn't an important partition so you should be able to fix this. To do that, you'll need to put the box in maintenance mode again and then drop to the command line interface (the CLI option from that telnet menu).

You will see a prompt that looks like humax# and you need to type the following commands there, pressing return after each one. I've shown the humax# prompt for context. Please be careful to get the numbers right - cut and paste if you can!

Code:
humax# hdparm --repair-sector 1932539180 --yes-i-know-what-i-am-doing /dev/sda
humax# mkfs.ext3 -m 0 -O sparse_super /dev/sda3
humax# exit

Then restart into normal mode and see how that looks.
 

gosling

New Member
I have followed your advice, restarting in maintenance mode and copy/paste the lines of code. I have restarted the box and can now see my recordings. I have tried a few and they seem to be playing without any issues.

Thank you 'af123' for your help, it is much appreciated.
:D
 
Top