Connecting to Synology NAS


I have a Synology DS115 NAS and can't get my Humax to connect to it. I press the media button, the blue "storage" button, select "Network" and then get a "Connecting..." message but eventually I get "No server has been found". My TV can connect to my NAS ok so DNLA is working on the NAS. My NAS can see the Humax OK. Has anyone else done this kind of thing and can help?
For reasons unexplained, it seems to take a long time for a DLNA server to be recognised first time. After that it's OK. Keep trying,
Almost 2 days and still no connection. I think thats long enough. Any ideas on what to try?
I have an ageing Synolog DS411J. This has always just worked. So put me down as someone who has done this sort of thing.

What I'm not acquainted with is troubleshooting DLNA. You might;

1. Install custom frmware. ( providing access to some diagnostic tools).
2. Telnet from the humax to the relevant dlna ports

What else have you got in the mix?
What's your network environment - wires, wireless, router type etc.?
Is it possible to eliminate/replace the router ?
Have you any other tools? A PC could provide a dlna service to test the Humax against for example.
Sometimes a router reboot has been reported to cure mysterious network problems (including for me).
I've got a Synology 413j and had a similar problem - until I significantly reduced the "SSDP Advertisement Interval" on the Synology to 300 seconds. On Synology DSM5, the settings on the Media Server's General Settings tab, accessible from the Control Panel. If you haven't already done that, you might want to give it a try.

Problem solved. In juggling ethernet connections around on my Router I recconnected the Humax to a duff router port, a common failure with DGN2000 routers apparently. Using a different port fixed the problem.