1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

copy fails using samba share from PC to HDR T2

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by morleym2002, Oct 21, 2012.

  1. morleym2002

    morleym2002 New Member

    Brand new HDR T2 just installed the custom firmware and started to copy my media files to the HDR hard drive. Music and Photo's copied ok but video fails part way through video transfer. Filename appears in My Video folder but fails withe message "cannot copy <filename> access is denied make sure the disk is not full or write protected and the file is not currently in use" Files are mainly xvid and around 700MB each. If I then try and copy any file it comes up with same message.
    Can any body help please?
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    Any unusual characters in the file name? is it possible to FTP the 'problem' files?
     
  3. morleym2002

    morleym2002 New Member

    Hi, thanks for the quick reply, I tried ftp but it fails, tried a different file it fails but shows the filename in destination folder. To completely clear this current state I previously rebooted the T2 (via wed interface) then I can for a short time start transfer again? No unusual characters in filename. Just rebooted T2 and tried transfer 2.15GB file to T2. File appears to transfer ok with FTP with no error but destination file is only showing as 0.444GB.
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    I'm going to make the QI klaxon go off here, but I can't resist it - I'm presuming there is enough free disk space on the destination drive ! ! . Moving quickly on, I wonder if your router is having problems with MTU size, details of changing this HERE, you could also try transferring the same files via a USB flash device, if this works it may prove that your router doesn't like big files
     
  5. morleym2002

    morleym2002 New Member

    Thanks for that Ezra but I can tell you I have transferred these same files through my router to a Acer Revo in the past. The T2 is a 1 terabyte drive with masses of space free. I will take a look at the MTU size. and get back to you.
     
  6. morleym2002

    morleym2002 New Member

    Just before i do Ezra does the ethernet section of the modinit.log indicate the T2 is set to MTU = 1500? I presume you are reffering to the Humax and not the Netgear router?
     
  7. Terrahawk

    Terrahawk New Member

    Are your source files located on a linux box such as a NAS or are they on a windows system?

    I have a similar issue when copying a 550Mb video file to the Humax 'media' share which I have mounted on my Linux based NAS. Copying the same file from a Windows box works.
     
  8. Ezra Pound

    Ezra Pound Well-Known Member

    Yes, The link in #4 reduces the MTU on the Humax box down to 1400
     
  9. morleym2002

    morleym2002 New Member

    Hi Ezra, I moved the USB drive to the T2 and tried to copy over the files and all operations appeared to complete although in a rather short time. When I checked for the files in My Video folder they were not there. I then ran the HDisk test utility and it seemed to pass. As I had only the music files copied over to My Music folder I tried to format the HDisk. I got message "unable to format too large"
    Tried a complete power off/on and then able to format. Now copying files over USB connection and looks ok, I will try the samba method later and confirm back to you.
    Its beginning to look like my T2 may have had a bumpy ride from Amazon and caused a bit of a problem. Just hoping it wont be permanent.
    Regards Mike
     
  10. morleym2002

    morleym2002 New Member

    Thanks for your reply, I am using windows XP to transfer files.
    Regards Mike
     
  11. Ezra Pound

    Ezra Pound Well-Known Member

    If you have Custom Firmware 2.12 installed there is a much better Hard Disk utility called Fix-Disk, I recommend you run that, it is non-destructive
     
  12. morleym2002

    morleym2002 New Member

    I do have 2.12 installed but dont see that utility is it an advanced one that needs loading individually, also I noticed that some extra directories had been created when I installed some utilities but these will probably no longer exist (i think they were for joining/spliting files), do I need to somehow reinstall these. Sorry to be a pain I am trying to get to grips with the new box and the custom firmware and only have a little technical understanding. I purchased the T2 over the Humax YouView box because of its ability to transfer files easily and your custom firmware is brilliant. I do still have my old trusty 9200t but it sometimes hangs when skipping forward through a recording so I plan to try and replace the hard drive. The T2 fits my requirements perfectly because I have a WD TV Live upstairs that can easily play the T2 recordings remotely and all my transferred files on the 1 terrabite drive. The T2 also seems to play all my video's well appart from some 1080p @28mbit .MOV files which I rename with ext mp4. These do play but have some jitter. I am going to try dropping them to 720p @10mbit to see if it works.
    Sorry to be going on a bit but rather excited about the T2
    Regards Mike
     
  13. Ezra Pound

    Ezra Pound Well-Known Member

    Fix-Disk is built-in with Custom Firmware 2.12 so it is already loaded and ready to go, you will need Telnet access though
     
  14. morleym2002

    morleym2002 New Member

    I will give it a go when my video's have completed transfer. Thanks for all your help Ezra.

    Regards Mike
     
  15. morleym2002

    morleym2002 New Member

    Hi again Ezra, everything seemed to be transfering via USB ok. for a few hours and I was monitoring file sizes via ftp then seemed to stall. I could still access the directories ok via ftp but no addition files were showing. I checked the activity light on the USB drive and it blinked rather slowly.
    I am thinking there is still a HDisk problem so tried fix-disk using putty as per documentation on this forum. Unfortunately I know nothing about telnet and am getting this return from fix-disk.
    humax#
    humax# fix-disk
    Warning: This procedure will freeze the Humax for anything up to 2 hours.
    Please ensure that no recordings are currently in progress or scheduled
    during this time.
    Do you wish to continue [Y/N]? y

    humax# y
    -/bin/sh: y: not found
    humax#
    humax#
    It looks like I am missing some files???

    Regards Mike
     
  16. Ezra Pound

    Ezra Pound Well-Known Member

    It looks like Telnet may not be setup correctly, have you done this from the Telnet NOTES :-
    [Putty] Telnet >> Connection >> Telnet >> return Key sends Telnet New Line instead of ^M should be 'un-Ticked'
     
  17. morleym2002

    morleym2002 New Member

    Yes thats how I did it.
     
  18. morleym2002

    morleym2002 New Member

    Sorry I miss read that I have it ticked, I'm being a pain arnt I. :)
     
  19. Ezra Pound

    Ezra Pound Well-Known Member

    That's O.K., you should now be able to do Fix-Disk and answer 'y' sucessfully
     
  20. morleym2002

    morleym2002 New Member

    Another update Ezra,
    I ran fix-disk and my telnet screen was full of inode cleared information "too many illegal blocks in inode, clear inode? yes". This went on for a long time and I could only capture the last screens to file (attached here). I then ran the fix-disk utility again this morning and it ran much quicker with no errors. My concern now is that the disk may be degrading and I could end up with corrupt recordings over time and a loss of usable space if fix-disk is deallocating these inodes. If you were me and had experienced this on a brand new machine from Amazon would you return it for replacement?

    Also I now notice that I cannot format the disk with the standard humax utility, message says disk too large?
    Regards Mike
     

    Attached Files: