1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Customised Firmware 2.13 Upgrade- Help needed

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Richard77, Nov 14, 2012.

  1. Richard77

    Richard77 New Member

    My first post!!! :)

    I've been lurking on this forum for the last year and a half - having stumbled upon it when i first purchased my HDR Fox T2. First up i'd like to thank & congratulate all those involved in the Customised Firmware project, I've found it a great addition to an already great product!

    Last night i finally got round to upgrading to CF2.13 and seem to have encountered a few problems. Basically the Custom Portal features disappeared, reverting back to the Original TV Portal which ceased to function - freezing upon trying to load any videos (I Player, You Tube etc). In addition I can no longer access Web-If from my PC, despite the Cust FW 2.13 message appearing at start up on my box. I read about a similar sounding problem in another thread after trawling the forum for solutions and finally gave Telnet a shot - fix-disk, which seems to have resolved the TV Portal problem (can now watch I Player etc).

    I've tried reinstalling the standard firmware/CF2.13 several times but no luck - unfortunately I still can't access Web-If via PC and now have the following strange message on the front of my box;

    == RMA ==

    I've even taken the drastic action of a factory reset with HDD format and still no joy - I'm at a loss! I wouldn't class myself as a technical wizz, but I've never encountered any problems in the past. Would greatly appreciate any help/guidance anyone could provide.

    Cheers,
    Richard
     
  2. af123

    af123 Administrator Staff Member

    Somehow you have managed to put your box into RMA (Return-to Manufacturer) mode. That's usually done via a button in the web interface under Diagnostics which asks for confirmation a few times.

    Let's start by fixing that. You need to telnet to the box and then type:

    Code:
    diag resetrma
    
    which should get you past that step. The loss of custom portal happens during an upgrade to 2.13 if you don't run the prepare_for_upgrade diagnostic first (as shown in the upgrade instructions). You can fix that with another diagnostic but since you've run RMA mode everything will have been deleted anyway.

    Try the resetrma step and let us know how it's looking.
     
  3. Richard77

    Richard77 New Member

    Whoops - not sure how I've managed to do that :confused: as it certainly wasn't my intention.

    Worked like a charm - used telnet just like you suggested and now have full access to Webif via my pc again. Installing packages as I type. :D

    Thanks alot af123, couldn't have done it without your help.