1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Deleting...

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Mr Austin, Jun 7, 2012.

  1. Mr Austin

    Mr Austin New Member

    My HDR Fox T2 says "Deleting..." every time I go into the media folder. Also, it won't record anything and I can't rewind live TV.
    I've seen some solutions for people using the custom firmware but I am not using it unfortunately. I've tried resetting (switched off at the wall for 20 minutes) but it still happens when I start it up again. When it started up again, everything that I had "deleted" today reappears.

    Does anyone have any suggestions?

    Thanks,
    Gary
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    If you have the latest (Beta) Humax Firmware e.g. 1.02.27, there is a Hard Disk Test Facility which may help. If this is not available a Hard Disk Format may be required but Please note this will delete all recorded programs
     
  3. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    I think the only fix if you are not running the custom firmware is to install an old firmware version http://beta.humaxonline.co.uk/downloads/hdr-foxt2v10105 , power down, boot up check that the problem has gone away and then reinstall a current firmware version.
     
  4. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    I suspect it won't allow a format whilst in this state.
     
  5. xyz321

    xyz321 Well-Known Member

    It should still be possible to install the custom firmware, if you wish. This should allow telnet access into the box without installing any of the additional packages.

    If you decide to do this, it would be helpful if you could post the contents of the file '/mnt/hd1/filebglastop.dat' here.

    Code:
    hexdump -C /mnt/hd1/filebglastop.dat
    To fix the problem, just delete the file and then reboot:

    Code:
    rm /mnt/hd1/filebglastop.dat
    reboot
    
     
    af123 likes this.
  6. rafletcher

    rafletcher Member

    Hmmm, mine did this, and I know I found a fix on here that didn't involve editing/deleting any files. I needed to do a factory reset to cure the playback freezing/skipping issue. Damned if I can remember what I did though - other than perhaps unplugging from mains and leaving for a couple of hours before restarting? That was with standard firmware.
     
  7. TeeJay

    TeeJay New Member

    Gary,

    I had this exact problem on one of my two boxes.

    To fix it, download version 1.01.09 of the firmware, copy it into the root of a memory stick (note guidelines on the mem sticks format) power down (via front switch) pop in the mem stick and restart.

    The files will copy across in a couple of minutes, restart the box again, and the "deleting" will be resolved - without losing any settings :eek:)

    You can then simply re-install v1.2.20 (or whatever version you have)

    Tony
     
  8. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    There are mixed reports about this. Certainly going back to an earlier firmware stops the problem. Some people report that reinstalling the latest firmware then restarts the problem; some people report it fixed. Before going back to the later firmware did you format the disk?
     
  9. TeeJay

    TeeJay New Member

    Hi Martin, No, I didn't reformat.

    As I've mentioned elsewhere, apart from the "deleting" issue I was also getting the occasional pixelation and "jump" of about 30 secs when using V1.02.20.

    Reverting back to 1.01.09 solved those issues - but then I got the "silent audio" problem on all HD channels on 1st June (raised in another thread, but basically sound was recorded, but not played back) which was only resolved by upgrading back again to 1.02.20 - which, so far seems to be running ok.(fingers crossed!)

    Hope all that makes sense :)
     
  10. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Thanks for the comprehensive reply. It all makes sense but I don't understand why different users see different behaviour. Maybe af123 has a theory?
     
  11. DRY411S

    DRY411S New Member

    I had this problem with custom firmware installed. Telnet onto the box would not allow me to delete the files. Linux reported that the file system was read-only, which would explain why recording was impossible, and many of the menu options were greyed out.

    Putting the box into maintenance mode didn't help, fsck on the sda2 failed with memory errors (1 TB disk)

    I tried unplugging from the mains to no avail. Just before trying the suggestions to downgrade to earlier firmware, I powered off and on using the rocker switch on the back of the unit. This seemed to cause a different startup sequence, and the problems disappeared!
     
  12. I've seen this behaviour too. Wish I knew what triggered it, but its happenned a few times. Box won't shutdown from the remote either. To fix it, I:

    1. Initiate a shutdown from the remote.
    2. telnet onto the box and issue a "reboot" command

    When the box comes back up, the "Deleting ... " message has gone
     
  13. af123

    af123 Administrator Staff Member

    If your box is routinely going read-only, even if a full reboot can fix it, then there is something wrong with the disk, either filesystem corruption or device errors.
    I'd recommend performing a full disk check (fsck). If you use xyx321's fix-disk helper package then it can check 1TB disks.

    http://hummy.tv/forum/threads/before-i-reformat.1897/#post-24606
     
  14. Thanks, that's a good idea. I'll do this as soon as I get a chance. So I install the package from the WebIF, and run the command manually from a telnet session?
     
  15. af123

    af123 Administrator Staff Member

    Yes, then reboot and it will come back in maintenance mode and you run the command again (full pathname this time)
     
  16. xyz321

    xyz321 Well-Known Member

    If the disk has become read-only you may not be able to install packages from the web-if. In that case follow the link in af123's post above where there are instructions and a download link.
     
  17. Hi, is the fix-disk package destructive, or will it just report any problems?
     
  18. xyz321

    xyz321 Well-Known Member

    It is really just a wrapper script around the standard ext2/3 file system checking program (e2fsck). The script takes care of putting the box in maintenance mode, unmounting the filesystems, creating a swapfile and running the checks.

    In answer to your question, it is setup to fix any errors it finds. I could add an option to do a dummy run if there is a demand for it.
     
  19. and if there were errors that needed fixing, could that result in lost recordings?

    P.S Sorry to be hijacking this thread. Can start a new one if preferred.
     
  20. xyz321

    xyz321 Well-Known Member

    It depends where the corruption is on the disk. It may decide to delete files or parts of files and can dump them in a lost+found directory.

    It is usually best to nip these things in the bud at the first sign of trouble. If the problem is left, it can get worse as more data is written to the disk.