1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disconnected network?

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Chris Parsons, Jun 19, 2012.

  1. Chris Parsons

    Chris Parsons New Member

    I keep getting a disconnected network message when browsing the file system on my Netgear NAS box?

    When I check the network configuration everything looks correct (IP address etc) - I thought I had a dodgy cat5 cable and changed to a TP-Link mains transmitter/receiver (the original cat5 cable was 30m long!) but get the same thing.

    Now I have found this site and downloaded and installed the mod (fabulous piece of work, well done all) I am wondering how to approach some network diagnostics (of the LAN adaptor in the Humax?)

    Don't have problems with anything else plugged into the router (O2 are my ISP and provided the router)

    Comes and goes, sometimes its OK - I did wonder if it's something to do with the DLNA server on the ReadyNAS (TwonkyServer)

    Any ideas where to start looking?

    Very annoying to be halfway through a good film and have the connection suddenly drop!

    Chris
     
  2. Black Hole

    Black Hole Felinos Guru

    Just to clarify, this is access to a media NAS from the Humax using DLNA.

    One thing you could do, now you have taken the plunge with the custom software, is to mount the NAS as if it were a USB drive (or even within My Video - but that can lead to problems so I don't recommend it) - see auto-mount. Then if it still drops out you know it's not the DLNA server.

    AF123 might be able to suggest something you could run from the diagnostics screen on the WebIF.

    As this is now more of a custom topic than a standard one, I shall ask the moderators to relocate it.
     
  3. Chris Parsons

    Chris Parsons New Member

    Thanks very much - I have managed to work out what I needed to install, and have got the [modsettings] displayed in the folder list

    Looks like I amend the 'folder names' to create the connection settings, although it took me a while to work this out (would have been easier
    just editing the appropriate file via telnet!) but I cannot get anything to appear on the Humax?

    I couldn't work out what 'mount as USB' means - I shoved a pen in the front panel connector and get this displayed, can browse etc, where
    does the NAS drive get displayed??

    Not even sure if my config file is correct, if someone can help me with what goes where I would be very grateful!

    domain=[No idea! I use a domain name on the office LAN, but at home??)
    folder=[Is this the share name on the NAS?? ie \media]
    host=[Is this the NAS name on the network?? ie \\nas-84a]
    mac=ABABABABABAB (only needed for wakeUp)
    password=Password [For what?? Windows?]
    shareFolder=off
    user=User [For what?? Windows?]
    wakeUp=off

    I use Windows 7 32bit on the PC, Windows 7 64bit on the laptop - according to Windows on the PC I have a computer name of 'Home' no domain
    and am a member of 'WORKGROUP'

    Couldn't find any documentation anywhere for this file, but I'll keep looking...

    Chris
     
  4. Climber

    Climber Member

    Here is my set up that connects to my NAS – It has been working fine for many months.
    Using SMB (Rather than nfs) The settings are:

    Domain= notrequired
    Folder=video (rename it to suit your folder/directory)
    Host=192_168_2_3 (renumber to your NAS net: address and use _ between digits)
    Mac=(leave as is)
    Password=Password (I don’t actually have a password set on the NAS)
    shareFolder=off
    user=User
    wakeup=off

    Give the settings a few minutes to load up.
    You’ll need a pen drive in the usb slot of the Humax.
    Access the NAS by the Humax remote – Media-blue button-USB
    If the NAS has mounted okay it should be showing on the screen.
    You can also go into – webif – diagnostics – scanmounts.log. This displays mounting details (both successful and unsuccessful mounts)

    Here is the link to the network-shares-automount discussion.


    http://hummy.tv/forum/threads/network-shares-automount-package-released.1126/

    Perhaps a mod could move these posts to there?
     
  5. Chris Parsons

    Chris Parsons New Member

    Thank you, that is very helpful - at least now I scan see it doesn't work <g>

    The log output was
    192.168.1.64 is on-line - attempting to mount
    mount -t cifs //192.168.1.64/media /media/pc -o user=,password=,domain=
    mount: mounting \\192.168.1.64\media on /media/pc failed: Invalid argument
    Mount failed...
    umount: can't forcibly umount /media/pc: Invalid argument

    Pity it doesn't indicate which argument!

    My IP address is correct, and the share is called 'media' I can browse to this
    on Windoze and see folders/files - I think I have tried every permutation but will keep
    trying *sigh*

    There is some communication because I inadvertently used the IP address for the Humax
    at the start and it mounted the USB pen in the Humax and I could browse it's folder structure

    If I telnet into the Humax I can see the USB pen mounted (as disk1) but no 'pc'

    Cheers

    Chris
     
  6. Ezra Pound

    Ezra Pound Well-Known Member

    Just a thought, try using a different / unique share name maybe my-media
     
  7. Chris Parsons

    Chris Parsons New Member

    Good suggestion - deleted the old configs, did a reboot and then created a share to another folder and doing this noticed the prompt said 'amend domain or workgroup' so I added the workgroup from Windoze and the files/folders appeared!

    Trying it again now with the 'media' share but and will try with/without the workgroup etc and post the resulting (hopefully!) working config file

    Thanks for the help everyone

    Chris
     
  8. Climber

    Climber Member

    I've also noticed if you do not put in something after domain= then the device will not mount and I get the Invalid arguement in the scanmounts.log
    I've tried putting in any name like alpha or bravo and it mounts.
    So: domain=alpha mounts the device for me.
    Restarting the humax via the remote also appears to help it save changes made to modsettings quicker.

    edit - previously I had domain=notrequired as the actual wording