1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DLNA Server Stopped

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Brian Burch, Jan 6, 2013.

  1. Brian Burch

    Brian Burch Member

    I have a hdr fox t2 with 1TB disk, running 1.02.29 firmware and custom firmware 2.13.

    Since recovering my disk a week ago (more thanks!) the humax has been running fine - playing, recording, deleting. I installed auto-unprotect, disable-dso, disable-ota and rs a month or so ago. I installed undelete (and ir) after the disk recovery.

    I decided to start backing up my recordings using wget and the dlna server, but kept getting connection refused. The humax was in "fully awake" state, but it would not respond to the media or guide buttons on the real remote, so I put it into standby.

    When I turned it on again with the real remote the media and guide buttons worked normally, but my wgets were still refused. The web interface diagnostics display showed the DLNA server was stopped in both cases. I did not click the button to reset the DLNA database because I did not understand what that action would do.

    I searched the web interface, especially services, but could not find anything that sounded like a DLNA server, but eventually something crept back into my memory from a long time ago...

    Real Remote -> Settings -> System -> Internet -> Content Share had become changed back to OFF somehow (definitely not me, and no-one else would even get there by accident in my house!)

    I changed the setting to ON and my wgets are running fine again.

    Is this typical behaviour? I hoped to be able to fetch some recorded programs when not at home, but if the DLNA server is likely to die again it will not be possible. Can it be restarted via the web interface, or a telnet session?
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    The Web-If >> Diagnostics >> DLNA Server >> Reset DLNA Database can be used to restart the DNLA database, but, as you say, this command is used after switching Off/On Content Share using Menu >> Settings >> System >> Internet >> Content Share. I don't think this second stage can be carried out using either Web-If or Telnet commands. It may be possible to create a macro with the Web-If ir (Virtual Remote) commands to replicate this
     
  3. af123

    af123 Administrator Staff Member

    I have known that option to turn itself off, but usually when I'm doing things like running the Humax application directly from the command line for testing. It's possible it disabled itself when your disk wouldn't mount properly.
     
  4. prpr

    prpr Well-Known Member

    I had to re-enable the DLNA server on a remote box last week. This is what I did:
    Code:
    humax# sqlite3 /var/lib/humaxtv/setup.db
    SQLite version 3.7.5
    Enter ".help" for instructions
    Enter SQL statements terminated with a ";"
    sqlite> update TBL_MENUCONFIG set itemValue=1 where itemName='DMS_START_ON';
    sqlite> .q
    humax# reboot
    
    Worked fine for me. Not sure if you need a reboot or can somehow just restart the Humax app.
    Perhaps af123 could comment?
     
  5. prpr

    prpr Well-Known Member

    I guess this could be built into the Web-If without too much trouble as well...
     
  6. Brian Burch

    Brian Burch Member

    Excellent advice! Thanks everyone.

    I haven't tried it yet, but if the humax is half-awake or full-awake, would I be able to re-activate the DLNA server using the menu on the remote control provided by the "ir" package. (I have it installed and can't see why it might depend on the DLNA server.)
     
  7. prpr

    prpr Well-Known Member

    I tried stopping and starting it using /etc/init.d/S90settop but these listening sockets never got recreated:
    HTML:
    Proto Recv-Q Send-Q Local Address          Foreign Address        State
    tcp        0      0 0.0.0.0:9955           0.0.0.0:*              LISTEN
    tcp        0      0 0.0.0.0:9000           0.0.0.0:*              LISTEN
    tcp        0      0 0.0.0.0:9001           0.0.0.0:*              LISTEN
    tcp        0      0 0.0.0.0:50001          0.0.0.0:*              LISTEN
    udp        0      0 humax:54743            0.0.0.0:*
    udp        0      0 0.0.0.0:1900           0.0.0.0:*
    
     
  8. prpr

    prpr Well-Known Member

    Certainly in fully-awake, IF you can see what you're doing on screen, which you probably can't. Trying to navigate menus otherwise can be very tedious and/or impossible.
     
  9. Brian Burch

    Brian Burch Member

    Oh! I didn't realise there isn't any feedback... if you don't even know which line of the menu is currently selected, you'd never be able to navigate into the 4 levels of submenu. My ir-remote idea is a non-starter for offsite management.
     
  10. Ezra Pound

    Ezra Pound Well-Known Member

    If you have a known starting point you can record the key presses and create an ir macro as suggested in #2, e.g. MENU >> SETTINGS >> SYSTEM >> INTERNET SETTINGS >> CONTENT SHARE (On) >> OK. the problem is that it's very difficult to get a known starting place, e.g. the screen after MENU will be pointing to where ever it was the last time you used it, so you can't guarantee that sending MENU >> OK will get you to Settings because the pointer could be anywhere

    If the solution in #4 is reliable that's a much better way to control it