Dynamic DNS not updating (no-ip.com)

simonlangford

New Member
I loaded the customised firmware the other night. Installation was straightforward and all seems to be working great... but I can't get dynamic DNS working.

I signed up with no-ip.com and entered my account details on the Hummy WebIF. It seemed to be accepted OK but the Hummy isn't updating no-ip.com. I can tell this because my router reboots whenever I change any settings on it, and it's rebooted a few times over the past days. This has meant my external IP address has changed, but when I run "nslookup <my-no-ip-host>" then the returned IP address is out of date.

Do I need to do anything else on the Hummy to enable dynamic DNS updating?
 

HarveyB

Active Member
Not clear from your statement:
Have you installed the inadyn package?

If so have you set up the corresponding Dynamic DNS parameters on the WEB-if settings screen?

Both are required to get DDNS working.

I'm not sure what triggers the Humax to update the DDNS server, but I suspect it may be stop/start of the Humax rather than the router. Perhaps AF123 can clarify.

So has the Humax been restarted between restarts of the router and checks on the DDNS site?

Sent from my iPad using Tapatalk HD
 
OP
S

simonlangford

New Member
Hello, thanks for responding. To answer your questions:

- yes, the inadyn package is installed and I have rebooted the Humax several times since installing it.
- yes, I have entered the parameters in the WebIF setup screen. Provider, username, password and hostname are all set.

I guess how it should work is whenever the Humax boots it should contact no-ip.com with the credentials to enable no-ip.com to update the IP address it holds against my account. But the IP address which no-ip.com stores against my account has never been updated.

I was wondering whether I needed to run anything at the Humax command line to get things started?
 
OP
S

simonlangford

New Member
DOH! I just realised my own mistake... I'd put "simonlangford @ no-ip.org" as the hostname in the WebIF instead of "simonlangford.no-ip.org". Once I corrected it then everything has updated nicely.

[I had to insert the 2 spaces in the @ username above as the forum won't let me post links!]

Thanks for your time and apologies for the schoolboy error ;-)
 
Top