• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

Easy FTP setup

#1
I've been trying to find something to help me setup the ftp stuff on my box/ laptop, but no luck so far.

In a non too technical way, can someone let me know how to get the ftp setup?

Thanks
Andy
 

fenlander

Active Member
#2
@Andy

This is pretty simple but, as usual, there are a few variables to take into account. The instructions below should work, but are not the only way to do the job.

On the Humax

If you connect to your local network via a wired connection:

- Open the main menu. Select Settings - System - Internet Setting - Configure LAN
- Set Configure IP to Manual
- Set IP Address to 192.168.0.101
- Set Gateway Address to 192.168.0.1
- Leave DNS Address unchanged
- Click Apply

This will work for most routers. Some routers may use addresses not in the range 192.168.0.n, in which case the IP Address and Gateway Address will need to be set according to the router's address range. Worry about this only if these instructions don't work!

This will give your Hummy the network address 192.168.0.101. If you have set up a wi-fi connection, you do not need to do the above. Provided the wi-fi connection is working correctly, the Hummy should have a default address of 192.168.0.100.

- Click left to return to the menu
- Select FTP Server. Set to On
- Exit the Menu.

On the PC

- Download FileZilla from here.
- Install it
- Run it
- Click File - Site Manager. You should see this dialog:



- Click New Site and enter a name, then complete the dialog as shown below. Remember to end the Host address with 100 or 101, depending on the type of network connection. The Password is 0000 (four zeros), unless you have changed the default password on the Humax, in which case it is whatever you changed it to.



- Click OK

You should be ready to go. Click the down arrow just below the File menu:



Select the connection you just set up. The connection should open, with the local system on the left and the Humax on the right.

To copy from the local disk to the Humax, first open the folder on the right that you want to copy to, then select the file on the left that you want to copy and either double click it, or right click and select Upload.

Similarly, to copy from the Humax to the local disk, first open the appropriate folder on the local disk, then select the required file on the Humax and either double click or use the context menu.

Remember that the .ts files on the Humax are encrypted. To use them on your PC, you must decrypt them first: there are several threads on this forum explaining how to do this.
 
#6

Black Hole

May contain traces of nut
#7
I've been thinking about that... I'll start a FAQ thread to index the other threads and ask for it to be sticky.

Re the link in my previous post, as I had already replied similarly in another thread I was mobile at the time and unable to insert a link.

Just noticed my Trail Guide has been pinned!
 
#8
@Andy

This is pretty simple but, as usual, there are a few variables to take into account. The instructions below should work, but are not the only way to do the job.

On the Humax

If you connect to your local network via a wired connection:

- Open the main menu. Select Settings - System - Internet Setting - Configure LAN
- Set Configure IP to Manual
- Set IP Address to 192.168.0.101
- Set Gateway Address to 192.168.0.1
- Leave DNS Address unchanged
- Click Apply

This will work for most routers. Some routers may use addresses not in the range 192.168.0.n, in which case the IP Address and Gateway Address will need to be set according to the router's address range. Worry about this only if these instructions don't work!

This will give your Hummy the network address 192.168.0.101. If you have set up a wi-fi connection, you do not need to do the above. Provided the wi-fi connection is working correctly, the Hummy should have a default address of 192.168.0.100.

- Click left to return to the menu
- Select FTP Server. Set to On
- Exit the Menu.

On the PC

- Download FileZilla from here.
- Install it
- Run it
- Click File - Site Manager. You should see this dialog:



- Click New Site and enter a name, then complete the dialog as shown below. Remember to end the Host address with 100 or 101, depending on the type of network connection. The Password is 0000 (four zeros), unless you have changed the default password on the Humax, in which case it is whatever you changed it to.



- Click OK

You should be ready to go. Click the down arrow just below the File menu:



Select the connection you just set up. The connection should open, with the local system on the left and the Humax on the right.

To copy from the local disk to the Humax, first open the folder on the right that you want to copy to, then select the file on the left that you want to copy and either double click it, or right click and select Upload.

Similarly, to copy from the Humax to the local disk, first open the appropriate folder on the local disk, then select the required file on the Humax and either double click or use the context menu.

Remember that the .ts files on the Humax are encrypted. To use them on your PC, you must decrypt them first: there are several threads on this forum explaining how to do this.
I'm new to this, but I just can't get ftp from the hummy to pc to work. Using Homeplug connection between humax and router I can 'ping' the host address and get a relevant reply and I can use the 'portal' for youtube, iplayer, etc. and retrieve files from my pc but, when I use filezilla - with the correct address, password, etc., I get the following messages:

Status: Connecting to 192.168.1.3:21...
Status: Connection established, waiting for welcome message...
Response: 220 Welcome to connection.
Command: USER humaxftp
Response: 331 Password required for humaxftp.
Command: PASS ****
Response: 230 User logged in, proceed.
Command: SYST
Response: 215 UNIX system type.
Command: FEAT
Response: 500 Syntax error, command unrecognized.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/media" is current working dir.
Command: TYPE I
Response: 200 Port command successful
Command: PASV
Response: 502 Command not implemented.
Command: PORT 192,168,1,2,10,101
Response: 200 Port command successful
Command: LIST
Error: Connection timed out
Error: Failed to retrieve directory listing

I'm obviously doing something wrong, but what?
I was hoping to use the ftp facility to backup recordings but this is a no-go at present (before you ask, I have enabled ftp and share).
Sorry this is so long - any help gratefully received!
 

Ezra Pound

Well-Known Member
#9
you can try the built-in FTP package in Windows (File) Explorer by entering into the address bar ftp://10.0.0.200 (using the IP addreess of your Humax box in place of 10.0.0.200) logon name = humaxftp and password = your remote control password default = 0000

 
#10
Thanks Ezra, I've already tried that (and IE & FileCommander......) no response after 'Getting contents of folder message' until 'timeout'. It seems strange, when I 'ping' the address I get 4 packets sent and received, with a round trip of 3ms - 8ms (ave 4ms), so there is communication - just not ftp. I guess I can get round it by copying to usb, just a pity I can't use the network facility.
 

af123

Administrator
Staff member
#12
From the trace you posted it seems your FTP client is trying to use passive mode. The Humax FTP server doesn't support that (unless you install the custom firmware).

Most clients allow you to change to active mode which should work.
 
#14
Thanks for your advice guys - tried disabling the firewall and active mode - still no joy (same messages) and I was aware that the files would still be encrypted- but they were only for backup, I could always play them back on the original m/c. I guess that if I copy to USB I could play the SD files elsewhere, if necessary, as the would be decrypted as part of the process, so there's some benefit there. Maybe I should look at the 'custom' mod.
 

Black Hole

May contain traces of nut
#15
Don't move on to custom software until you have your FTP problem worked out - depending where the problem is it might have an effect on your "user experience"! It can't be that hard.

Being as you have some kind of contact, the network does not seem to be implicated - but to eliminate that you can always temporarily connect your PC to the Humax by a Cat5 cable. Do this while the PC and the Humax are running - if you turn off (and if your router is providing IP addresses by DHCP) they will forget their IP addresses and not have a host to allocate them.

My opinion is that you have an FTP configuration problem at the PC end. However, just double check that you have the FTP service turned on in the Humax Internet settings. Next, download a simple FTP client program (eg FTP Commander or AceFTP) and use that rather than rely on IE or Windows Explorer. Commander worked out-of-the-box for me.

Replicate the step-by-step trail in Black Hole's Trail Guide and let us know what happens.
 

xyz321

Well-Known Member
#16
Thanks for your advice guys - tried disabling the firewall and active mode - still no joy (same messages)
I not entirely sure you mean here. If you are connecting using active mode then you shouldn't see the same messages - the PASV command will no longer be present.
 
#17
Yes, I see what you mean, the messages are:
Status: Connection established, waiting for welcome message...
Response: 220 Welcome to connection.
Command: USER humaxftp
Response: 331 Password required for humaxftp.
Command: PASS ****
Response: 230 User logged in, proceed.
Command: SYST
Response: 215 UNIX system type.
Command: FEAT
Response: 500 Syntax error, command unrecognized.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/media" is current working dir.
Command: TYPE I
Response: 200 Port command successful
Command: PORT 192,168,1,2,8,72
Response: 200 Port command successful
Command: LIST
Error: Connection timed out
Error: Failed to retrieve directory listing

So still no ftp - I presume that the 500 Syntax error means that the 'FEATURES' commandf is unsupported.
 

fenlander

Active Member
#19
I use Filezilla with transfer mode set to 'default'. It does issue the PASV command and connects OK. I'm puzzled by the address to which the client is connecting:

Status: Connecting to 192.168.1.3:21...
Status: Connection established, waiting for welcome message...
Response: 220 Welcome to connection.
Command: USER humaxftp
Response: 331 Password required for humaxftp.
Command: PASS ****
Response: 230 User logged in, proceed.
Command: SYST
Response: 215 UNIX system type.
Command: FEAT
Response: 500 Syntax error, command unrecognized.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/media" is current working dir.
Command: TYPE I
Response: 200 Port command successful
Command: PASV
Response: 502 Command not implemented.
Command: PORT 192,168,1,2,10,101
Response: 200 Port command successful
Command: LIST
Error: Connection timed out
Error: Failed to retrieve directory listing

When I connect to Filezilla, the IP address is the same (192.168.1.5,nn) in both commands. Is this a clue, or is it something to do with the Homeplugs?