EPG button in RS

peterworks

Ye Olde Bowler
No big deal but...
When clicking on the EPG button in RS a box opens with the option to go to Guide or do a search.
Entering text in the search box and clicking on the spyglass does nothing however entering text in the search box and pressing Return initiates the search.
 
OP
peterworks

peterworks

Ye Olde Bowler
I'm using Firefox on Win 7 - is there anything I can check ? (Had a look at the source but it is beyond my pay grade !)
 

MymsMan

Ad detector
If there is any tinkering with the RS menu can I suggest that the EPG button at top left should take you directly to the main EPG menu without the need for a second click on the Guide button.

This would be more consistent with the webif and the small search box is uneeded since there is a perfectly adequate search box on the main RS EPG display.
I know it is not a big deal but it is one of those annoying little inconsistencies
 

af123

Administrator
Staff member
I'll have to boot up my windows system to troubleshoot this one, unless anyone can spot something in the debug console of their browser.
 

af123

Administrator
Staff member
If there is any tinkering with the RS menu can I suggest that the EPG button at top left should take you directly to the main EPG menu without the need for a second click on the Guide button.

This would be more consistent with the webif and the small search box is uneeded since there is a perfectly adequate search box on the main RS EPG display.
I know it is not a big deal but it is one of those annoying little inconsistencies
I won't change the default as I like the way it works at the moment. The original reason for this was because it was relatively expensive to render the EPG page just to run a search and have it replaced by the results - not so much of a problem now that I have upgraded the hosting but in the early days I was charged based on CPU time.

I have added a new option for you on the RS settings page - 'EPG Quick Access'. If you enable that then the EPG button at the top will work in the way that you want (you'll need to refresh the page after updating that setting).
 

MymsMan

Ad detector
I won't change the default as I like the way it works at the moment. The original reason for this was because it was relatively expensive to render the EPG page just to run a search and have it replaced by the results - not so much of a problem now that I have upgraded the hosting but in the early days I was charged based on CPU time.

I have added a new option for you on the RS settings page - 'EPG Quick Access'. If you enable that then the EPG button at the top will work in the way that you want (you'll need to refresh the page after updating that setting).
Thanks
 
OP
peterworks

peterworks

Ye Olde Bowler
Thanks af123 - the magnifying glass button still does not work for me but it is of no concern now (unless you want to progress further)
 

Black Hole

May contain traces of nut
Maybe AF didn't do anything to fix it, and whatever was stopping it working for me has now cleared itself. It worked on iOS too.
 

af123

Administrator
Staff member
Maybe AF didn't do anything to fix it, and whatever was stopping it working for me has now cleared itself. It worked on iOS too.
Yep, I did nothing at all on that fault. I'd like to get to the bottom of it but I can't replicate it on any of my systems, including Windows : (
 
Top