1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EPG not working on WebIF

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Cyberjack, Feb 17, 2012.

  1. Cyberjack

    Cyberjack New Member

    I "upgraded" my HDR-T2 successfully.

    Now I'm facing this problem:

    >>> Contents of /var/log/epgd.log 413.00 bytes
    epgd: DB time 1329480421, last 0
    epgd: Regenerating.
    Section header magic mismatch.
    00000000: 28 47 71 87 00 00 00 00 02 00 00 00 00 00 00 14 (Gq.............
    00000010: 00 00 00 00 50 f0 0f 2c 27 fb 00 48 01 4a 20 28 ....P..,'..H.J (
    00000020: 00 50 71 30 0c 54 55 55 28 47 71 87 00 00 00 00 .Pq0.TUU(Gq.....
    00000030: 02 00 00 00 00 00 00 14 00 00 00 00 50 f0 0f 2c ............P..,
    epgd: Done in 0 seconds.

    The EPG is not working from the WebIF, it just stays empty.​
    Any hints?
    M.
     
  2. af123

    af123 Administrator Staff Member

    Interesting, your EPG data that has been retrieved from the broadcast stream by your Humax and then stored on disk has a slightly different format to the one that the code is expecting. I've never seen this reported before so I wonder if the broadcast stream has changed or whether there is something about your local transmitter - do you know which transmitter you are on? You can check the region from the web interface via the channel info link at the bottom of the main page.

    I will update the EPG code to take account of this different format and upload a new package this evening.
     
  3. Cyberjack

    Cyberjack New Member

    There changed nothing on the transmitter ;)

    I'm located on the continent, most western part of Austria near Lake Constance.

    The EPG format is the "standard" DVB-T one used here by the local broadcasters (Austria, Gemany & Switzerland)

    Do you have an idea how i can get the png files into /img/channels?

    Because of this:

    [1329480801] [error] [client 192.168.1.112] GET /img/channels/PULS 4.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/3SAT.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ORF SPORT +.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ServusTV.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ORF III.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ZDF.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/3sat.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ZDFinfo.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/neo/KiKA.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ORF1.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ORF2 T.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ATV.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/ORF2 V.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/SF 1.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/SF zwei.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/SF info.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/TSR1.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/RSI LA 1.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/Bayerisches FS.png: Error 404: Not Found
    [1329480801] [error] [client 192.168.1.112] GET /img/channels/hr-fernsehen.png: Error 404: N
     
  4. af123

    af123 Administrator Staff Member

    That would explain it; I haven't tested the code with non-UK data! : )

    Can you send me a copy of the epg.dat file from your Humax disk and I'll see if I can make the EPG parser work with it. You can retrieve the file via FTP if you install the betaftpd package and then log in to it as root with the PIN as your password (defaults to 0000). Email it to my forum username @hummypkg.org.uk.

    If you have suitable images then just upload them to the Humax using FTP and place them in /mod/var/mongoose/html/img/channels/

    If you don't have images, then you could download the blank one (blank.png) and then send it back up with each of the new names.
     
  5. Cyberjack

    Cyberjack New Member

    Hmm, I installed the betaftpd package rebooted and still can't log on (Port 21?)

    My FTP Client (Cyberduck on Mac) says "Login failed, need account for login".

    Maybe because of

    Starting betaftpd...
    An FTP Server is already running, not starting betaftpd.
    Done.

    WTF?

    EDIT: Bummer :rolleyes: Had to switch off built-in FTP first ...

    M.
     
  6. Cyberjack

    Cyberjack New Member

    Might be a dumb question but in which folder is the epg.dat file?

    M.
     
  7. mcquaim

    mcquaim Member

    Hi folks,

    Is the epg.dat only used for the Web-If?

    If the Web-If can successfully store EPG data from multiple regions/countries could the EPG on the receiver be made to look at this epg.dat file also to successfully populate the EPG screen?
     
  8. af123

    af123 Administrator Staff Member

    Not dumb, I meant to put it in the post!

    /mnt/hd1/dvbepg/epg.dat
     
  9. af123

    af123 Administrator Staff Member

    No, it's the cache file that is created and maintained by the Humax software.
     
  10. mcquaim

    mcquaim Member

    Any way to modify the Humax software?
     
  11. Cyberjack

    Cyberjack New Member

    @ af123:

    Sent you epg.dat and my channel.db via e-mail.

    Already put the .png's to the directory and they're working :)

    M.
     
  12. af123

    af123 Administrator Staff Member

    If you upgrade the epg package on your box, the EPG should start working in the web interface.
    The EPG data is very similar to that in the UK so it was fairly easy to add support.
     
    Cyberjack likes this.
  13. Cyberjack

    Cyberjack New Member

    Great, working, Thank you!

    One minor glitch:

    Is it possible to add somewhere an GMT offset? I can set that in the T2 itself but the EPG data is retreived in GMT, regardless the GMT+1 setting in the T2.

    Another question:

    Is it possible to force-update the EPG from the WebIF? ATM I see only the EPG from the mux received on booting the T2. Even with switching channels the EPG won't change.

    M.
     
  14. Ezra Pound

    Ezra Pound Well-Known Member

    EDIT :
    Sorry raised in error.
    Just another feeble attempt at pushing up my post count
     
  15. af123

    af123 Administrator Staff Member

    The timezone is set in /mod/etc/init.d/S01mongoose

    You'll need to update that file - this line:

    Code:
    export TZ=GMT+0BST,M3.5.0/1,M10.5.0/2
    
     
  16. James

    James Member

    Yes, use a hex editor - please feel free to try if you wish to (however it may well be illegal where ever you are in the world :) )
     
    af123 likes this.
  17. Cyberjack

    Cyberjack New Member

    That'll do it fine, thanks a lot again.

    M.
     
  18. frollic

    frollic New Member

    Sorry for bumping an old thread, but I'm having the same issue, and it seems mongoose ignores the TZ setting completely :(

    EDIT, got it to work using:

    TZ=GMT-1BST,M3.5.0/1,M10.5.0/2

    (for Sweden)