1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ethernet/LAN - Laptop/Humax Connection (Trouble At Mill)

Discussion in 'HDR-FOX T2 Freeview Recorder' started by ukayjohn, Aug 16, 2012.

  1. ukayjohn

    ukayjohn Member

    Ports and cable working fine, when I fire up Laptop/Humax and attempt to connect, the Humax is shown as an unidentified network/public network and troubleshooting my connection to it, (where the yellow exclamation mark sits between the two) returns the message

    'local area connection does not have a valid IP configuration'.

    Found these whilst trying to determine Laptop IP

    autoconfiguration ipv4 169.254.43.86
    ipv4 subnet mask 255.255.0.0

    I'm assuming (probably wrongly) that once this is fixed I can manually set the Laptop & Humax's IP/Netmask to access the custom firmware/web-if interface that's awaiting me on the Hummy's HDD.


    Any ideas on how to resolve this problem chaps?!.

    TIA

    UKJ.
     
  2. Black Hole

    Black Hole Felinos Guru

    Need a lot more info. The Windows warning is possibly because the Humax is not on the right subnet to be recognised as part of your local network. Is there a router in the middle? Have you got the Humax set to DHCP or have you configured the IP settings manually - or have you left them in their default state but manual instead of DHCP???

    If you want us to check what you are doing you need to post the output from Menu >> Settings >> System >> Internet Setting >> Configure LAN, and the output from your PC: Run >> cmd >> ipconfig.
     
  3. ukayjohn

    ukayjohn Member

    No Router, just crossover cable between the two. humax lan settings on default, no point touching them until IP config issue resolved I reckon. They are as follows,

    Configure IP DHCP
    IP Adress 192.0.2.100
    Netmask 255.255.255.0
    Gateway Address 0.0.0.0
    DNS Address 0.0.0.0
    Will supply ipconfig details later.
    Thanks Again,
    UKJ.
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    your laptop appears to have an IP address of 169.254.43.86 while your Humax is on 192.0.2.100, If you change your Laptop to something like 192.0.2.102 they will then be on the same 'network'
     
  5. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Because there is no DHCP server involved you need to set the two ends to be on the same subnet so either manually set the PC to 192.0.2.101 or the Humax to 169.254.43.200
     
  6. Black Hole

    Black Hole Felinos Guru

    Probably easiest to change the Humax, and switch "DHCP" to "Manual" (no good without a router to act as a DHCP server).
     
  7. xyz321

    xyz321 Well-Known Member

    That's a bit odd, it should come up with a 169.254.X.X IP address if set to DHCP with no DHCP server present.
     
  8. Gavarnos

    Gavarnos New Member

    It'll also do that if the DHCP server pool has ran out of addresses to provide because theres either not enough provided, combined with the lease time being too long and no MAC addresses have been reserved. In recent years with all the IP devices in the home it's getting more and more common.

    Have you enabled ics (internet connection sharing) on the laptop?
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    In this setup there is no DHCP server
     
  10. ukayjohn

    ukayjohn Member

    Thanks for the info, will try out suggestions and let you know the outcome!. Sounds straightforward enough, but I am running Windows 7!.

    UKJ.
     
  11. ukayjohn

    ukayjohn Member

    All working, marvellous! now I have a clock I can read without being down a mineshaft at midnight...