ffmpeg Utility


I have recently installed the custom firmware and several packages which have really opened up the Hummy's versatility - well done to everyone involved in developing these packages.

I have a question regarding the ffmeg utility. I have installed this yet every recording I select will not allow me to convert. The following options are all greyed out:

Extract Audio
Extract to MPG

Am I doing something wrong here? I have reset my HDR but to no avail. Any help would be appreciated.:confused:
Items from the menu will be greyed out if something they are dependant is missing, in this case it is probably the DLNA logo, See the flow chart HERE. This logo indicates that the Humax has allocated the recording a DLNA URL e.g. which is required by quite a few CF packages, the two items required for the Humax to provide this URL is Content Share = On (See flow chart Notes) and time, e.g. the Humax takes some time to do this. You can check on the status of the DNLA server in the Web-If e.g. Diagnostics >> DLNA server
Thanks for the response, Ezra. I have, however, solved my problem and it is really rather obvious (he says with embarrassment!). I just needed to decrypt the file first. :oops:
SandyMac : not sure what you are referring to when you state DLNA logo
It looks like this DLNA-small.jpg and is the logo next to the DLNA note in the flow chart, the idea is that by checking the logos in the flow chart you can see what steps need to be taken to get files in an un-encrypted state onto your P.C. or in your case get 'greyed out' items to work. The logos appear next to recordings in the Web-If >> Browser screen.
In your case you needed the DEC3.jpg logo
not sure what you are referring to when you state DLNA logo

The DLNA logo is a round green blob (see Wiki for a list of all the WebIF icons). It denotes that a recording has been indexed by the DLNA server, which is a pre-requisite for decryption (which is itself a pre-requisite for the other operations as you have discovered). Unfortunately DLNA indexing can be delayed quite some time after the recording completes, nothing we can do about that.

For information, these operations require Menu >> Settings >> System >> Internet Setting >> Content Sharing = On.
Thanks, guys, for such prompt answers. I've always had content sharing on as have been using it as a DLNA server since new. The logo was always there, just needed to decrypt which was so obvious I didn't even think of it :)
I am having a similar problem. The 'Extract to MPG' option is greyed out as is 'Crop' and 'Split'. However 'Extract Audio' is not. I have checked the files and the green 'Indexed by DLNA' and 'Dec' logos are in place so I'm now at a loss. Any ideas please?
I think I may just have found the answer to my own question. Extract to MPG appears when working with an SD file - I was trying to extract a Hidef file.
Am I right in thinking this can't be done? And if so, how do I do this instead?
Correct. The extract to mpg works because the StDef broadcast stream contains a suitable format to be simply repackaged from the .TS container to a .mpg container - no video or audio processing required (which would be too much for the Humax processing capability to handle). HiDef broadcast streams (H.264 video, AAC audio) are not in a suitable format.

Your only option is to transfer the recording (decrypted) to a PC and play with it there.
Thanks for that. At the risk of pushing my luck, is there a faster way of transferring files to my pc other than copying to an hdd via the USB port?
Have you tried the WebIF download option? Alternatively there is FTP, or if you install the samba package you will be able to "see" the Humax as a network drive from your PC. It is horses for courses though - copying to USB is an off-line operation not involving your PC, and HiDef files are going to take a while whichever way you do it.

Make sure whichever operation you choose includes decryption somewhere in the chain (ie pre-decryption in the case of FTP or network access). See Things Every... (click) section 5 and the links from there.
Thanks again, Black Hole.

I have tried using the download option on WebIF but I've no idea what it is doing. When I try this, all I get is blank browser window appearing an no indication of whether anything is actually happening or what to do next. As for FTP'ing I had discounted that as I'm sure I read that you could FTP files to a Fox T2 but not from it. I'll give it a go though.
If you are using FireFox Ver 21 to do the Download, they have replaced the download 'window' with a very small download icon., See link HERE
Well FTP'ing seems to be working very well so I think I'll stick to that. I am using Firefox Ver21 so I'll check downloading again once these files have FTP'ed.
I'll also have a look at samba out of curiousity :)
I'm sure I read that you could FTP files to a Fox T2 but not from it.
That's only because the files extracted would remain encrypted without custom firmware facilities or a copy to USB first (with Foxy for HiDef*). Files can also be FTPed from the USB drive.

* Non-custom users can decrypt HiDef most easily by FTP extraction of the .hmt file to PC, tweak it with Foxy, put it back by FTP, and then copy the recording to USB in the normal way.
BTW: if the programme you require is available on iPlayer, select the HD feed and start playing it (never mind stutters if your broadband isn't fast enough). Pause the playback if you like and use the WebIF to monitor download progress (status at the bottom of the media browser page) - do not switch the Humax away from the (paused) programme until the status says the buffer has stopped growing. How long this takes depends on the speed of your connection - it could be slower than real time, or quicker.

You will then be able to save the buffer to a file, which will be the complete programme (as downloaded) in MP4 format.