Fix-disk can't find inode.

I suspect some symptoms I'm suffering on my HDR are down to a corrupt hard disk (choppy playback on recordings, inconsistent chase play).

I'm running CF 2.15. Running the Hard Disk Diag screen via Webif shows a couple of errors. "Current pending sector" and "offline uncorrectable". The short self test lines also show a consistent LBA error.

I've booted into maintenance mode, this is where the troubles start. Running fix-disk starts fine and it locates the same error as the Webif Diag. It then says the sector is in use and starts searching for the inode. It is this search that times out and the fix-disk appears to halt. (Pic attached)

Any pointers would be great, I'd love to be able to watch my recordings again!

Thanks!
 

Attachments

  • image.jpg
    image.jpg
    140.6 KB · Views: 17

xyz321

Well-Known Member
Looking at the pic. it doesn't show any evidence of having timed out. It may take a while to first find the inode using that block and then to find the file using the inode. Take a note of the filename because it will be corrupt. You may wish to delete it or if it owned by one of the packages then the package can be reinstalled.

If it is still searching for the inode after a hour or two then please post back.
 
OP
F

freestyle_gus

Member
Sorry, the time out message is just below the line of the keyboard.

It takes about 8 minutes to time out. I've tried a handful of times and the result is the same.
 

af123

Administrator
Staff member
Glad you have managed to sort it. I think the timeout message is something to do with your telnet client.
 
Top