Fixdisk help please


Hello All,

I have just got a new (to me) HDR Fox T2 to replace my ailing unit. I've loaded the latest custom firmware and noted that there were some minor issues with the HDD, so tried to run fixdisk.

I ran fixdisk without any options, and it first ran a short disk test and said that the LBA has not yet been found and asked to run a long test. This I did but at the end it said "Error - pending sectors but LBA not found", "fix-disk: session terminated with exit status 1".

Please select option: fixdisk                                                                                                                                                 
Any additional options (-h for list or press return for none):                                                                                                               
Are you sure you wish to run the hard disk checker? [Y/N] y                                                                                                                   
Running /bin/fix-disk                                                                                                                                                         
Checking disk sda (512 byte sectors)                                                                                                                                         
Unmounted /dev/sda1                                                                                                                                                           
Unmounted /dev/sda2                                                                                                                                                           
Unmounted /dev/sda3                                                                                                                                                           
Running short disk self test                                                                                                                                                 

Pending sector error(s) found                                                                                                                                                 
LBA has not yet been found                                                                                                                                                   
A long test is required - this could take 1 hour(s) 50 minutes                                                                                                               
Do you wish to continue? [Y/N]: y                                                                                                                                             
Running long disk self test                                                                                                                                                   

Error - pending sectors but LBA not found                                                                                                                                     
fix-disk: session terminated with exit status 1
Any thoughts on what this means?


Have just found a similar problem in an earlier thread here and am running fixdisk with the -P option. Seems to have lots of issues to clean up and is still running. The HDD runs fine, records and plays back with no issues, so will continue to use it until it becomes a real problem.