Folder mismatch bug - DLNA?

DanP

New Member
Hi

Tried to search the forum, but came up empty handed.
I am experience a bug in the software for the HD T2 based on 1.02.32 firmaware
no custom software as of yet.
To describe it as a programmer would....
it appears that the software parses the DLNA folder structure or gets a list from a DLNA server.
this list however is not the one that is then used for the GUI. difference might be music, video, pictures
who knows. something is interlaced that is partly removed making the lists different. Somehow the T2 gets the selections made in the GUI wrong because of this.
So standing on one folder and selecting that folder sends me to a folder that is two entries erlier in the list.

ie i want to go into folder 5, but the humax sends me to folder 3.
standing on 4 gets me into 2 etc
movies selected in the top folder are selected correctly.
anybody else experienced something like this?
The DLNA server works correctly for other clients on my network so don't think it is the DLNA server.
it could be caching, since i have recently added folders that might not have been pushed out...hmm but not in this level.

hmm it works on the video level but not selecting browse folders on the top level
DLNA-server-video-browse folder - works correct (folders missing because of pending refresh?)
DLNAserver-browse folder- does not work.

might not be a humax problem per se but a DLNA quirk with how it refresh media.

ho hum, perhaps the above will help someone else not to feel so lost....or alone
 

Black Hole

May contain traces of nut
Ermmmm....

The HD-FOX doesn't have a DLNA server, so I imagine you're talking HDR-FOX?

DLNA is a bit strange. The structure you navigate from a client device is a database created within the server itself, and not the actual folder structure on disk (which is what you see with the TV menus). If you move stuff around on disk, it takes a while for the DLNA index to catch up.

Something you might try to resolve the issue is to purge the database and let it build a new one. I'm not sure how one would go about that without custom firmware though.
 
OP
D

DanP

New Member
I was referring to the client part of the HD -T2.
the server is a NAS unit that i have. I think it is best to tell the NAS to rebuild the DLNA structure...it is supposed to do that automagically ...but....
strange that other clients does not exhibit this behavior.
Was hoping for more from the DLNA client in the Humax...but it really appears to be minimal implementation...so it might not have had that much effort spent on it.
 

Black Hole

May contain traces of nut
Fair enough, but your post only made sense to me if it was referring to the server on an HDR. If the GUI you are referring to is the Media list (via the Network option) on the Humax menus, what you see is just what the server is sending in response to a request for the content of any particular directory level. You only see movie or music or photo files according to which you select (yellow button).

I don't see how the Humax client could be getting it wrong if other devices see it OK - are you sure they are using DLNA and not Wndows File Sharing or something (the NAS is probably capable of multiple protocols)?
 
OP
D

DanP

New Member
After a couple of hours of refresh, the DLNA server is back online and ...problem gone. So the issue was? down to the way the DLNA server worked not humax HD-T2. 20 files to update and 24hours was apparently not enough time for the server....

sorry, humax....HD-T2
 
Top