Foxsat HDR USB2 And ethernet port


New Member
hi all,

I have a pretty new Foxsat with a couple of issues I hope somebody can shed light on:

I discovered it would only accept a flash update on a USB stick less than 1Gb. I thought that was strange but I had a spare small memory stick and they do mention it in the manual.

Then I tried to use the USB port to transfer some media and got the 'media wrong format not EXT3/FAT16/FAT32' message on a 4Gb flash card and on an external drive.

Does anybody know if the external media size limitation applies to all the Freesat boxes? I hoped it may have just been for reflash, but my box does not like any media size >1Gb.

My second problem is the box Ethernet is not recognised in my router 'devices connected' table (when I am inside the router setup). All my other devices, PCs, printers and my Humax HDR-FOX-T2 show their MAC addresses when connected. The green led is lit, but I think that is no more than a power or ground indicator for a connected link.

There isn't a 1GB limit, Humax merely recommend a small stick, I use the same 8GB stick for updates with all my Humax pvrs (they can be picky about some chipsets). To see the box on your network you need to install the Custom Firmware (see the CF thread on AV forums). Without this the internet connection only provides vod services like iplayer.
Thanks, I'm beginning to think the 'A' grade box has a problem. Yes I understand about the network server as I just went through the custom route on my Freview box. But this Freesat box does not even offer up an IP address, just the DHCP option or manual entry and as I said, my router does not see the connection and I suspect neither could I Telnet since the screen just shows its MAC and no IP address. I am reluctant to go the custom firware route at the mo. as it is so new. I can at least expect it to have a presence on the Internet which it does not seem to. On the Freeview box there's a check button to enable Internet but I see no option here.

If yours works ok and it seems the same as my Freeview box, then either there is something stupid in setup I missed or a fault. I have been through the reset to factory default and the annoying postcode and scan thingy a couple of times, but nothing has changed.
Thanks, I am away a few days and will come back on my post, but I have some interim findings to help others.:

It would appear that my two identical 4Gb USB2 flash stick can be read in my new Freeview T2 but one is unreadable (says it is wrong format!) in the Freesat box. Now I thought all these problems which I had with early flash memory in cameras had been worked around by manufacturers of more recent products. I am thinking some of the design in the Freesat boxes may be a little behind.

I borrowed 'several' USB flash sticks between 1Gb and 16 Gbyte, All worked in the Freeview box and TWO failed to be recognised as formatted sticks in the Freesat box. All the flash sticks could be read and written to from Windows and all were FAT32 4K clusters.

The two that did not work in the box had both been reformatted under XP, which had no problems with them. But this used to happen in cameras. I took an identical 4Gb drive that worked, copied the image sector for sector on to a non-working 4Gb flash the same make and they both worked ok. Tried reformatting under XP and it broke the drive.

Then I dug out my HP .exe utility for re-formatting broken flash and Bingo! I could reformat it and it worked in the Freesat box. What I have not tried is re-formatting the flash drive under Linux which should be DOS free (?).

So that is half the problem solved. The Freesat boxes unlike the Freeview boxes are not so happy with USB2 flash drives formatted using Bill Gates Format utilites and anybody with a seemingly 'broken' flash drive needs to know it probably is not broken. Just the hummy box not wanting to be compatble with it.