1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP downloaded standard def films won't play on PC

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by michael.h, Oct 19, 2011.

  1. michael.h

    michael.h Member

    Until the software was updated to ver. HDR-FOX T2 1.02.20 all files downloaded played without any problem using Gom player, and or VLC player.


    Since the update:
    Gom player reports that the files are either .tp and .trp video format.
    VLC Player Just sits there and does nothing!


    I am using Filezilla as my FTP client with the following settings:
    Name: HDR-Fox T2
    FTP Server: 192.168.1.120
    FTP Port: 21
    User ID: humaxftp
    Password: 0000
    Passive Mode: NO I have tried both Active & Default modes:bye:
     
  2. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Can I just check that you have removed the encryption before using FTP?
     
  3. Black Hole

    Black Hole Ron Glum

    There's a load of missing information from the post.

    Before you updated to 1.02.20, how were you decrypting the recordings you downloaded? If you were using FTP, you must have been copying the recordings to a USB drive to decrypt them first, and then (assuming you are not running the modified software) copy them back again to be available for FTP. If you were running the MSP, there was no need to use FTP and copy-decrypt, because the web interface provides a download option which decrypts on the fly.

    Now you have updated, have you forgotten what you used to do? If you were using the MSP at any stage, do you realise that updating the standard firmware means you must then load the modified firmware (the correct version for the update) again?
     
  4. michael.h

    michael.h Member

    I had no need to decrypt as I will not be able to receive HiDef until June 2012, however, I did try using Foxy but it made no difference.
    What is MSP? Attempted a search but was informed "keywords were too short, too long, or too common"
    The USB port fails to recognise any HDD. I am using HDD formatted to FAT32.
     
  5. af123

    af123 Administrator Staff Member

    The Humax encrypts all content, even SD. The FTP server doesn't decrypt on the fly so I'm not sure what you were doing previously.

    MSP is Black Hole's acronym for Modified Software Project, aka customised firmware.
     
  6. 4291

    4291 Well-Known Member

    Modified Software Project (also known as "Custom Firmware") - This is the term I have coined to encompass the beaverings of the BYTs. In very brief summary: a few small additions to the standard firmware in the Humax allow additional program code to be installed on the hard drive and executed as part of the day-to-day operational environment, creating a rich set of additional facilities (for example: web browser access to the files and EPG; ability to download StDef and HiDef recordings in the clear; external drives in NTFS format... etc). The additions to the standard firmware are applied by installing a fake firmware update file from a USB drive or stick, and removing them again is as simple as re-updating with the original Humax firmware. With the firmware additions in place, a minimal web interface becomes available and the full suite of software additions can be downloaded and installed from there.

    Extracted from Black Hole's Glossary of terms.
     
  7. Black Hole

    Black Hole Ron Glum

    Wrong!

    To begin at the beginning...

    The pinned topics at the top of the forum listing provide you with a primer - read those, and you will know what you need to know not to commit any blunders.

    The Trail Guide introduces the concepts, the Glossary is an encyclopedia, the Index provides useful forum references... and the Wiki (link at the top of every screen) provides the manual.

    What do you mean "any HDD"? How many have you tried? I've not had a failure yet, although it has rejected a few USB sticks.
     
  8. michael.h

    michael.h Member

    Thank you all for pointing me in the right direction.:)
    I have successfully installed HDR_FOX_T2_1.02.20_mod_1.12_upgrade.hdf.
    I have downloaded auto-unprotect_1.0.3_mipsel.opk but after several hours of reading have failed to find any instructions for installing it on the Hummy.
     
  9. af123

    af123 Administrator Staff Member

    Does your Humax have access to the Internet? if so, you can use the web interface that is built into the custom firmware to download a more complete web interface, from which you can manage packages and install auto unprotect.

    Alternatively, rename the downloaded auto-unprotect package to auto-unprotect_1.0.3_mipsel.opk.auto and place it on a USB HDD. Plug the HDD into the Humax while it is turned on and wait a moment or two. Then unplug the stick again and check it for a log file which will show you the results of the package installation.
     
  10. Black Hole

    Black Hole Ron Glum

    Connect your HDR-FOX to your home network, then access it from your web browser as described in the Trail Guide. Then everything will become clear.
     
  11. michael.h

    michael.h Member

    Thanks folks for all the help. I now have the following installed and web access works well.:)

    auto-unprotect 1.0.3
    busybox 1.18.3-1
    cifs 2.6.18
    dropbear-ssh 0.53.1
    epg 1.0.7
    hmt 1.0.8
    inotify-tools 3.14
    jim 0.71-1
    jim-cgi 0.4
    jim-oo 0.71
    jim-pack 0.71
    jim-sqlite3 0.71-1
    libevent 2.0.11
    libutil 0.9.29
    lsof 4.82 LiSt
    mediatomb 0.11.
    mongoose 3.0-2
    samba 2.2.12-2
    service-control 1.0
    sqlite3 3.7.6
    ssmtp 2.64
    transmission 2.22-1
    virtual-disk 1.1
    webif 0.7.7
    webif-epgkeywords 1.0.1

    I have now found a problem i.e. Std Def files copied to the virtual disk do not get decrypted.
    any ideas?
     
  12. af123

    af123 Administrator Staff Member

    As long as you copy them using the remote control then they should be. Is that what you're doing?
     
  13. michael.h

    michael.h Member

    No I was using windows explorer.
     
  14. Black Hole

    Black Hole Ron Glum

    If you want a decrypted file copied to your PC, the easiest way is to use the Media Browser on the web interface, click the OPT+ button along side the programme you are interested in, and select "download". The download decrypts on the fly.

    Incidentally, this doesn't work for me (something to do with my IE8 configuration) - if it doesn't work for you, I can give you another way to do it.
     
  15. fenlander

    fenlander Active Member

    I've found this to be by far the quickest and simplest way to export a file. I have long since removed virtual-disk. Remember that to use the webif/OPT+ download you must have media sharing turned ON on the Humax.