1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP occasionally failing

Discussion in 'HDR-FOX T2 Freeview Recorder' started by jack616, Dec 5, 2011.

  1. jack616

    jack616 Member

    Has anyone else had any issues with FTP from the HDR-Fox T2 to a PC?

    I'm using filezilla on a Vista machine and every so often an FTP transfer will stop part way and tell
    me the file already exists and would I like to overwrite/rename etc?

    What seems to happen is the file partially transfers then stops itself and tries to start again and then
    transfers a shortened file anyway.

    I've checked out everything I can and cant get it to do this if I do a PC to PC transfer. It only seems
    to happen from the box. I'm guessing maybe 2 in every 30 times.

    I have tried powering down and deleting and re-installing packages with no luck.
     
  2. Black Hole

    Black Hole Ron Glum

    What size of files are you dealing with?
     
  3. fenlander

    fenlander Active Member

    And what is the format of the disk you're copying to?
     
  4. jack616

    jack616 Member

    Hi

    File sizes - usually between 2-8GB - the last one was just under 4GB
    Drive format is NTFS Vista 32 box or NTFS Win7-64 box
    It isnt anything to do with file limits or drive space.
    It seems totally random as far as I can tell.

    If I delete the partial file and start it again it then transfers fine.

    The Humax is connected via ethernet through a netgear router into the Dell laptop
    Nothing else is on the router (appart from the internet cable connection of course)
    I've checked the router settings and it has no odd blocks or anything happening.
    There are no related firewall settings I can find. The router WiFi is off.
    I've tried a CAT5 & CAT6 cable
    I've had the same issue with and without HDMI in use from the box (I used to just use the composite outputs)
    I've kept the firmware mod packages up to date.
    The Humax drive is usually only half full or less (which is why I use FTP in the first place)
    I dont do anything else (like copying etc) with the box while transfering

    It isnt the end of the world but I'm puzzled by it and out of ideas.
     
  5. Black Hole

    Black Hole Ron Glum

    All I can think of is if you are hitting another 32-bit implementation limit, which would be petty obvious if all transfers failed after the same number of bytes (4GB, or some other repeatable pattern).

    Other than that - we all know Vista isn't very stable, but you've had the same on Win7.
     
  6. fenlander

    fenlander Active Member

    I've never seen anything like that - FZ has always been 100% reliable for me, even if both the Hummy and the PC (yeah, Vista!) are multi-tasking during transfers. I'd suggest setting logging on in FZ's settings - it might provide some clues next time it happens. Failing that, I'd try a different client, purely in the interests of eliminating one variable from the equation.

    As an alternative, have you tried using a samba share instead of FTP?
     
  7. jack616

    jack616 Member

    Fair enough - I just thought I'd put it out there just in case

    I'll give another FTP program a go and see what happens.
    Thanks anyway.
     
  8. jack616

    jack616 Member

    Just an FYI post:

    OK I've tried this over the xmas break and can confirm there is an issue somewhere. I'm just not sure where.
    This applies to my configuration at least:

    If I am transfering a file to a laptop via my router (wired) and select the "menu" on the HRD-Fox T2 then change channel
    "often" (not always) it will truncate the file and and the FTP application will request an overwrite/rename etc. on the stub

    I've been able to make it do this a few times now.
    I'm convinced there is an issue perhaps relating to multi-tasking or processor loading or something.
    The "tiny FTP" client behaves the same as filezilla.

    If you get this - to avoid the issue just don't do FTP and ask the box to do anything that may also load it .
    I never have any issues if I leave it just FTP'ing and doing nothing else with it even when it transfers
    more than 1 file at once.
    For info my FTP setup is transfering 10MB /s or 2x 5MB if that should be relevant to anything.
     
  9. Black Hole

    Black Hole Ron Glum

    Perhaps somebody can try to replicate this.