FTP problems


I can get into my Humax using various FTP programs, but, surprisingly, not with my favourite FTP program.

I am using a Mac, (OS 10.12 Sierra) and like ForkLift. FTP works fine on ForkLift 2, but not on ForkLift 3. ForkLift 3 just reports

The item can't be opened.
502 Command not implemented.

Any suggestions as to getting ForkLift 3 to work. I have reported this to the developers, but they don't seem to have done anything about it. I don't expect Humax to do anything, especially as other FTP programs work fine. It would be interesting to know why there is a problem, and if there is a decent work-around, other than using a different program.
Install the customised firmware and the betaftpd package. The stock FTP server is 5h!t3.
Your client might be as well though, but it's difficult to tell without knowing exactly which command it's issuing that causes the error it doesn't like.
I'm probably not understanding fully. I have installed the betaftp, and turned off the Humax FTP.

I tried to connect (username humaxftp, password 0000) to the server 5h!t3, and got Connection timed out.

I note that one FTP program I tried objects to the ! (exclamation) in the name. Is that possibly due to a transcription error in my browser
I'm probably not understanding fully.
You’re right there, that was a “whoosh” moment (the sound of something sailing over somebody’s head).

You need to connect your FTP client to the HDR’s IP address. “5h!t3” was a comment on the Humax native FTP server’s reliability.

It’s a glutton for punishment who insists on using a particular piece of software that isn’t working when they have other software available that does work, but if you want to continue in your purgatory try tweaking the settings - such as passive transfer mode instead of active.
Yes, that was really over my head.

Not a glutton for punishment, but since ForkLift 2 has been superseded by ForkLift 3, there's too much of a chance that it will stop working on an OS upgrade, I'ld rather use a program that is still in active development.

And in fact ForkLift 3 does work with the betaftp, so many thanks.