Full web-if install fail - error


New Member
I have pored over your forum/wiki guides today and have just done the custom install (need to rectify the delete loop). I have just tried to download and complete the full web interface and it has failed with the following error - which is different to error on the wiki - I am no techy but can follow instructions. I tried installing first via chrome (forgot to switch to IE) then via IE but it failed both times. Error message summarised below due to inability/new member rules to post links
Message below, any help gratefully received:

Downloading /hummypkg[dot]org[dot]uk/hdrfoxt2/base/Packages.gz.
Collected errors:
* make_directory: Cannot create directory `/mod/var/opkg/info': Read-only file system.
* opkg_download: Failed to download /hummypkg[dot]org[dot]uk/hdrfoxt2/base/Packages.gz, wget returned 1.
* rm_r: Failed to open dir : No such file or directory.

Error retrieving package list from the Internet. Please check your connection
and try again.
You do not need to perform the full installation to correct the delete loop. The difficulties are probably because of the disk problem.

With just custom firmware 2.16 (or later) loaded by USB, connect to the Telnet menu as per the Wiki instructions HERE (click). At the first menu, select "1" (reboot into maintenance mode), then when the system restarts connect to the Telnet menu again and choose "fix disk". You will be asked if you need to fix the delete loop.
Yes, the difficulties are certainly due to the pre-existing disk fault. The filesystem is read-only due to errors which should be correctable by following Black Hole's instructions above. Once the disk is fixed, you can proceed to install the rest of the customised firmware if you wish.
Tried the above and was not asked if i needed to fix the delete loop...ran the fix-disk and received the following log about blocks:
Please select option: 1
Any additional options (or press return for none):
Are you sure you wish to run the hard disk checker? [Y/N] y
Running /bin/fix-disk
Custom firmware version 2.16

Checking disk sda

Using superblock 0 on sda3
Using superblock 0 on sda1
Using superblock 0 on sda2

Unmounted /dev/sda1
Unmounted /dev/sda2
Unmounted /dev/sda3

Running short disk self test
Error at LBA 752360648
Dev: /dev/sda LBA: 752360648
LBA: 752360648 is on partition /dev/sda2, start: 2104515, bad sector offset: 750 256133
dumpe2fs 1.41.14 (22-Dec-2010)
Using superblock 0
Block size: 4096
LBA 752360648 maps to file system block 93782016 on /dev/sda2

Checking to see if this block is in use...
debugfs 1.41.14 (22-Dec-2010)
/dev/sda2: Can't read an block bitmap while reading block bitmap
testb: Filesystem not open
Unknown error

Press return to continue:
Try running the disk repair process again, and when it asks ' Any additional options (or press return for none):' then type
followed by pressing return - that's minus capital P.

That should at least allow the filesystem checks to run. You may still have a pending sector on your hard disk afterwards but we can help you with that later.
Well it took a really long time and there's still about 42% of sda2 that has problems but the rest is fine and the delete loop seems to have been fixed. Thanks for your help, much appreciated