Full web interface


New Member
I'm having problems installing Full Web Interface. I had upgraded to custom firmware. I am definitely connected to the Internet. When I connect with my browser to the box I get the "custom firmware successfully installed" message. I then click on the "download and install full web interface" button and it shows a "please wait" message for at least 15 mins with nothing else happening. any ideas?
When you say "definitely connected to the Internet", does the TV Portal work?

(By the way, this should be in the Custom Firmware section of the forum... a moderator will move it soon)
Yes, TV portal fully functional. It has since partially worked but now when I link with a browser to the box I get a directory listing and no further downloads are occurring
I've seen the directory listing thing before. I think I fixed it by reinstalling the official firmware, then installing the appropriate version of the CF again to get back to the 'download full web interface' step.

EDIT: BH beat me to it!
no, didn't work. reinstalled the official version, checked that I no longer could connect, then reinstalled 2.19 but I still see the directory listing. any other ideas?
telnet into the box, choose the 'cli' option from the menu and type the following:
diag remove_mod_yes_i_am_sure
Then try to reinstall from the web interface.
unfortunately I can't telnet onto it. I assume that software wasn't copied onto it. I suppose I could reset the box and reformat the HDD but that seems a little drastic as I will lose recordings so if anyone has any other idea I would be very grateful!
If you can get back to the "custom firmware successfully installed" message." you should be able to Telnet into your Humax at this stage
Bullguard firewall was preventing access. have now removed as suggested by Ezra Pound and I'm now downloading again. Fingers crossed
So having been round the houses yesterday with various problems (some self-inflicted) I am back at the beginning today. My overall conclusion now is that when I click "download ... full web interface" the process gets stuck at random places. it sometimes gets further than others but never completes. during this "please wait" phase everything else seems to work. the TV can still connect to TV portal, my laptop still has normal internet connection. is there any way of performing the download via USB perhaps. Anyway I'm back to being stuck. Any further ideas?
Now that you have telnet access, get to the command line and try the web interface installation from there.

humax# opkg update
humax# opkg install webif

Just the bits after the #, humax prompt shown for context.

You can also install from USB but the above should give you more feedback on the download process.
gets as far as a message saying "downloading ... webif_1.0.7-5_mipse1.opk" and then stalls
gets as far as a message saying "downloading ... webif_1.0.7-5_mipse1.opk" and then stalls

I had the same or similar problem with the second HDR Fox T2 I recently got (hanging whilst waiting to download an opk, including attempts to install the first full Webif, although it did work eventually). It would also often do the same when trying to install add-on packages.

I don’t think there has been a problem since I gave it a static IP address and also made sure that the name configured into the router was the same as it is configured to use internally (the default is probably "humax")- I have no idea if this is relevant or a coincidence as I didn’t investigate the problem.

Or it could be some problem with access to the repository (where the opks are stored on the net); in which case try again later?
Einstein's definition of madness is repeating the same action and expecting a different outcome. However, even Einstein was wrong sometimes. After countless attempts it suddenly announced that it was finished and it now works. Thanks all for help. I wish I could add some knowledge as to what the problem was and how it got fixed but I really do think it was shear bloody mindedness.
It smells like some kind of network problem be that cables, router, firewall, ISP, ...

Glad it's working though!