Hard drive errors

RobJW

New Member
Hi all

After getting grief for the last few days from the family for scheduled programmes not recording and "*deleting" being permanently displayed, and following the instructions on this site I have just done a Maintenance Mode Disc Check. The results of which are below. This is way above my level of IT competence, so is anyone able to tell me if the problems have been fixed, and if not is there anything else I can do or do I need to think about replacing my hard drive. It looks to me like there was a bad block (whatever that may be), it has been fixed, but there is something still not right.

Many thanks

Code:
      /---------------------------------------------\
      |  M A I N T E N A N C E   M O D E   M E N U  |
      \---------------------------------------------/

  [ Humax HDR-Fox T2 (humax) 1.02.32/3.10 ]

  Note: Some areas of the hard disk are not mounted.
        Not all functions will be available.
        (normal if you have just run a disk check)

fixdisk - Check and repair hard disk.
   short - Run short hard-disk self test.
    long - Run long hard-disk self test.
   check - Check self-test progress.
    gptf - Re-format disk using GPT scheme.
     epg - Clear persistent EPG data.
    dlna - Reset DLNA server database.
       x - Leave maintenance mode (Humax will restart).
    diag - Run a diagnostic.
     cli - System command line (advanced users).

Please select option: fixdisk
Any additional options (or press return for none):
Are you sure you wish to run the hard disk checker? [Y/N] y
Running /bin/fix-disk
Custom firmware version 3.10


Checking disk sda (512 byte sectors)

Partition /dev/sda1 is already unmounted
Partition /dev/sda2 is already unmounted
Partition /dev/sda3 is already unmounted


Running short disk self test
Error at LBA 1906580676
Do you wish to attempt repair of the bad block? [Y/N]: y

/dev/sda:
re-writing sector 1906580676: succeeded

Running short disk self test

No pending sectors found - skipping sector repair

Checking partition tables...

MBR Status: MBR only
GPT Status: not present

Using superblock 0 on sda1
Using superblock 0 on sda2
Using superblock 0 on sda3
Dev: /dev/sda LBA: 1906580676
LBA: 1906580676 is on partition /dev/sda2, start: 2104515, bad sector offset: 1904476161
dumpe2fs 1.42.13 (17-May-2015)
Using superblock 0
Block size: 4096
LBA 1906580676 maps to file system block 238059520 on /dev/sda2

Checking to see if this block is in use...
debugfs 1.42.13 (17-May-2015)
/dev/sda2: Can't read a block bitmap while reading block bitmap
testb: Filesystem not open
Unknown error
 
Last edited:

prpr

Well-Known Member
What version of CF are you running?
Run the disk check again and use CODE tags for listings.
Check the WebIf SMART data for the disk on the Diag page.
Oh, and post in the correct section of the forum!
 

Black Hole

May contain traces of nut
Should be in the Customised Firmware section of the forum, the section you originally posted in is for discussion of aspects that affect unmodified HDR-FOX (but a moderator will move this when they notice).

Please also be aware of posting conventions: see Newbies' Guide to the Forum (click), particularly the section "Code Listings and Terminal Output".
 
OP
R

RobJW

New Member
Attached are the hard disk attributes and logs from the diag page after the dskfix was run.

Does this help?
 

Attachments

  • attrib.JPG
    attrib.JPG
    153.9 KB · Views: 16
  • logs.JPG
    logs.JPG
    41.6 KB · Views: 14
Last edited:

Owen Smith

Active Member
Some of the filing systems were not mounted before you started fixdisk, and it looks like it didn't check them as a result hence the error you got at the end. I don't know how to sort it out though.
 
Top