1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HD-FOX T2: No System Clock Without Aerial Feed - TV Portal Problem

Discussion in 'HD-FOX T2 Freeview Receiver' started by Black Hole, Nov 4, 2011.

  1. Black Hole

    Black Hole Ron Glum

    Now the trouble I was having accessing iPlayer (via the TV Portal) have been pinned down on the system clock not being set up after a cold start (see THIS TOPIC - click), I have started this topic to classify it under a descriptive title.

    Summary:

    I have been using an HD-FOX T2 as a stand-alone streaming client for my HDR-FOX, with the expectation that it would also provide access to iPlayer. However, every time I tried to access the TV Portal I received an on-screen report "An error has occurred accessing...".

    This was eventually tracked down to the HD-FOX (and presumably also the HDR-FOX) setting up the internal system time from the EPG data received from the aerial. Without an aerial feed, the box doesn't know what the date/time is, so cannot negotiate the authentication handshake with the Humax TV Portal service on the Internet.

    The date/time can be set up manually using a Telnet session (needs the CF installed but not the full MSP), and once set up it appears to be maintained as long as the box is on or in stand-by, but loses it over an exetended period of power down (disconnected from the mains).

    Note that this will be an extremely rare circumstance - specifically when cold-starting without an aerial connection in the manner that I wish to do (sigh).

    The CF can provide a fix - there is the possibility of fetching system time from an Internet time server (as far as I know there are NO circumstances which would demand system time when you have neither an aerial nor an Internet connection). I await with baited breath!
     
  2. Black Hole

    Black Hole Ron Glum

    Update: The CF has indeed provided the fix, in the form of ntpclient - a utility to set the system clock from the Internet.
     
  3. Black Hole

    Black Hole Ron Glum

    [The following was as a result of the Custom Software forum section being set up, and a tidy-up moving topics out of the HD-FOX and HDR-FOX sections to the new section]

    I don't agree this topic should have been moved. The work-around may be incorporated in the CF, but the problem is intrinsic to the unmodified HD-FOX.
     
  4. Brian

    Brian Administrator Staff Member

    OK, no problem I'll move it back.:rolleyes:
     
  5. Black Hole

    Black Hole Ron Glum

    Something a little odd occurred - noted here in case anyone else sees the same thing and we can build up the observations and get a bearing on it.

    I had the HD-FOX running into the Qumi last night, HD-FOX has been on warm standby lately so although the ntpclient fix sorted out the system-clock-from-cold problem it should have maintained the clock in standby anyway. As I recall, the screensaver showed the correct time.

    However, to give the Qumi time to warm up and come into focus before actually viewing, I had fired up and gone away for a bit. When I came to actually play something, I found I had the HDMI no-audio problem and executed a hard reset to restore it (button under the flap). I then dozed off catching up on some time-shift TV. This morning the screen saver clock showed 00:00:00, and not incrementing.

    Fearing the worst, I tried the TV Portal - but it still worked! That is the odd part. I draw these provisional conclusions, pending confirmation:

    1. The system clock and the screen saver clock are not the same thing.

    2. Performing a hard reset does not update the screen saver clock from the system clock.

    3. TV Portal negotiation is based on the system clock, not the source of the screen saver clock.

    New information: as an experiment, I did a warm start and sure enough the screen saver showed the correct time. I then performed a reset, and the screen saver went to 00:00:00 not running. Then I tried to cycle through stand-by to a warm start, and had a series of lock-ups but eventually got up and running with the screen saver clock incrementing but approx 00:10:00 - ie having reset and started some time while I was trying to get it booted. I was called away before I had chance to test the TV Portal.

    I believe this last state indicates the system clock had reset and not been updated by ntpclient, and that if I had tested the portal it would not have worked.
     
  6. Black Hole

    Black Hole Ron Glum

    Note also that the i-plate date/time display remains resolutely set at 1970 throughout - suggesting that this is based on live EPG data rather than any system time.
     
  7. LesButler

    LesButler New Member

    I'm new to this but have amazingly managed to get the customised firmware and web interface up and running.

    Portal was working fine, but I moved box to bedroom to connect to tv (no aerial) to watch some recorded stuff. Now on returning to living room and connecting aerial the Portal is failing to load - I sometimes get that error message, other times not, it just shows a blank screen. I have checked internet is connected ok. Telnet is working so I can still boot the HDR firmware and uncrypt files ok.

    My TV is an LG internet model, so I can access iPlayer, etc via that, so I'm not too bothered about The HD-Fox T2 Portal problem - still, would be nice if I can get it fixed. I have read your other thread, does my problem sound like it might be something to do with system clock. The EPG and time on front of box are showing correctly. Thanks.

    Les.
     
  8. Black Hole

    Black Hole Ron Glum

    If you have an aerial connected I don't think this can be the same problem. More likely to be a network issue. As long as the screen-saver clock is showing the right time (unplug the aerial and the HD-FOX will get fed up telling you "there is no signal" in a few minutes), I have never known the TV Portal to fail because of system time.
     
  9. LesButler

    LesButler New Member

    I checked the screen saver and its showing the correct time, as is front of box. I checked that the ethernet cable is ok by plugging into tv, and trying four other router ports. Internet is confirmed in the box settings and IP address, etc is showing ok.

    What happens when I try to get to the portal is a box shows 'connecting' but disappears leaving just the tv channel showing full screen.

    No idea what problem is. I guess I could reinstall original firmware and then reinstall mod and web interface, but maybe that won't get portal back? Also, can't connect to web portal interface. I have Telnet connection to box and can decrypt recordings ok, so that's the main thing.
     
  10. Black Hole

    Black Hole Ron Glum

    It sounds like the far end isn't responding for some reason. I'm going to redirect this to a more appropriate thread HERE (click), which I think also suggests some pings to try.
     
  11. Black Hole

    Black Hole Ron Glum

    I'm still having trouble with ntpclient (see relevant topic).

    For the record (and my easy reference), the manual method for setting the clock via Telnet is:

    Code:
    humax# /mod/bin/busybox/busybox date yyyy.mm.dd-hh:mm
    humax# /etc/init.d/S90settop restart
    Update: The "/mod/bin/busybox/busybox" prefix to the "date" command above was only necessary because I had the custom software installed on a FAT32 UPD, which does not support the necessary symbolic links for the OS to automatically locate the "date" command. With my UPD converted to Ext2 (recommended), "date yyyy.mm.dd-hh:mm" is sufficient. Further, the restart command is not necessary for the TV Portal to run once the system time is set.
     
  12. LesButler

    LesButler New Member

    Thanks, I'll have a read through that thread and try setting clock via Telnet later today.
     
  13. Black Hole

    Black Hole Ron Glum

    Breaking news: my system clock did not survive stand-by overnight, and this morning setting it via date / restart did not get the TV Portal up! I tried a hard reset and date (no restart - I've noticed you don't need one if you get in soon enough, before the box first drops into screen-saver) and now I have iPlayer again.

    Suspicions: Don't know what killed the system clock in warm stand-by, could be that I have Power Saving turned on and I've been lucky at other times. I have now turned it off.

    More news: the time on the i-plate is now current, as far as I can remember the first time I've seen that. I think that might be because I got the date command in soon after reset.
     
  14. Martin Roddam

    Martin Roddam New Member

    One question - what on Earth are Humax doing to fix this? Any suggestions from them yet? I bought an HD-FOX-T2 purely to play back recordings from the HDR and access iPlayer, but thanks to this I can't get the system time, or use the TV Portal.
     
  15. Brian

    Brian Administrator Staff Member

    Probably nothing, as I can't see many people being affected by this. Just connect an aerial to your HD-FOX T2, and use it as it was intended.:)
     
  16. Black Hole

    Black Hole Ron Glum

    ntpclient is working very well for me. I'm more concerned about Humax fixing the 4GB streaming limit bug, for which we have no work-around other than to decrypt the source files, mount the HDR-FOX drive as a network share, and then play the file "locally".
     
  17. Black Hole

    Black Hole Ron Glum

    Correction - it isn't, but I will take that up on the custom software forum (see relevant topic).