HD-FOX upgrade problem - disk permissions?

MontysEvilTwin

Well-Known Member
I thought I'd upgrade my HD-FOX to 1.02.31/ CFW 3.00. It had not been used for a while and was on 1.02.29/ CFW 2.21. It seemed to go fine, but in package management. I could not list or update the packages. I eventually downgraded to 1.02.29 vanilla, then back up to 1.02.31/ CFW 2.23 but the problem persisted. I moved the 'mod' folder into a temporary folder and upgraded to CFW 3.00. I had to reinstall Web-If and packages etc. and deleted the old 'mod' folder but all seemed well. Later I got a crash, but found only two log files listed (auto and crash) and could not clear the crash log. I also could not run the fix flash packages diagnostic from within Web-If, though it worked from Telnet. I ran 'fix-webif' from Telnet. This worked but the problem persists. I have also found that I can't copy files into the 'mod' file, using FTP (logged in as root). It seems like some of the file permissions are messed up. Is there a way of globally resetting the file permissions to default using Telnet? If I am barking up the wrong tree, does anyone have a different solution?
 
OP
MontysEvilTwin

MontysEvilTwin

Well-Known Member
Eventually I ran the RMA procedure, installed 1.02.29 then 1.02.31/ CFW 3.00. It seems OK now, but there are some issues in the Diagnostics section of Web-If. The only log file listed is 'auto' and running diagnostics by typing the name, or selecting from the drop-down menu does not seem to work. Diagnostics run fine though using Telnet, so it seems like a problem with Web-If. Is this a bug, or is my installation still faulty? Could someone with this version on the HD-FOX confirm this as a bug or otherwise?
 
OP
MontysEvilTwin

MontysEvilTwin

Well-Known Member
It is not a bug. In the end I had to reformat the USB drive and reinstall Web-If and packages etc. to get everything running correctly.
@af123: there were some recordings on the hard drive I wanted to keep. Ideally I would have just deleted everything else but the recordings and then reinstalled. However, I could not delete all components in the 'mod' folder and had to format to remove the files. Is there a way to alter the file permissions to allow deletion? It would also be nice, say if you wanted to switch from a USB stick to a USB hard drive, to just be able to copy everything from the stick to the hard drive and plug the latter in. I presume it is also file permissions that prevents this.?
 

af123

Administrator
Staff member
It won't be related to file permissions as everything on the Humax runs as super-user.
The mod folder at the top level is just a link to the real mod folder which is on the drive, so you can just copy /media/drive1/mod/ to the new stick/drive.
 
Top