Help - HDR locking up playing back mp4

Would really appreciate some help from the wise heads here. Last night I had a problem playing an mp4 video - the box put up the "Processing ...." banner and then wouldn't respond to the remote. I could reboot it from the web interface. I tried a couple more files including re-converting a couple. Same result. Then I tried ones that had played perfectly before and pretty much the same result - although one did play, just I couldn't then stop it or get any response from the remote. Wondering about disk corruption, I tried some files from a NAS box running minidlna on OpenMediaVault - same result - even on files that have previously played from the NAS. Thinking there must be something wrong with the box, I deleted all the custom firmware, re-installed the Humax 29 software and tried again - same result. Reset to factory settings (no customised software) - same result etc.

After a lightbulb moment with people commenting about Twonky and other media servers, I switched off the NAS box and bingo - no more issues - files played again, even the ones that hadn't yesterday. Turning the NAS box back on - problem re-appears. Turned off the DLNA server on the NAS - problem still there with the NAS on.

Does anyone know what is going on, as I would like to have the nas on and be able to play the files either on the humax box or on the NAS.

I'm now going through the process of putting the customised firmware back on the box.


PS Spoke too soon. Even with the NAS box off, the Humax is still locking up playing some mp4 files. So there is still something going on. I am now trying with the Content Share (ie dlna server off on the Humax box).
The only solution to the Twonky problem (apart from turning off Content Share on the Humax) is to replace Twonky Ver 7 with Twonky Ver6
Thanks Ezra.

Exceptionally weird. I tried playing the files from the NAS on the HD Fox and it's playing fine. So I've gone back to the HDR and its now playing fine again!!! The only recent thing I did was re-scan the media .

Overnight I ran the fix-disk from telnet in maintenance mode, and nothing strange there. I'm running badblocks -vv /dev/sda as well, just in case. When testing yesterday, it was freezing on audio files as well as video files. Something going wrong in the mp4 decoder? It seems to play sometimes and not others. Could there be any corruption on the box related to playing a codec? I tried playing a video off the NAS and it still had problems, so it rules out file corruption at source as the issue.

Any ideas anyone? Raydon/af123?/xyz321?

You're exploring new territory. As far as I can recall we've not seen a report of this before (except where something else on the network causes a crash).

Have you done a complete shut-down, power off, and restart from cold?
Yes. When I removed the custom firmware, the only way (when you're impatient like me! - I didn't wait more than five minutes to see if it came back) was to power off with the switch. As I say, I lose all response from the remote and from the front buttons...

After the badblocks has run, I'll do another power off and cold boot.

The reason I suggested a cold start is that sometimes hardware has an initialisation process independent of software. The only thing that would trigger initialisation is a full power off (reboot via WebIF would not be enough).

Not waiting 30 secs after standby means the box does not complete it's shutdown procedure, which may include not programming the next wake up into the clock module.
Thanks, BH, but eliminated that with several full cold starts.

Now the box is locking up (as in not responding to the remote or the front buttons) when just left on. :(

Any ideas, anyone?

Will look at top when it next freezes ( shouldn't be too long now!) - by freezes, I mean becomes unresponsive to the remote. Web/telnet is still OK and programme still carries on playing.....

Top of the list for top when it had stopped responding was unsurprisingly the humaxtv process, followed by scanmounts. So I have removed networkshares-automount and issued a soft (web) reboot. Next up is the mongoose service.

After the soft reboot, response to remote OK again, then went to look at the portal and it's stuck again..... :(

Latest capture of top:
 Mem: 116064K used, 8920K free, 0K shrd, 37948K buff, 36276K cached
CPU:  74% usr  20% sys  0% nic  3% idle  1% io  0% irq  0% sirq
Load average: 2.70 1.69 0.84 5/174 1960
  174  158 root    S    366m 300%  50% /usr/bin/humaxtv
1027  1026 root    S <  2632  2%  10% {auto} /mod/bin/jimsh /mod/webif/lib/b
  733  725 root    R    1352  1%  0% top
  135    1 root    S      816  1%  0% /sbin/utelnetd -l /var/lib/humaxtv_bac
  504    1 root    S <  12392  10%  0% /mod/sbin/mongoose /mod/etc/mongoose.c
  560    1 root    S <  2920  2%  0% /mod/sbin/smbd -D
  561    1 root    S <  1864  1%  0% /mod/sbin/nmbd -D
  534    1 root    S <  1652  1%  0% /mod/bin/epg -f /media/drive1/epgsaved
  497    1 root    S <  1368  1%  0% /mod/sbin/crond
  586  135 root    S    1264  1%  0% {tmenu} /bin/sh /var/lib/humaxtv_backu
  158    27 root    S    1252  1%  0% {S90settop} /bin/sh /etc/init.d/S90set
    1    0 root    S    1248  1%  0% init
  725  586 root    S    1248  1%  0% /bin/sh -l
  27    1 root    S    1244  1%  0% {rcS} /bin/sh /etc/init.d/rcS
1026  497 root    S <  1240  1%  0% /bin/sh -c /mod/webif/lib/bin/auto >>
1959  1027 root    R <  1112  1%  0% /mod/bin/lsof
1960  1959 root    S <  1060  1%  0% /mod/bin/lsof
  661    1 root    S <  1056  1%  0% /mod/sbin/auto-unprotectd -d /mnt/hd2/
  128    1 nobody  S      932  1%  0% /usr/bin/dnsmasq
  521    1 daemon  S <    824  1%  0% /mod/sbin/portmap

Well, an update.

My 2Tb disk had arrived, so after posting the above, I thought it would be good to have a go at installing that, following in af123's footsteps...

However, after a couple of hours struggling with gfdisk and fdisk and getting wierd problems, I gave up and went to bed pretty dejected. Taking the disk to work the following day, I tested it in another machine and found that it was a bad disk and wouldn't format properly - badblocks -vv quickly gave ATA DMA errors! Not having much luck, then.

I duly returned the disk the following day, and by Friday, thought I've nothing to lose putting the old disk back in the machine, which I did. It turned on fine, ran for a few hours and still responded to the remote! Strange. Left it for another day, and tested it for more hours - still responding to the remote like it should. Tried one of the previously problematic files and no problem playing the file! No freezing/lockups whatever. Problem seems to have fixed itself.

Whether there was some corruption that needed unplugging (left for a few days) to fix, I don't know, but it seems to be working fine again now.

When the new disk comes back, I'm going to check it in another machine before going through the hassle of taking the Humax box apart again....

So a happy but perplexed bunny!

The Humax will have seen a different disk ID, so perhaps something has been reset. Plugging the same drive in again (without another in between) would not have been a different ID.
Interesting thought. Not sure why it would be linked to the problem of no response to the remote/front buttons, but then neither should unplugging have been any more effective than switching off, unless there was residual capacitance keeping nvram alive and not refreshing properly on boot up....