Hidden Recordings

Fumar Sid

New Member
Hi all, (sorry for the title)

I have an unconventional setup which was working fine prior to the recent Humax/CF update, but now seems to display some very eratic behavior.

I have a HD-Linux satellite reciever (MK Digital XP1000) running Enigma 2. I have mounted a CIFS share on my Humax which I have been using for recordings from the XP1000. This setup works fine for me, I don't need an additional storage device as my Humax is always On and I can view recording on both stb's (there are some issues when watching multi language programs or films with NAR), but I would normaly watch any recordings via the stb they were recorded from.

The problem I am having now, is that although the recordings are taking place and are visible in the directory on the Humax, my XP1000 can't see them. They are hidden. They also don't show up in tuxbox from the XP1000 but show up from filezilla on my PC (W7). I should add that sometimes it works as before and it dosen't seem to mater whether its FTA, Encryted or HD.

Now I'm not suggesting that there is a problem with the CF, just asking if you might know what would cause this.
 

Black Hole

May contain traces of nut
FileZilla is FTP I believe.

Can I confirm: you are definitely accessing recordings using a network mount (hence must be running some method of decryption) rather than as a DLNA client?
 
OP
Fumar Sid

Fumar Sid

New Member
Hi BH,

both Humax and XP1000 (192.168.1.3) are wired to my router (192.168.1.1).

Path from XP1000 to Humax /media/net/MediaHUMAX/My Video/XP1FILES

Mounted

Local share name MediaHUMAX
Mount type CIFS share
Server IP 192.168.1.4 (Humax)
Server share Media
Mount options RW
Username username
Password password

If you want I can make up some screen grabs
 
OP
Fumar Sid

Fumar Sid

New Member
This is what it should do when working correct. Also this is a test recording small clips from different channels to rule out any issues on the XP1000 side
 

Attachments

  • screenshot_2013-02-23_22-49-18.png
    screenshot_2013-02-23_22-49-18.png
    401.5 KB · Views: 22
OP
Fumar Sid

Fumar Sid

New Member
Update.

I have done a little test by recording a segment of a movie that is being braodcast (satellite) in Europe in SD & HD. I can watch a see the SD recording happening as above (red-dot) however the HD channel does not show as above although I can see it via FTP (filezilla).

I have no such problem when recording direct to usb attached to the XP1000. Just find it strange that the Humax is taking control of external recording stored on its hdd.
 

Black Hole

May contain traces of nut
So you are using the network-mounted HDR-FOX internal drive as the recording medium for the XP1000???

The network mount is performed at the operating system / file system level, so it is unlikely the specific humaxtv process is getting in the way of that. The DLNA indexer (if turned on) is probably getting confused though!

I'm inclined to think this is to do with the XP1000 not the HDR-FOX.
 
OP
Fumar Sid

Fumar Sid

New Member
Thanks again for your help. Yes I'm uising the HDR-FOX-T2 internal drive as storage. The XP1000 has usb which works fine for storage albeit limited. 8gb at the moment.

DLNA Indexer ? do I need it switched on?

In my head I'm having this thought that the Humax is doing some sort of DRM filtering, even though in this case it only being as storage.

Now if I ftp the "ts" file with or without the associated file's from the Humax to the USB on the XP1000 they work as normal.

TBH and getting back to the original question. Why are the files being hidden ? and more to the point what would cause a file to get hidden.

ps I can access/see all the local recordings on the Humax from the XP1000.

Re the XP1000 firmware "OpenPli 3.0" I had a chat with them on their forum and they seem to think its something associated with the Humax.
 

Black Hole

May contain traces of nut
DLNA Indexer ? do I need it switched on?

Only if you want to stream content by DLNA (which includes decryption-in-place): Menu >> Settings >> System >> Internet Setting >> Content Share = On

In my head I'm having this thought that the Humax is doing some sort of DRM filtering, even though in this case it only being as storage.

I don't see how it can be, the CIFS network server is accessing the file system directly through the operating system without any interference from the Humax-specific software.

TBH and getting back to the original question. Why are the files being hidden ? and more to the point what would cause a file to get hidden.

Exactly - which is why I point at the XP1000.

Re the XP1000 firmware "OpenPli 3.0" I had a chat with them on their forum and they seem to think its something associated with the Humax.

We have a stand-off then :)
 
OP
Fumar Sid

Fumar Sid

New Member
Thanks for your help BH, most appriciated.

I now know that is not just a simple setting change that is required.

I'll have play later with older images on the xp1000 first, they do nightly builds and I update quite regularly.

DNLA?, dont use it, so will switch it off. Thanks
CIFS good to know.

Stand Off? not yet :)

Thanks again
 

Black Hole

May contain traces of nut
Oops, I omitted essential info... if you want to access HDR recordings from the network, you need Content Share = On to support decryption-in-place (I have edited the previous post).
 
Top