1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I change the MTU (Maximum Transmission Unit) on my HDR-Fox T2?

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Norm.D, Apr 19, 2012.

  1. Norm.D

    Norm.D New Member

    I need to change the MTU (Maximum Transmission Unit) in the Humax to 1400 or lower, as my ISP is TalkTalk and their MTU limit seems to be 1400. Anyone know how to do this on the HDR-Fox T2?

    I will also (first) need to install WebIF and its associated packages offline, as any fix for the MTU will presumably require this to be installed first, so I would be grateful if anyone can point me to a clickable list of all the associated packages that have to be installed in order, or a bundle that will do it offline in one go.

    For those who haven't a clue what I'm talking about or why I might want to do this, here is the background to the problem:

    I recently bought a Humax HDR-Fox T2, updated to lastest firmware (1.02.27 + mod.2.10 customised) and tried to install WebIF via the basic web interface. Nothing seemed to happen for a while, so I tried refreshing the page, and got the following error message, which will be familiar to some of you:

    Collected errors:
    * opkg_conf_load: Could not lock /tmp/opkg.lock: Resource temporarily unavailable.
    Error retrieving package list from the Internet. Please check your connection and try again.

    I tried again repeatedly, after soft and hard resets, but got the same error message each time I refreshed the page whenever it seemed to hang. I checked the forum for this problem - and found that it was only due to an attempt to re-run the action while the previous action was still in process.

    So I decided to restart again, and let the download process run for a while. It made a little progress after about 20 minutes, downloading and inflating the hummypkg.org.uk/hdrfoxt2/base/Packages.gz package, which is only about 10kb. It then began downloading the installation package for WebIF, but then it seemed to hang. However, my router lights showed that the Humax was communicating with the web, so I let it continue, while trying to figure out what might be slowing it down. The basic WebIF page updated instantly in my browser whenever I refreshed it, so I figured the difficulty was not with my local network.

    Then I realised what the problem was. It was the internal MTU setting in the Humax. Each time I buy an internet device (PC, laptop, etc.) I have to change the MTU for the network connection to the internet, to 1400 or less, or the net connection slows to a crawl, and often fails to work entirely. But it had been so long since I did this last, that I had forgotten about the problem.

    So.... any ideas? Can I change the MTU via the WebIF, once I have installed the full WebIF? And what is the easiest way to install the WebIF offline? I'm not a Linux expert, and so far, have only ever had to change the MTU on various flavours of Microsoft Windows.

    Any advice most welcome!

    Norm
     
  2. Black Hole

    Black Hole Felinos Guru

    This seems very strange. Anybody else on TalkTalk?

    It is possible to install packages from USB, I believe the Wiki has the details. I would be inclined to get to the bottom of the TalkTalk problem though - I don't think it should be an issue.
     
  3. af123

    af123 Administrator Staff Member

    If you telnet to the Humax then type this at the command line, that will temporarily change the MTU and allow you to install the web interface in the normal way.

    Code:
    humax# ifconfig eth0 mtu 1400
    
    The humax# bit is shown for context and the interface name is eth0 - the last character is a zero.

    I'll have a look to see what the best way to do this permanently is.

    Talk Talk must not support MTU discovery for some reason!
     
  4. af123

    af123 Administrator Staff Member

    To make the change permanent, install a startup script like this:

    Code:
    humax# echo ifconfig eth0 mtu 1400 > /mod/etc/init.d/S22mtu
    humax# chmod 755 /mod/etc/init.d/S22mtu
    
    then that will be run every time the system is booted.
     
  5. Ezra Pound

    Ezra Pound Well-Known Member

    I have added this to the WiKi HERE, I have broadband from Talk-Talk (Used to be Tiscali) and have not fould I need this MTU fix, However If I ever do need it, I now have the fix - Thanks
    EDIT
    Some background Talk-Talk info. HERE
     
  6. Black Hole

    Black Hole Felinos Guru

    So it sounds like the proper solution is to configure the router properly rather than the Humax.
     
  7. af123

    af123 Administrator Staff Member

    Yes. What should usually happen is that the sending host on the network (the Humax here) would perform path MTU detection by sending packets with the do-not-fragment bit set and a router along the path would respond with an ICMP error. The Humax would automatically lower the MTU until the error was no longer returned, thus determining the correct MTU.

    If that isn't working for some reason then the local router would be required to fragment all large packets which would increase load on it - maybe enough to noticeably degrade performance.
     
  8. Black Hole

    Black Hole Felinos Guru