How do you change your network group.

David Howarth

New Member
Hi All, How do you change the network group of a hdr t2 to the same as the rest of your network. Be it home or Alfs network or what ever?

Thanks Dave
 

Ezra Pound

Well-Known Member
The Humax doesn't use network groups such as Home. if the base address of your routers is say 192.168.1.1 then it will usually see any device in the numbering range 192.168.1.2 to 192.168.1.254, so if you want to set the Humax up manually rather the using DHCP where the Humax's IP address is allocated by the router automatically, set Menu >> Settings >> System >> internet settings >> Configure LAN as follows:-

Configure IP = Manual
IP address = 192.168.1.10
Netmask = 255.255.255.0
Gateway Address = 192.168.1.1
DNS Address = 192.168.1.1
 
OP
D

David Howarth

New Member
Thanks Ezra
I just wanted to know if there was a simple way to set the humax to the same network as the windows machines instead of having 2 work groups. Just curious thats all

Dave
 

Ezra Pound

Well-Known Member
Work groups are usually associated with Microsoft Windows as far as I'm aware and as your Humax is running Linux work groups don't apply. I have edited #2 to add more detail
 

dragon-it

Member
If you are running samba I presume it will use the one in the file smb.conf, I don't use samba at the mo. to check but from putting it on before theis a config file is listed in

/mnt/hd2/mod/etc/smb.conf



Steve
 

dragon-it

Member
Just re-enabled Samba package and it does appear to still use that config file but no obvious amendment through the web interface settings tab -- you can change in the diagnostics page using "file editor" or through telnet.
 

Black Hole

May contain traces of nut
Hi All, How do you change the network group of a hdr t2 to the same as the rest of your network. Be it home or Alfs network or what ever?

I don't remember needing to set the network group - the Humax (with the samba package installed - you have done that?) just appears in File Explorer (Win7) as a network device.

Are you trying to restrict its access to a specific group?
 

dragon-it

Member
In Windows networking it is normal to keep the workgroup name the same as any other workgroup or domain names, would normally only show computers in your own workgroup/domain in "network neighbourhood". Not sure how current Windows versions actually use it as such, though all mine are the same anyway...
 

raydon

Well-Known Member
I don't remember needing to set the network group - the Humax (with the samba package installed - you have done that?) just appears in File Explorer (Win7) as a network device.
That's because you don't need to to set the network group for Windows 7 unless you have changed it from the default, which on Windows 7 is "WORKGROUP". The samba default configuration file on the T2 has this set to "WORKGROUP" also, to enable it to work "straight out of the box". Computers in the same workgroup must elect one of them to become the "Master Browser" who's duty it is to maintain a list of members of that workgroup, so it is important that the workgroups match for members to be browsable by other members. On the Foxsat HDR there is an entry under the "Settings" page for the workgroup to be defined, as well as the hostname, to facilitate this.
 

Mike0001

Well-Known Member
This is easy on the Foxsat HDR. It's at the top of the Settings page. (Edit: must learn to read posts just above mine.)

I have changed the netbios name for the T2 to something more meaningful than just "Humax."
 

raydon

Well-Known Member
Work groups are usually associated with Microsoft Windows as far as I'm aware and as your Humax is running Linux work groups don't apply. I have edited #2 to add more detail
Sorry Ezra but SMB/CIFs is a Microsoft protocol and if you're running a samba server under linux then it will appear to the Windows workgroup as just another member of the group, (or not if it isn't). If it's not in the group it may not automatically appear under 'Network' although you should still be able to map a network drive providing you specify the share name manually, as you may not be able to browse to it.
 
Top