1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

https

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by black jack, Feb 27, 2012.

  1. black jack

    black jack New Member

    I have been reading this forum for a while now but haven't joined in because I can't hope help in the various projects. I have tried the Custom firmware for sometime now and find it a great editon to the Humax.
    Yesterday I changed the Http to Https in the browser and than lost the connection to the Humax. I have tried various ways to get it back but nothing works. I changed to Https in the address bar, I checked on the Humax to see if the address had changed (which sometimes it as done before), I reloaded the official firmware and the custom firmware again, they all loaded okay. This problem is on both a wired connection and wifi. The Humax is wired connected to the modem via the router. I can still connect by Ftp, so I can access all the files on the Humax that way. Hope one of you smart guys can help me get it back working.
    I have a Humax HDR-FOX T2
     
  2. af123

    af123 Administrator Staff Member

    You should be able to get to the web site just by putting https://<ip address of humax>/ in the address bar.

    Can you retrieve the /tmp/modinit.log file via FTP and see what's in there? You'll only be able to do that if you have the betaftpd package installed and you log into the FTP server as root with your PIN as the password..

    Otherwise you'll need to get in via telnet and run some commands which I can post later when I'm in front of mine..
     
  3. black jack

    black jack New Member

    Thanks for the reply. Tried https//192.168.2.xxx nothing, just Internet Exporer Cannot Display This Page. You are dealing with a novice here so simple instructions please if you have them.
    Is this the File:

    === diag =================================================
    Filesystem Size Used Available Use% Mounted on
    /dev/root 15.6M 15.6M 0 100% /
    tmpfs 61.0M 16.0K 61.0M 0% /tmp
    tmpfs 61.0M 0 61.0M 0% /media
    /dev/mtdblock1 2.0M 496.0K 1.5M 24% /var/lib/humaxtv
    /dev/mtdblock2 2.0M 1.2M 812.0K 60% /var/lib/humaxtv_backup
    /dev/sda1 1011.4M 39.9M 920.2M 4% /mnt/hd1
    /dev/sda2 447.6G 127.8G 297.1G 30% /mnt/hd2
    /dev/sda3 9.8G 775.7M 8.6G 8% /mnt/hd3

    eth0 Link encap:Ethernet HWaddr 00:03:78:BC:6E:CA
    inet addr:192.168.2.3 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:16

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


    PID USER VSZ STAT COMMAND
    1 root 1248 S init
    2 root 0 SW [migration/0]
    3 root 0 SWN [ksoftirqd/0]
    4 root 0 SW [migration/1]
    5 root 0 SWN [ksoftirqd/1]
    6 root 0 SW< [events/0]
    7 root 0 SW< [events/1]
    8 root 0 SW< [khelper]
    9 root 0 SW< [kthread]
    10 root 0 SW< [kblockd/0]
    11 root 0 SW< [kblockd/1]
    12 root 0 SW< [khubd]
    13 root 0 SW< [kseriod]
    14 root 0 SW [pdflush]
    15 root 0 SW [pdflush]
    16 root 0 SW< [kswapd0]
    17 root 0 SW< [aio/0]
    18 root 0 SW< [aio/1]
    19 root 0 SW< [ata/0]
    20 root 0 SW< [ata/1]
    21 root 0 SW< [ata_aux]
    22 root 0 SW< [scsi_eh_0]
    23 root 0 SW< [scsi_eh_1]
    24 root 0 SW [mtdblockd]
    25 root 0 SW< [kpsmoused]
    27 root 1244 S {rcS} /bin/sh /etc/init.d/rcS
    73 root 0 SWN [jffs2_gcd_mtd1]
    74 root 0 SWN [jffs2_gcd_mtd2]
    120 nobody 932 S /usr/bin/dnsmasq
    125 root 812 S /bin/utelnetd -l /bin/sh -p 23 -d
    134 root 1244 S {S90settop} /bin/sh /etc/init.d/S90settop start
    143 root 353m S /usr/bin/humaxtv
    256 root 912 S tinyftp -i HumaxFTP -p 0000 -c /media
    287 root 1244 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    297 root 0 SW< [kjournald]
    305 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    313 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    329 root 0 SW< [kjournald]
    334 root 0 SW< [kjournald]
    336 root 1232 S < sleep 1
    348 root 1232 S < sleep 1
    352 root 1244 S < {modinit} /bin/sh /sbin/modinit
    359 root 1336 R < ps -w
    === setup_directories ====================================
    ln: boot/mod: File exists
    === create_rcS ===========================================
    === setup_hostname =======================================
    === setup_hosts ==========================================
    IP: [192.168.2.3]
    === run_init =============================================
    Loaded CIFS module into kernel.
    Loading config file /mod/etc/mongoose.conf
    Failed to start Mongoose. Maybe some options are assigned bad values?
    Try to run with '-e error_log.txt' and check error_log.txt for more information.
    Anacron 2.3 started on 2012-02-27
    Normal exit (0 jobs run)
    2012-02-27 15:23:31 INFO: Loading configuration from: /mod/mediatomb/config/config.xml
    2012-02-27 15:23:31 INFO: Checking configuration...
    2012-02-27 15:23:31 INFO: Setting filesystem import charset to ASCII
    2012-02-27 15:23:31 INFO: Setting metadata import charset to ASCII
    2012-02-27 15:23:31 INFO: Setting playlist charset to ASCII
    2012-02-27 15:23:31 INFO: Configuration check succeeded.
     
  4. black jack

    black jack New Member

    Forgot to mention all the folders from mod have a ? mark on them.
     
  5. af123

    af123 Administrator Staff Member

    That's the relevant bit - anything in /tmp/mongoose_errors.log?
     
  6. black jack

    black jack New Member

    Got lost a bit in the file branches. Didn't find anything in TMP, only found Mongoose in Var. In there were folders: Mongoose, +cgi-bin, +html, include, lib, plugin portal. I couldn't any error file, but may have missed it.
    Some folders have a ? mark on them.
    Thanks for the help.
     
  7. af123

    af123 Administrator Staff Member

    Telnet into the box so that you get to the humax prompt then type these commands (humax# shown for context, don't type that)

    Code:
    humax# rm /mod/etc/mongoose.conf
    humax# opkg install mongoose --force-reinstall
    
    That should repair it.
     
  8. black jack

    black jack New Member

    Thanks I will try that. Need to put Telnet on computer and figure out how to use it. Seen videos else where on forum. I let you know how I get on.
    Thanks af123.
     
  9. Black Hole

    Black Hole Felonius Gru

  10. black jack

    black jack New Member

    Thanks for all your help af123 and thanks black hole for the info.
    Figured out how to telnet and used Putty. seen it used on the video on this site.
    Did what you said and it said something about an error but it worked fine. It's all back to normal now.

    Very grateful, Cheers.:)