Humax DLNA disappears

Following some problems with internet access that Black Hole helped me resolve (thanks again), my DLNA servers now either disappear or don't appear.

The initial problem was after a firmware upgrade, it seems my modem/router (Archer D7) got confused and prevented my two HDRs from connecting. This was solved after I accessed one of the HDRs directly.

Although I can access via Webif and the TV Portal, now the Humax DLNA servers either do not appear, or if they can only be seen for a short while (10 minutes-ish) after everything is reset and/or power cycled. But I can see my NAS DLNA server and any other devices that connect to the network. Webif diag says that the DLNA servers are running.

Also, if I disconnect one Humax from the modem/router and connect it to the other one (via powerline adapters) they can see each other for a short while.

I have disconnected the NAS to see if that is interfering and changed to my old modem/router that everything previously worked ok with. The same problems are present.

I have also tried a factory reset of the HDRs. Turning content sharing off and back on again. Resetting the DLNA.

Any suggestions on what to try next?

Archer D7 router/modem
Synology DS212j NAS
Two Humax HDR-Fox t2
One connected by Tp link AV500 power line adapters the other by cat 5 Ethernet cable
I've no idea if or how DLNA handles name clashes, but it might be worth installing the dlna-servername package on your HDRs and set them to unique names.
DLNA doesn't care about name clashes (or at least the Humax clients don't) - two servers with the same name just appear in the list as two instances with the same name. Presumably the client can distinguish them by IP address or something behind the scenes.
Also, I already had dlna-servername installed etc. I will be trying out the solutions suggested in the tp article linked above this evening (I work away from home a few nights a week).

Thanks again to this forum for the help and suggestions of what you can do with your Humax.